Abandoned Add-ons - Need Maintainers - Open to Anyone

Discussion and development of scenarios and campaigns for the game.

Moderator: Forum Moderators

Post Reply
User avatar
Lord-Knightmare
Forum Regular
Posts: 1207
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Lord-Knightmare »

Wayirr wrote: October 26th, 2020, 12:21 am Somebody has uploaded version of Age of Tentacles 0.9.0 to 1.14 addon server, who wasn't me.
But judging by diff it's older than what I have on my computer, even though my latest version was 0.8.x.
My latest change was in Sep 25 2017

If, whoever it was, was coming from this topic, why they didn't contact me first? And I would like to know if they have any plans to maintain and expand the addon or not.
If your add-on was hijacked, I suggest contacting one of the moderators or admins of the add-on server to restore your ownership.
Wayirr
Posts: 86
Joined: February 11th, 2012, 3:42 pm

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Wayirr »

If your add-on was hijacked, I suggest contacting one of the moderators or admins of the add-on server to restore your ownership.
It's kinda my fault that I did not update it on the addon server for a while and somebody though that it was abandoned, so I wanted to contact whoever it was first directly.

P.S. Somebody has removed the addon, whenever it was a moderator or original uploader, I do not know. I have uploaded my version now.
User avatar
egallager
Posts: 35
Joined: November 19th, 2020, 7:27 pm
Location: Concord, New Hampshire
Contact:

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by egallager »

I recently took over "A Little Adventure" (which was abandoned) and am now working on porting "Saving Elensefar", "The Earth's Gut" from 1.12 to 1.14, and also intend to port "The Unstoppable Legion" and "The War of Terrador" from older versions to 1.14 as well. Any offers of help and requests to port other abandoned add-ons are welcome!
Konrad2
Forum Moderator
Posts: 2671
Joined: November 24th, 2010, 6:30 pm

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Konrad2 »

I'd love to see Rise of the Elementalist. :)
User avatar
Lord-Knightmare
Forum Regular
Posts: 1207
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.
Contact:

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Lord-Knightmare »

egallager wrote: November 19th, 2020, 9:13 pm I recently took over "A Little Adventure" (which was abandoned) and am now working on porting "Saving Elensefar", "The Earth's Gut" from 1.12 to 1.14, and also intend to port "The Unstoppable Legion" and "The War of Terrador" from older versions to 1.14 as well. Any offers of help and requests to port other abandoned add-ons are welcome!
I shall help out if you need it. Please do add "Fire Forged Friends" to your list of porting/completing/maintaining.
InfernalGuardian
Posts: 2
Joined: April 6th, 2020, 7:54 pm

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by InfernalGuardian »

Hi so im not experienced at all in coding, and am confused by it, but am looking at possibly trying to port Rise Of The Elementalist to 1.14.14. Is there anyway I can do it without going hardcore coder style? I would try to maintain it as well.
Usually found on my own, cause im alone.
User avatar
Helmet
Posts: 201
Joined: December 19th, 2006, 5:28 pm
Location: Florida, USA

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Helmet »

InfernalGuardian wrote: Yesterday, 6:43 pm Hi so im not experienced at all in coding, and am confused by it, but am looking at possibly trying to port Rise Of The Elementalist to 1.14.14. Is there anyway I can do it without going hardcore coder style? I would try to maintain it as well.
You can write complex, fun scenarios without intricate WML, by the way.

I suggest you write a short, simple 2- or 3-scenario campaign, and learn about WML. If you enjoy the process, try to figure-out a few things you don't understand, like how to make a custom trait or a custom unit. The WML Workshop is a great resource for that.

If you can't figure-out how to make a small, simple campaign, you might struggle to port a campaign, because porting a campaign would be that hard or harder, in my opinion.

At first glance, WML seemed hard to me, but after a while it started making sense. I suggest you try it. You might find yourself with a new hobby.
User avatar
lhybrideur
Posts: 158
Joined: July 9th, 2019, 1:46 pm

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by lhybrideur »

I don't think it was the question.

I would say it heavily depend on what is used in this campaign.
Porting from 1.12 to 1.14 is not horribly difficult.
The first thing would be to launch 1.12 version of the add-on on 1.14 and take a look at the error messages. Then try to solve them 1 by 1.
I thought there was a list of commands that got deprecated btw 1.12 and 1.14 but I cannot find it :/
User avatar
egallager
Posts: 35
Joined: November 19th, 2020, 7:27 pm
Location: Concord, New Hampshire
Contact:

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by egallager »

lhybrideur wrote: Today, 3:34 pm I don't think it was the question.

I would say it heavily depend on what is used in this campaign.
Porting from 1.12 to 1.14 is not horribly difficult.
The first thing would be to launch 1.12 version of the add-on on 1.14 and take a look at the error messages. Then try to solve them 1 by 1.
My first step is usually just to run wmllint on the add-on first, and then proceed as you mentioned...
I thought there was a list of commands that got deprecated btw 1.12 and 1.14 but I cannot find it :/
Here is the link: https://forums.wesnoth.org/viewtopic.php?f=21&t=47614
User avatar
Helmet
Posts: 201
Joined: December 19th, 2006, 5:28 pm
Location: Florida, USA

Re: Abandoned Add-ons - Need Maintainers - Open to Anyone

Post by Helmet »

lhybrideur wrote: Today, 3:34 pm Porting from 1.12 to 1.14 is not horribly difficult.
Earlier Pentarctagon wrote...
Pentarctagon wrote: October 13th, 2019, 6:41 am I would say learn writing your own campaign first. There were a lot of changes between 1.12 and 1.14, so trying to work through those while also having to read someone else's code could end up very frustrating.
I think that's good advice, especially for someone who stated that they were confused by coding.
Post Reply