What happened to the add-on's

All questions/issues/feedback for the iOS version of Wesnoth belong here.

Moderators: Forum Moderators, Developers

Post Reply
Salex
Posts: 20
Joined: October 15th, 2017, 4:52 pm

What happened to the add-on's

Post by Salex » April 29th, 2018, 5:28 pm

After the last patch 1.14 I lost every add-on I had campagins and MP faction, so I went to re-download them and most are all gone, is there a reason the add-on section lost a ton of user created content ?


Thanks.

User avatar
Bitron
Moderator
Posts: 438
Joined: October 19th, 2015, 9:23 am
Location: Germany

Re: What happened to the add-on's

Post by Bitron » April 29th, 2018, 5:41 pm

Hello Salex.

The add-ons did not exactly disappear. With the 1.14 version, the game uses a new directory on your disk.
Usually, addons go into documents/my games/wesnoth1.XX/data/addons/, where wesnoth1.XX now is Wesnoth1.14.
The addons you installed are most likely still in Wesnoth1.13 or Wesnoth1.12, depending on which version you played before.

As for the addons on the server, with 1.14, there was also a new server opened for addons. All the addons from 1.13 need to be reuploaded first to the 1.14 server. If you used 1.12 before, not all addons can be transferred to the 1.14 server, since 1.14 introduces a lot changes to the WML engine, thus most likely break the addons designed to work in 1.12.

Salex
Posts: 20
Joined: October 15th, 2017, 4:52 pm

Re: What happened to the add-on's

Post by Salex » April 29th, 2018, 5:46 pm

Bitron wrote:
April 29th, 2018, 5:41 pm
Hello Salex.

The add-ons did not exactly disappear. With the 1.14 version, the game uses a new directory on your disk.
Usually, addons go into documents/my games/wesnoth1.XX/data/addons/, where wesnoth1.XX now is Wesnoth1.14.
The addons you installed are most likely still in Wesnoth1.13 or Wesnoth1.12, depending on which version you played before.

As for the addons on the server, with 1.14, there was also a new server opened for addons. All the addons from 1.13 need to be reuploaded first to the 1.14 server. If you used 1.12 before, not all addons can be transferred to the 1.14 server, since 1.14 introduces a lot changes to the WML engine, thus most likely break the addons designed to work in 1.12.
So you're saying they are still on my IPAD ? Or were they erased when I updated from the previous version ? And if so is there away to erase them since I cannot use them ?

User avatar
Bitron
Moderator
Posts: 438
Joined: October 19th, 2015, 9:23 am
Location: Germany

Re: What happened to the add-on's

Post by Bitron » April 29th, 2018, 6:02 pm

Oh, you're using an iPad. Well, in this case I don't know excactly, but I assume it works similar.
EDIT: There should be a similar folder called documents on iPad, have a look there.

User avatar
singalen
iOS Port Maintainer
Posts: 217
Joined: January 3rd, 2007, 10:18 am
Location: bay

Re: What happened to the add-on's

Post by singalen » April 29th, 2018, 6:25 pm

That's my fault. I didn't realize iPad version will change the save directory too.
I think I need to publish a hotfix release.

User avatar
singalen
iOS Port Maintainer
Posts: 217
Joined: January 3rd, 2007, 10:18 am
Location: bay

Re: What happened to the add-on's

Post by singalen » May 1st, 2018, 10:34 pm

Salex wrote:
April 29th, 2018, 5:46 pm
So you're saying they are still on my IPAD ? Or were they erased when I updated from the previous version ? And if so is there away to erase them since I cannot use them ?
Hi,
Your saves are still there, and with today's release you must get them back. Sorry!

PirateUyesugi
Posts: 1
Joined: May 3rd, 2018, 2:49 am

Re: What happened to the add-on's

Post by PirateUyesugi » May 3rd, 2018, 2:53 am

Thanks for the hot fix. My saves are back but the add ons I had are still gone - means some of my games are missing elements such as the Legends of the Invincibles data. Is there any way to recover that? The add ons for 1.14 don’t have that add on presently.
Thanks.

User avatar
singalen
iOS Port Maintainer
Posts: 217
Joined: January 3rd, 2007, 10:18 am
Location: bay

Re: What happened to the add-on's

Post by singalen » May 3rd, 2018, 3:38 am

That's exactly the reason I didn't migrate the add-ons: for 1.14, they were re-validated and only 1.14-compatible made it to the server.
I would kindly ask you to wait till they are tested/ported/uploaded to 1.14 server, or directly ask the author to update LotI.

Wait, I already did it.

The author is very active and open, I believe, it won't take long.

Post Reply