[iOS] Movement issue

All questions/issues/feedback for the iOS version of Wesnoth belong here.

Moderators: Forum Moderators, Developers

[iOS] Movement issue

Postby Planking » October 15th, 2017, 7:50 am

Version : Battle for Wesnoth HD 1.13.10
Language setting : English

The Battle for Wesnoth version 1.13.10
Running on Darwin 16.6.0 Darwin Kernel Version 16.6.0: Mon Apr 17 17:33:35 PDT 2017; root:xnu-3789.60.24~24/RELEASE_ARM64_T7001 iPad5,3

Game paths

Data dir: /private/var/containers/Bundle/Application/D9ADD749-600E-466D-9583-029F363DB82C/battleforwesnoth-iPad.app
User config dir: /private/var/mobile/Containers/Data/Application/BE01B456-82C2-45D0-85E0-F3E167BA9473/Library/Application Support/wesnoth.org/iWesnoth/.wesnoth1.13
User data dir: /private/var/mobile/Containers/Data/Application/BE01B456-82C2-45D0-85E0-F3E167BA9473/Library/Application Support/wesnoth.org/iWesnoth/.wesnoth1.13
Saves dir: /private/var/mobile/Containers/Data/Application/BE01B456-82C2-45D0-85E0-F3E167BA9473/Library/Application Support/wesnoth.org/iWesnoth/.wesnoth1.13/saves
Add-ons dir: /private/var/mobile/Containers/Data/Application/BE01B456-82C2-45D0-85E0-F3E167BA9473/Library/Application Support/wesnoth.org/iWesnoth/.wesnoth1.13/data/add-ons
Cache dir: /private/var/mobile/Containers/Data/Application/BE01B456-82C2-45D0-85E0-F3E167BA9473/Library/Application Support/wesnoth.org/iWesnoth/.wesnoth1.13/cache


Boost: 1.60
Cairo: USE_cairo_version_OR_cairo_version_string_INSTEAD.USE_cairo_version_OR_cairo_version_string_INSTEAD.USE_cairo_version_OR_cairo_version_string_INSTEAD (runtime 1.10.0)
Pango: 1.28.3 (runtime 1.28.3)
SDL: 2.0.5 (runtime 2.0.5)
SDL_image: 2.0.1 (runtime 2.0.1)
SDL_mixer: 2.0.1 (runtime 2.0.1)
SDL_ttf: 2.0.14 (runtime 2.0.14)


Experimental OpenMP support: no
PNG screenshots: no
Lua console completion: no
Legacy bidirectional rendering: no
Cocoa notifications back end: yes
Growl notifications back end: no

I bought this Battle Wesnoth way back, and I have played and finished almost all the campaigns and most add one. When this update hit, I was like "NO WAY, I can't believe it" I click update ASAP, and tried a new campaign but there was one problem I can't seem to move a unit, so I turned to tutorial but I still can't move a unit. I have played this game many times, even played the specific ios Wesnoth versio before they removed it from App Store, and I'm pretty sure I can navigate how to move a unit, please fix this issue. Thanks in advance.
Posts: 2
Joined: October 15th, 2017, 7:46 am

Re: Movement issue

Postby singalen » October 15th, 2017, 6:56 pm

Thanks for kind words!

In a new version, units are moved with swipes. Please try dragging them, and let us know if it answers the question.

Updating tutorial text is a known issue. It will take very long to get translations updated, though.
User avatar
iOS Port Maintainer
Posts: 178
Joined: January 3rd, 2007, 10:18 am
Location: bay

Re: [iOS] Movement issue

Postby Planking » October 16th, 2017, 1:00 am

Thanks it works now, long last I can finally play!!!
Posts: 2
Joined: October 15th, 2017, 7:46 am

Re: [iOS] Movement issue

Postby Pentarctagon » October 17th, 2017, 6:11 am

Moved to the new iOS Support forum.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Forum Administrator
Posts: 3154
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: [iOS] Movement issue

Postby plamentg » December 10th, 2017, 7:45 am

One more question: how do I teleport the silver mage? With swiping I can only teleport within the current screen. I am able to make limited use of the ability by performing several one-screen jumps (provided there is an abundance of villages) but it would be nice to reach the far end of a map at the cost of just one movement point.
P.S. Thanks for the port, other than this issue, all seems to work great.
Posts: 14
Joined: October 27th, 2011, 8:14 am

Re: [iOS] Movement issue

Postby singalen » December 15th, 2017, 9:54 pm

Thank you!
I'm afraid that Silver Mage has a problem with the current interface.
The only thing you can do is to reduce zoom to 50% - it's a leftmost small button under minimap.
Registering it as an issue with iOS version.
User avatar
iOS Port Maintainer
Posts: 178
Joined: January 3rd, 2007, 10:18 am
Location: bay

Return to iOS Support

Who is online

Users browsing this forum: No registered users and 1 guest