Getting on Ubuntu

General feedback and discussion of the game.

Moderators: Forum Moderators, Developers

Getting on Ubuntu

Postby PenguinZdravko » November 8th, 2005, 1:43 pm

Hi, guys and gals! I use Ubuntu Breezy, and I'm now with version 1.0. I want to upgrade to 1.0.1 through Synaptic, but I can't. In the packages list from Universe it writes, that i have 1.0-1, and 1.0-1 is the latest version. In WesnothBinariesLinux, it says that I can install 1.0.1 through Synaptic with the Universe repo. What should I do now?
Linux rules!
PenguinZdravko
 
Posts: 6
Joined: October 10th, 2005, 10:07 am
Location: South Pole

Postby Ankka » November 8th, 2005, 3:19 pm

Code: Select all
apt-cache search wesnoth


Only gives wesnoth 1.0. This was a little weird.

And, when using linux there's no way to change the language from Finnish to English.

I also installed BfW on Ubuntu, a family computer.
User avatar
Ankka
Forum Regular
 
Posts: 594
Joined: January 2nd, 2005, 2:40 pm
Location: Finland

Postby Dragonking » November 8th, 2005, 6:32 pm

I'm always compiling my wesnoth..
But Synaptic shows: wesnoth 1.0.1+svn20051101-1 so it is in repositoies

About switching to english - try reconfigure locales. I have no problem with switching to diffrent languages.

Using Ubuntu 5.10
This is a block of text that can be added to posts you make. There is a 255 character limit
User avatar
Dragonking
Developer
 
Posts: 591
Joined: November 6th, 2004, 10:45 am
Location: Poland

Postby Ankka » November 8th, 2005, 6:56 pm

Dragonking wrote:I'm always compiling my wesnoth..
But Synaptic shows: wesnoth 1.0.1+svn20051101-1 so it is in repositoies

About switching to english - try reconfigure locales. I have no problem with switching to diffrent languages.

Using Ubuntu 5.10
Hmm looks like I'll just have to look more carefully.
User avatar
Ankka
Forum Regular
 
Posts: 594
Joined: January 2nd, 2005, 2:40 pm
Location: Finland

Postby Benanov » November 9th, 2005, 12:25 am

Since I added the bit on how to get Wesnoth for Ubuntu to the wiki, I figure I should respond here. :)

Synaptic does say 1.0-1 for wesnoth.

Is the latest version 1 dot 0 dot 1 or 1 dot 0 dash 1?

There is a difference as far as the Ubuntu folks go (even though I haven't been using it for long, I've caught onto that immediately) and the package may not be updated.

Force reinstall doesn't get me the new main menu music, so it might be 1 dot 0 still.

I should update the wiki, or would someone else like to do it?
Benanov
 
Posts: 23
Joined: November 3rd, 2005, 5:58 pm
Location: Westminster, MD

Postby WildPenguin » November 9th, 2005, 12:41 am

Although I use Debian, there shouldn't be too much difference...

The latest release version should read 1.0.1-1, (or wesnoth-1.0.1+svn for the SVN version)

Also, make sure that the repositories are configured correctly (latest version in Debian stable is 1.0-1, whereas unstable contains the latest 1.0.1-1).

And obviously running "apt-get update" to update the cache before performing any retrieval.

Steps I generally take to upgrade "apt-get update" followed by "apt-get install wesnoth wesnoth-music wesnoth-httt ... etc" Probably not the easiest way, but it works.

Hope that helps. :)
WildPenguin
 
Posts: 161
Joined: September 6th, 2005, 10:41 pm
Location: Australia

Postby PenguinZdravko » November 9th, 2005, 11:38 am

When I type the command given by WildP, I get this:
Code: Select all
root@ghostwheel:/home/penguinzdravko# apt-get install wesnoth wesnoth-music wesnoth-httt
Reading package lists... Done
Building dependency tree... Done
wesnoth is already the newest version.
wesnoth-music is already the newest version.
wesnoth-httt is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

But I don't have the new things that are in Wesnoth 1.0.1!
Linux rules!
PenguinZdravko
 
Posts: 6
Joined: October 10th, 2005, 10:07 am
Location: South Pole

Whoops

Postby Benanov » November 9th, 2005, 12:38 pm

I'm seeing 1.0-1, not 1.0.1-1 as the latest version in Ubuntu Breezy. Hence the wiki is wrong. :( Someone wanna update it?

I'll try getting on IRC and figuring out who to ask about upgrading the package, if that's done. Haven't quite figured out that logic yet; perhaps our repositories are wrong, or it hasn't been updated. My worst fear is that the repos are frozen because Breezy is released and then we'll have to get it out of svn.

I'd say not to use a Debian repo. They usually don't work (I've gotten lucky with one or two). Maybe I'll try that "generic binary" out on the wiki with the statics compiled in.

If they won't update the package, I'll figure out which packages are needed to build it from source (I know build-essentials will be) and I'll post it here. Once a few of us get it right we'll stick it out on the wiki.

Sound good?
Benanov
 
Posts: 23
Joined: November 3rd, 2005, 5:58 pm
Location: Westminster, MD

Postby Dragonking » November 9th, 2005, 12:41 pm

I belive your problem exist because you have wrong repositories. Maybe post here which repositories do you use (they are in /etc/apt/sources.list).
Moje to:
Code: Select all
deb http://pl.archive.ubuntu.com/ubuntu breezy main restricted universe multiverse
deb-src http://pl.archive.ubuntu.com/ubuntu breezy main restricted universe multiverse

deb http://pl.archive.ubuntu.com/ubuntu breezy-updates main restricted universe multiverse
deb-src http://pl.archive.ubuntu.com/ubuntu breezy-updates main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse


I have backports too (currently unavailable):

Code: Select all
deb http://pl.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
deb-src http://pl.archive.ubuntu.com/ubuntu breezy-backports main restricted universe multiverse
This is a block of text that can be added to posts you make. There is a 255 character limit
User avatar
Dragonking
Developer
 
Posts: 591
Joined: November 6th, 2004, 10:45 am
Location: Poland

Postby Benanov » November 9th, 2005, 5:06 pm

http://packages.ubuntu.com/breezy/games/

This contains version 1.0-1.

http://packages.ubuntu.com/dapper/games/

This contains version 1.0.1-1.

So one way we could upgrade is to upgrade to Dapper. :)
Benanov
 
Posts: 23
Joined: November 3rd, 2005, 5:58 pm
Location: Westminster, MD

Postby Dragonking » November 9th, 2005, 6:26 pm

Yes.. you are right.
I checked one more time, and I can download 1.0.1+svn only because I've added unofficila repository to my sources.list.
This is a block of text that can be added to posts you make. There is a 255 character limit
User avatar
Dragonking
Developer
 
Posts: 591
Joined: November 6th, 2004, 10:45 am
Location: Poland

Postby Benanov » November 10th, 2005, 12:42 am

I'm currently upgrading my system to Dapper (I'll let you know if it breaks, I have my girlfriend's windows machine behind me I can borrow) and wesnoth packages were slated to be upgraded.

I'll let you know how it goes. If so you can be crazy like me. If not...well, we'll try to find another source that's official enough to put in the wiki.
Benanov
 
Posts: 23
Joined: November 3rd, 2005, 5:58 pm
Location: Westminster, MD

Postby Benanov » November 10th, 2005, 1:12 am

Dapper works. However upgrading to Dapper is A) not for the faint of heart and B) not recommended because it's so new.

I've added a request for 1.0.1-1 to be added to Breezy Backports.

http://ubuntuforums.org/showthread.php?t=40291
Benanov
 
Posts: 23
Joined: November 3rd, 2005, 5:58 pm
Location: Westminster, MD

Postby PenguinZdravko » November 10th, 2005, 11:38 am

Thanks, people! Now I'm downloading Wesnoth 1.0.1 from backport!
Linux rules!
PenguinZdravko
 
Posts: 6
Joined: October 10th, 2005, 10:07 am
Location: South Pole

Postby PenguinZdravko » November 10th, 2005, 12:24 pm

Now I have another problem. I've downloaded 1.1-svn from backports but the server requires 1.0. Looks like i will build from source...
Linux rules!
PenguinZdravko
 
Posts: 6
Joined: October 10th, 2005, 10:07 am
Location: South Pole

Next

Return to Users’ Forum

Who is online

Users browsing this forum: Yandex [Bot] and 1 guest