Need help getting 3 old add-ons to work (1.4)

General feedback and discussion of the game.

Moderators: Forum Moderators, Developers

Post Reply
hunter_z
Posts: 4
Joined: August 16th, 2017, 12:05 pm

Need help getting 3 old add-ons to work (1.4)

Post by hunter_z »

Hello!

Last time I played this game actively was in the late 2000s, and around the early 2010s, and it's interesting to see all the new updates, yet I can't help but crave a little nostalgia. It's amazing that a few of my favorite add-ons are supported to this day, over a decade later, but my absolute favorites have sadly been abandoned.

I think these specific add-ons are 1.4 compatible, given they are from around 2007-2008, but I haven't been able to get them to work no matter what. Since it's an outdated version, I couldn't download the add-ons through the game, so I extracted the .zip files I found on the forum into the userdata folder, and I still couldn't get them to show up in-game. I had to create a campaigns folder in \userdata, since the game was unable to create one without connecting to the server. I think that's where add-ons used to be stored, but correct me if I'm wrong!

Add-ons I'm interested in getting to work: The Dark Hordes, A Gryphon's Tale, The High Seas

First two are campaigns, third one is a scripted multiplayer map. Simply extracting them isn't enough, is there something else that should be taken care of? Please let me know! Thanks!

User avatar
Ravana
Forum Moderator
Posts: 2370
Joined: January 29th, 2012, 12:49 am
Location: Estonia
Contact:

Re: Need help getting 3 old add-ons to work (1.4)

Post by Ravana »

It might be easier to download 1.4 wesnoth instead. There have been at least some breaking changes in every release, so to begin with it would make sense to get them running on 1.6, then 1.8, and so on.

gnombat
Posts: 266
Joined: June 10th, 2010, 8:49 pm
Contact:

Re: Need help getting 3 old add-ons to work (1.4)

Post by gnombat »

I think maybe what you're looking for is this:

https://addons.wesnoth.org/

All the add-ons you mentioned are available there. Note that you don't have to go all the way back to version 1.4 - The Dark Hordes and A gryphon's tale are available for version 1.10, and The High Seas is available for version 1.8.

hunter_z
Posts: 4
Joined: August 16th, 2017, 12:05 pm

Re: Need help getting 3 old add-ons to work (1.4)

Post by hunter_z »

I downloaded 1.4 to try to get these three add-ons to run, which is why I mentioned not being able to connect to the server, and I think 1.10 might've been the last version I played A Gryphon's Tale on. It worked up until a certain point where it would be unable to run a map due to outdated scripting or something. I might still own the installer for 1.10, since it was the last version I played before taking a break from BfW.

I will install 1.8 and see how it works there, I will then report back.

EDIT: They appear in 1.8! Now I just hope they won't crash. Thank you guys for the info! :D

Post Reply