Android 1.12 support thread

General feedback and discussion of the game.

Moderators: Forum Moderators, Developers

Post Reply
alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » June 11th, 2015, 7:25 am

JoelPera wrote:Installation: The apk file downloaded the game for me at least four times, despite me choosing only the basic core game and didn't run the game. I reinstalled it once and it downloaded it twice again but automatically started loading the game afterwards.
What do you exactly saw see when the game didn't run? Was it hang in black screen or did it shut down bringing you back to android?
JoelPera wrote:Running:
Phone = Micromax A116
Android = Jellybean (4.2.1)
Port = 1.12.2-39
Description = The game starts fine but the virtual keyboard doesn't function properly. The problem is the keyboard area too responds to touch, so when you press a key, even the tile behind the keyboard gets selected.

Hope this helps and thanks for your time,
Which software keyboard are you using? Can you give a try with "Hacker's keyboard" which can be downloaded from Google Play?

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » June 11th, 2015, 7:27 am

pe_em wrote:Hi alep!
I have just downloaded BfW 1.12.2 on Android 4.0.4 (unlike JoelPera, I didn't have any problems with the installation), then while I was trying to log in MP server I discovered that I cannot tip my nickname "pe_em". The reason of the problem is the fact that something changes _ to - whenever I write my nickname (pe-em instead of pe_em).

Thanks for sending BfW to Play Store.
Please send a bug report following instructions here: http://www.alessandropira.org/bfw_android/faq.html#dbg
To reproduce the bug, just press the "_" key (it does not matter if you are not typing inside a text box).

JoelPera
Posts: 3
Joined: June 9th, 2015, 7:29 am

Re: Android 1.12 support thread

Post by JoelPera » June 11th, 2015, 8:22 am

alep wrote: What do you exactly saw see when the game didn't run? Was it hang in black screen or did it shut down bringing you back to android?
It kept doing what it did the first time, it said "cleaning folders" first and started downloading it again; this is what happened many times.
alep wrote: Which software keyboard are you using? Can you give a try with "Hacker's keyboard" which can be downloaded from Google Play?
Yes, it works now. I was using Google keyboard and just installed Hacker's. I wonder how this didn't cross my mind. Thanks a lot,

highquality
Posts: 22
Joined: June 19th, 2015, 9:59 am

Re: Android 1.12 support thread

Post by highquality » June 19th, 2015, 10:16 am

It doesn't download addons anymore.I had downloaded 1 era and 2 campaigns.Later I clicked remove addons and it won't connect to server of addons or multiplayer server anymore.I have Lenovo A 10 (tablet), android 4.2.2 If it isn't a bug then please a never because I love this game.

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » June 22nd, 2015, 7:13 am

highquality wrote:It doesn't download addons anymore.I had downloaded 1 era and 2 campaigns.Later I clicked remove addons and it won't connect to server of addons or multiplayer server anymore.I have Lenovo A 10 (tablet), android 4.2.2 If it isn't a bug then please a never because I love this game.
This doesn't look like a port related issue.
Maybe the add-on server was temporarily down or unreachable... have you tried again after a few hours?

rayrox222
Posts: 3
Joined: June 11th, 2011, 5:38 pm

Re: Android 1.12 support thread

Post by rayrox222 » July 17th, 2015, 2:15 am

I'm using the Battle for Wesnoth Android app version 1.12.4.

When I installed this I am pretty sure I checked the box to include downloading game music files. Assuming I failed to do this, is there a way I can download the music files to add to the core game without simply reinstalling the whole game? I went into preferences and checked music on with the volume up. I hear all other game sounds but no music and would love to have music playing when I play. Thanks in advance for any answers to resolving my issue!

-Ray

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » July 20th, 2015, 6:36 am

rayrox222 wrote:I'm using the Battle for Wesnoth Android app version 1.12.4.

When I installed this I am pretty sure I checked the box to include downloading game music files. Assuming I failed to do this, is there a way I can download the music files to add to the core game without simply reinstalling the whole game?
Maybe even if you selected it on the first startup something in the download process may have gone wrong.
I'd suggest to:

- wait for sourceforge to exit maintanance mode (see: http://sourceforge.net/blog/sourceforge ... storation/)
- start the game and hit "Change configuration" button to open the port menu
- pick "Select packages to download" and check one of the two music packages
- tap on "Ok" and then pick "Start game"

The app will try to download music data again.

rayrox222
Posts: 3
Joined: June 11th, 2011, 5:38 pm

Re: Android 1.12 support thread

Post by rayrox222 » July 20th, 2015, 4:21 pm

- start the game and hit "Change configuration" button to open the port menu
- pick "Select packages to download" and check one of the two music packages
- tap on "Ok" and then pick "Start game"

The app will try to download music data again.
Ok so when I go into change configuration it wont let me select only to download music data. I also have to redownload the game core data even though I already have it? Is this going to wipe my save files?

Also let me ask while I have your attention, if I dl music data and alternative music data, how does the game know which one to play? Could that be whats messing it up since originally im pretty sure I picked both? Thanks for all your help!

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » July 22nd, 2015, 3:33 pm

rayrox222 wrote:Ok so when I go into change configuration it wont let me select only to download music data. I also have to redownload the game core data even though I already have it? Is this going to wipe my save files?
You are not selecting what to download. You are selecting the packages you want.
If you check something that was not checked it will be downloaded.
If you uncheck something that was checked it will be removed.
Everything you leave as is (checked or unchecked) won't be touched.
rayrox222 wrote:Also let me ask while I have your attention, if I dl music data and alternative music data, how does the game know which one to play? Could that be whats messing it up since originally im pretty sure I picked both? Thanks for all your help!
You can't download both music packages (the app won't let you do it, when you check one the other will be automatically unchecked). If you are sure you managed to check them both then it may be a bug...

Sarhento
Posts: 4
Joined: July 23rd, 2015, 11:42 pm

Re: Android 1.12 support thread

Post by Sarhento » July 23rd, 2015, 11:54 pm

Hello alep!

I've actually sent you an email on July 20 2015 10:28 PM +8 UTC, good thing I also saw this thread!
Here is what I've sent:


First of all thank you for bringing Battle for Wesnoth on Android!
It thrills me that a game of this depth be now available freely on mobile devices.

I do have a concern though. In this latest version 1.12.2 from the playstore (erroneously used the term .apk in the email)
the tutorial is not available, displaying an error of:


"Error loading game configuration files. The game will now exit.

Details:

Macro/file 'campaigns/tutorial/units' is missing
at_main.cfg:104 "



I've downloaded all the resources required from the app. Also tried copying said folder
from the desktop version to copy on my device but I cannot find the data folder with a
campaign folder in my device's storage.

I understand you do this on your free time, it may be my device or it went past testing.

If it helps I'm running a Nexus 7 2012 32gb WiFi on Android 4.3 (I've erroneously wrote as 4.1 before) JB

Thanks again for your work on porting Battle for Wesnoth!

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » July 24th, 2015, 5:52 am

Sarhento wrote:Hello alep!

I've actually sent you an email on July 20 2015 10:28 PM +8 UTC, good thing I also saw this thread!
Here is what I've sent:
Yeah, sorry for not replying until now.
I've checked the 1.12.4 archives and it looks like they are ok.
Did you do a fresh new install or an upgrade from 1.12.2?

I'd suggest to reinstall datafiles from scratch by doing this:

- check that your device is properly connected to internet
- start the game and hit "Change configuration" button to open the port menu
- pick "Startup options" and check "Clean installation folder"
- tap on "Ok" and then pick "Start game"

This will repeat the first startup download.

Sarhento
Posts: 4
Joined: July 23rd, 2015, 11:42 pm

Re: Android 1.12 support thread

Post by Sarhento » July 24th, 2015, 5:59 am

That's quite alright alep, offline getting in the way of our online lives hehe.

It is a fresh install of 1.12.4 and I did reinstall it completely twice over now.
Still no tutorial with that very same error message I posted above.

alep
Android Port Maintainer
Posts: 156
Joined: June 24th, 2013, 6:22 am

Re: Android 1.12 support thread

Post by alep » July 24th, 2015, 1:40 pm

Sarhento wrote:It is a fresh install of 1.12.4 and I did reinstall it completely twice over now.
Still no tutorial with that very same error message I posted above.
Which packages have you installed? I'm asking because right now I cannot reproduce the bug.
Do other things (local multiplayer game, campaigns, etc...) work well?
Also I'm sorry, but I'll be offline for a couple of weeks starting from tomorrow, so I won't be able to fix this quickly.

Sarhento
Posts: 4
Joined: July 23rd, 2015, 11:42 pm

Re: Android 1.12 support thread

Post by Sarhento » July 24th, 2015, 2:39 pm

alep wrote:
Sarhento wrote:It is a fresh install of 1.12.4 and I did reinstall it completely twice over now.
Still no tutorial with that very same error message I posted above.
Which packages have you installed? I'm asking because right now I cannot reproduce the bug.
Do other things (local multiplayer game, campaigns, etc...) work well?
Also I'm sorry, but I'll be offline for a couple of weeks starting from tomorrow, so I won't be able to fix this quickly.
Different combinations, of course campaign data is always included - as well as the music and its alternative. Even tried
installing language data, still no dice.

Internet, local and campaign games work very well. The tutorial is the only thing missing for me.

It's alright, I understand completely.

tauri
Posts: 3
Joined: August 18th, 2015, 7:25 am

Re: Android 1.12 support thread

Post by tauri » August 18th, 2015, 7:41 am

Hi alep,

first thank you for a port of this great game ;) I enjoy playing it on my nexus7, however I have an issue to start it on my phone. After starting a game I see only a black screen. Have you already seen such issue ?

Phone: Honor 6
Android: stock 4.4.2
game version: 1.12.4-40

thank you in advance.

Post Reply