Wesnoth 1.13.6

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Developers, Forum Moderators

Re: Wesnoth 1.13.6

Postby gfgtdf » December 2nd, 2016, 3:12 pm

@wesnothbug, RaphaelWesnoth

ON which reoillutio (windowssize) do you run wesnoth ? does the problem go away if you use a smaller window?
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.
gfgtdf
Developer
 
Posts: 704
Joined: February 10th, 2013, 2:25 pm

Re: Wesnoth 1.13.6

Postby RaphaelWesnoth » December 2nd, 2016, 4:46 pm

@gfgtdf

I am on 1366x768, and the problem does not go away in a smaller window.

Windows 8 with 3,88go of RAM.

I tried to download 1.13.5 to test it but I don't know how to run the archived version.
RaphaelWesnoth
 
Posts: 2
Joined: December 1st, 2016, 12:00 pm

Re: Wesnoth 1.13.6

Postby wesnothbug » December 3rd, 2016, 2:10 am

Pentarctagon wrote:The best thing to do would be to open a bug on GNA and give the information you provided here, especially about it being new to 1.13.6, but I can do that if you'd rather not.

Thank you, It would be best if you do that, since I am mainly passing by here and won't be able to further help.

gfgtdf wrote:ON which reoillutio (windowssize) do you run wesnoth ? does the problem go away if you use a smaller window?


I believe I am using the lowest resolution possible 1024x768, it is also the native resolution for my laptop. I tried using windowed and full screen. No change. I can barely pass the main screen on 1.13.6 without a freeze. Meanwhile 1.13.5 plays as before and I am already enjoying a new campaign on it.

RaphaelWesnoth wrote:I tried to download 1.13.5 to test it but I don't know how to run the archived version.


You can get both from the download page here, they are installed and run the same way. (unless the desktop icon is overwritten in which case you can find both version in the list of programs)
wesnothbug
 
Posts: 4
Joined: December 1st, 2016, 9:14 am

Re: Wesnoth 1.13.6

Postby Pentarctagon » December 3rd, 2016, 2:15 am

wesnothbug wrote:
RaphaelWesnoth wrote:I tried to download 1.13.5 to test it but I don't know how to run the archived version.


You can get both from the download page here, they are installed and run the same way. (unless the desktop icon is overwritten in which case you can find both version in the list of programs)


You can also get most historical versions here. All development versions (odd numbered releases, such as 1.13.x) are under the "wesnoth" link.

Also, the bug report has been submitted.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Moderator
 
Posts: 2643
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.13.6

Postby zepko » December 3rd, 2016, 11:33 am

Sorry if this has already been reported, I have not found it. Not sure how to describe the problem. Sometimes, when moving the mouse pointer from one unit to another, the indicator of the movement points on the sidebar looks strange. The bottom half of the numbers is that from the previous unit, the top half is from the current unit. Other times the bottom part of the numbers is invisible. See the attachment. The problem disappears when I actually click on a unit or move the mouse over an empty tile, even without clicking. It does not always happen, so I'm not really sure how to reproduce it. I am on Ubuntu 16.04. By the way, this also happened on Wesnoth 1.13.5.

Now that I have looked better, I see that also the side number is not visible and there are some dots on the right of the flag in the sidebar. There appears to be some overlap between the different information in the sidebar. This appears to be solved if I switch to fullscreen mode.
Attachments
image.png
User avatar
zepko
 
Posts: 34
Joined: November 29th, 2010, 7:35 pm

Re: Wesnoth 1.13.6

Postby Pentarctagon » December 4th, 2016, 3:31 pm

zepko wrote:Sorry if this has already been reported, I have not found it. Not sure how to describe the problem. Sometimes, when moving the mouse pointer from one unit to another, the indicator of the movement points on the sidebar looks strange. The bottom half of the numbers is that from the previous unit, the top half is from the current unit. Other times the bottom part of the numbers is invisible. See the attachment. The problem disappears when I actually click on a unit or move the mouse over an empty tile, even without clicking. It does not always happen, so I'm not really sure how to reproduce it. I am on Ubuntu 16.04. By the way, this also happened on Wesnoth 1.13.5.

Now that I have looked better, I see that also the side number is not visible and there are some dots on the right of the flag in the sidebar. There appears to be some overlap between the different information in the sidebar. This appears to be solved if I switch to fullscreen mode.


This seems to be a vertical resolution problem. I can reproduce the issue on both Mint 18 and Windows 7, but only when a resolution option with a height of 720 or less is chosen.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Moderator
 
Posts: 2643
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.13.6

Postby Shiki » December 4th, 2016, 5:03 pm

If that's the case, you can switch to the classic (pre-1.10) theme.
It's at settings > display > theme
Maintainer of Era of Myths.
Shiki
 
Posts: 78
Joined: July 13th, 2015, 9:53 pm
Location: Germany

Re: Wesnoth 1.13.6

Postby Bob_The_Mighty » December 7th, 2016, 10:32 pm

gfgtdf, regarding my point #11 on the previous page about the map editor crashing. Try this:
Open any map > Resize Map > Click in the middle of the 3x3 grid > add 2 hexes to the height > scroll down. It crashes every time for me.

As for points #3 and #4, I'm getting the same results no matter what resolution or theme I use. Any ideas?
My current projects:
2p Campaign: The Altaz Mariners
3p Survival: Save The Village
User avatar
Bob_The_Mighty
UMC Pioneer
 
Posts: 716
Joined: July 13th, 2006, 1:15 pm

Re: Wesnoth 1.13.6

Postby Eagle_11 » December 8th, 2016, 10:34 am

7. In macros/abilities ABILITY_HEALS and ABILITY_EXTRA_HEAL have the same id (id=healing). It was like this in 1.12 too, but I guess it could be a problem if you were trying to filter on this.

Afaik, this is the only way of getting them to not stack. They share the same id= so fe. in the scenario of having Elf Shaman and Druid adjacent to 1 wounded unit the stronger heal gets in effect and not both(they both would if had different id=)
User avatar
Eagle_11
 
Posts: 520
Joined: November 20th, 2013, 12:20 pm

Re: Wesnoth 1.13.6

Postby vultraz » December 13th, 2016, 7:44 am

Bob_The_Mighty wrote:1. There's a new type of tooltip on the title screen>multiplayer menu (that includes 'Join Official Server', 'Connect to Server', etc), which comes up in a box while all the other tooltips on the title screen appear at the bottom. Not only is this inconsistent, they also pop up very quickly, obscuring the menu. What's more it actually confused me - I repeatedly pressed the wrong thing, thinking I had selected one of the options when it fact I'd just activated a pop-up. If the tips must appear in boxes, could there be a slight delay in the pop-up box?


I've implemented a change so that tooltips won't obscure their source widgets. As for the inconsistency, the titlescreen itself has tooltips that appear at the bottom of the screen. Any dialog accessed through the titlescreen has tooltips that appear in hover boxes.
Creator of Shadows of Deception (for 1.12) and co-creator of the Era of Chaos (for 1.12/1.13).
SurvivalXtreme rocks!!!
What happens when you get scared half to death...twice?
User avatar
vultraz
Community Manager
 
Posts: 768
Joined: February 7th, 2011, 12:51 pm
Location: Dodging Daleks

Re: Wesnoth 1.13.6

Postby The_Gnat » December 16th, 2016, 6:20 am

Hi, i am planning on releasing my 5 lords reign add-on for 1.13 and in testing i noticed that backstab has been deprecated and was wondering if their are any other deprecations that i should be aware of?
User avatar
The_Gnat
 
Posts: 585
Joined: October 10th, 2016, 3:06 am

Re: Wesnoth 1.13.6

Postby Pentarctagon » December 16th, 2016, 6:29 am

The_Gnat wrote:Hi, i am planning on releasing my 5 lords reign add-on for 1.13 and in testing i noticed that backstab has been deprecated and was wondering if their are any other deprecations that i should be aware of?


FOREACH has been deprecated, though at the moment the [for] tag doesn't seem to quite work either.

The message attribute for [option] has been deprecated.

[advance] was renamed to [advancement].



I would imagine there are more though.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Moderator
 
Posts: 2643
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.13.6

Postby The_Gnat » December 16th, 2016, 7:12 am

Pentarctagon wrote:FOREACH has been deprecated, though at the moment the [for] tag doesn't seem to quite work either.

The message attribute for [option] has been deprecated.

[advance] was renamed to [advancement].



I would imagine there are more though.


Thank you for your response!

My only question is:

If FOREACH has been deprecated and no suitable replacement has been made that will cause many problems in the functionality of the game. I have seen that in the mainline Multiplayer/eras.cfg they have replaced FOREACH with a complicated lua file but it seems that it would be easier not to remove it. Why has it been removed? What plans are being made to replace it with an easy to use alternative for UMC content? Also is the [while] tag deprecated or is it usable as an alternative? (also if these answers could be included in the wiki i am sure that would help many people)

Thank you!

EDIT: also if [for] is not working does that mean that the dehydration utils in UtBS are not functional in 1.13.6? And if the [foreach] tag is not functional it means that the lava will not function in tSoF in 1.13.6, is this true?
User avatar
The_Gnat
 
Posts: 585
Joined: October 10th, 2016, 3:06 am

Re: Wesnoth 1.13.6

Postby Pentarctagon » December 16th, 2016, 7:24 am

[for] would depend on how it was used. If it's just used as a straight replacement for FOREACH, then there's no problem; but if it was used to also replace logic of the type "if $i is > 3 and < 12, then do stuff", with:
Code: Select all
[for]
  array=some_array
  variable=i
  start=4
  end=11
  [do]
# ...
  [/do]
[/for]

then it does not currently function correctly.

As far as I know, the [while] tag is sticking around.

edit-
I also haven't tried the [foreach] tag, since the wiki didn't seem overly clear to me about when/whether the array being looped over can be modified, and I didn't feel like investigating.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Moderator
 
Posts: 2643
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Wesnoth 1.13.6

Postby The_Gnat » December 16th, 2016, 7:27 am

Pentarctagon wrote:[for] would depend on how it was used. If it's just used as a straight replacement for FOREACH, then there's no problem; but if it was used to also replace logic of the type "if $i is > 3 and < 12, then do stuff", with:
Code: Select all
[for]
  array=some_array
  variable=i
  start=4
  end=11
  [do]
# ...
  [/do]
[/for]

then it does not currently function correctly.

As far as I know, the [while] tag is sticking around.


Ok, that's good, i used FOREACH often in my mod for checking through stored units and sides, i will try the [for] tag and see if it works! (also thanks for responding so quickly!)
User avatar
The_Gnat
 
Posts: 585
Joined: October 10th, 2016, 3:06 am

PreviousNext

Return to Release Announcements, Compiling & Installation

Who is online

Users browsing this forum: No registered users and 2 guests