Wesnoth 1.12-4 and 1.13-1 for Linux

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

User avatar
Unnheulu
Posts: 738
Joined: November 25th, 2007, 4:50 pm
Location: Cymru
Contact:

Re: Wesnoth 1.12-4 and 1.13-1 for Linux

Post by Unnheulu » July 23rd, 2015, 5:30 pm

Check the backports as well, 1.12 is in there.

User avatar
shadowm
Site Administrator
Posts: 6583
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Why you should submit my new packages

Post by shadowm » July 23rd, 2015, 9:03 pm

nikita1996 wrote:@shadowm Yeah.. I know that the package released by the professional Ubuntu contributors are more stable. But, by now, except for my packages, there's no v1.12.4 package or v1.13.1 package for Ubuntu.
Did you read my post above?
shadowm wrote:
PPA for development releases (ppa:pkg-games/wesnoth-devel)

PPA for stable releases (ppa:vincent-c/wesnoth) (ignore the outdated description, it does have 1.12.4 for post-precise versions)

Extremely simple instructions for compiling from source on precise (12.04) without having to add any external repositories
The first two sources above can be trusted as they are maintained by the same people who prepare the official Wesnoth builds for Debian and Ubuntu. If in doubt, you should always check your distribution’s backport repositories first.
Also, when I said “trusted”, it wasn’t just about stability.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.

User avatar
tr0ll
Posts: 522
Joined: June 11th, 2006, 8:13 pm
Location: canada

Re: Wesnoth 1.12-4 and 1.13-1 for Linux

Post by tr0ll » July 23rd, 2015, 9:29 pm

As noted on this page
https://packages.debian.org/sid/wesnoth-1.12
wesnoth 1.12.2 is available but not 1.12.4
You can contact the maintainers linked there (right edge of page) to find out how to help.
Ubuntu gets its packages from Debian which is its upstream source.

EDIT: and more to the point see shadowm's post above :lol:

benjam
Posts: 11
Joined: August 1st, 2015, 5:53 pm

Re: Wesnoth 1.12-4 and 1.13-1 for Linux

Post by benjam » September 9th, 2015, 6:33 pm

I think 1.12.4 is no longer in backports, but in the "sloppy backports" (for wheezy users).
Adding this line

Code: Select all

deb http://http.debian.net/debian wheezy-backports-sloppy main
to the sources.list file allows for apt/aptitude installation.

Wussel
Posts: 607
Joined: July 28th, 2012, 5:58 am

Re: Wesnoth 1.12-4 and 1.13-1 for Linux

Post by Wussel » January 11th, 2016, 10:12 am

Just started to use some kind of debian based linux on an old machine. It all looks very practical to me. There is a working "office" clone included. Hardware works nicely. GIMP is missing or bugging me. No current flash player is available. Hopefully I will figure out how to install Wesnoth after resolving this exotic gimp issue. Please continue to support open source software.

Post Reply