[Solved] trouble building- not seeing boost *Linux + scons

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
Crow_T
Posts: 851
Joined: February 24th, 2011, 4:20 am

[Solved] trouble building- not seeing boost *Linux + scons

Post by Crow_T » May 11th, 2015, 12:36 am

I'm getting this error:

Code: Select all

Checking for Boost filesystem library version >= 1.44.0... (cached) no
Checking for Boost locale library... (cached) no
Base prerequisites are not met.
I have Boost 1.5x installed, did the build essential

Code: Select all

$ sudo apt-get build-dep wesnoth
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'wesnoth-1.10' as source package instead of 'wesnoth'
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
Still no luck. I've built 1.10-1.11 quite a bit in the past, late 1.11 to present is giving me issues.
Last edited by Crow_T on May 11th, 2015, 1:48 pm, edited 1 time in total.

User avatar
iceiceice
Developer
Posts: 1056
Joined: August 23rd, 2013, 2:10 am

Re: trouble building- not seeing boost *Linux + scons

Post by iceiceice » May 11th, 2015, 12:48 am

1. Try "scons --config=force"

2. Try "sudo apt-get install libboost-all-dev", then try "scons --config=force" again.

3. If you are on ubuntu precise (I think you said this once a year ago :p ) , I think you might not have all the boost libs you need available. For travis-ci which is on precise we had to do some shenanigans to get the libs.

I don't remember exactly what the best way to do it on a vanilla machine is anymore. But I would try googling "ubuntu precise boost 1.48" or something like that.

User avatar
Crow_T
Posts: 851
Joined: February 24th, 2011, 4:20 am

Re: trouble building- not seeing boost *Linux + scons

Post by Crow_T » May 11th, 2015, 3:29 am

I'm using 14.04 these days- it's currently crunching away building after
2. Try "sudo apt-get install libboost-all-dev", then try "scons --config=force" again.
we'll see what happens, thanks!

Edit: that worked, Wesnoth is up and running :geek:

Post Reply