Failing to compile 1.12.1 on Mint 17.1 [SOLVED]

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
Bobajot
Posts: 4
Joined: January 29th, 2015, 3:18 pm

Failing to compile 1.12.1 on Mint 17.1 [SOLVED]

Post by Bobajot » January 29th, 2015, 3:29 pm

Hi,
I raised this on the linux mint forums but still no solution. I'm confused on what to attempt next it must be 20 years since I looked at a C compilation process :?
http://forums.linuxmint.com/viewtopic.php?f=90&t=188233
I've been playing 1.10.7 for a long time and would like to move to the latest version.
Any help would be appreciated
Last edited by Bobajot on January 29th, 2015, 9:45 pm, edited 1 time in total.

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Failing to compile 1.12.1 on Mint 17.1

Post by AI » January 29th, 2015, 4:55 pm

Besides the build-essential, you also need wesnoth's dependencies. The following command will help with that: sudo apt-get build-dep wesnoth
If it can't find a package named wesnoth, it may be wesnoth-1.10 instead.

Bobajot
Posts: 4
Joined: January 29th, 2015, 3:18 pm

Re: Failing to compile 1.12.1 on Mint 17.1

Post by Bobajot » January 29th, 2015, 7:29 pm

bob@bob-MS-7514 ~ $ sudo apt-get build-dep wesnoth
[sudo] password for bob:
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: You must put some 'source' URIs in your sources.list
bob@bob-MS-7514 ~ $ sudo apt-get build-dep wesnoth-1.10
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: You must put some 'source' URIs in your sources.list
bob@bob-MS-7514 ~ $

Thanks for your reply.

I did a search on apt-get wesnoth and found this which worked and I now have application running first campaign (heir to the throne) :D :D
http://forums.wesnoth.org/viewtopic.php?f=5&t=41366
I'll test it out over time

Regards
Bob

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Failing to compile 1.12.1 on Mint 17.1 [SOLVED]

Post by AI » January 30th, 2015, 2:10 pm

You now have a regular binary install from a different source. That works too.

The reason the commands failed is that apparently, mint ships without source repositories enabled. Someone who actually uses the distro may be able to help you with that. (Unless you want to build wesnoth yourself, this isn't necessary)

Bobajot
Posts: 4
Joined: January 29th, 2015, 3:18 pm

Re: Failing to compile 1.12.1 on Mint 17.1 [SOLVED]

Post by Bobajot » January 30th, 2015, 10:35 pm

Thanks. 8)

I prefer the binary rather than compiling stuff.

Regards

Bob

Battlecruiser_Venca
Posts: 196
Joined: June 3rd, 2009, 11:37 am
Contact:

Re: Failing to compile 1.12.1 on Mint 17.1 [SOLVED]

Post by Battlecruiser_Venca » March 7th, 2015, 3:07 pm

1.12.x is getdeb, you can enable getdeb in minstources

Post Reply