scons errors since rev 50543 [solved]

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
averyimaginativename
Posts: 245
Joined: August 21st, 2010, 12:40 pm
Location: /dev/null

scons errors since rev 50543 [solved]

Post by averyimaginativename » August 6th, 2011, 2:32 pm

First, I have a working copy of Wesnoth, and I'm using the SVN simply to learn by comparing file differences and seeing the changes in game. It's not any of your jobs to teach me, so if this takes too much time, feel free to ignore it.


I've been getting a scons error when updating from the SVN recently:
Spoiler:
My last successful build was 50543 and I've had the same error since then right up until 50620 today. I don't think it's related, but just in case, I started getting SDL/FGLRX crashes in 50543 as described here http://forums.wesnoth.org/viewtopic.php?f=4&t=34511

The only changes to my system (Debian based, 2.6.31 kernel) have been removing FGLRX and adding a udev rule since my last successful build, neither of which should be relevant, so I've got no idea where to even start. Google hasn't proved useful. Any suggestions?
Last edited by averyimaginativename on August 6th, 2011, 6:08 pm, edited 1 time in total.
UMC Story Images web gallery

On an indefinite Wesbreak for health reasons - please only try to get my attention for UMC story images website issues.

Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: scons errors since rev 50543

Post by Anonymissimus » August 6th, 2011, 3:13 pm

The reason is that your boost version isn't new enough (1.42 did suffice for me). But try a svn update since boucman just committed a fix (r50621).
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign

Boucman
Inactive Developer
Posts: 2119
Joined: March 31st, 2004, 1:04 pm

Re: scons errors since rev 50543

Post by Boucman » August 6th, 2011, 3:23 pm

we are upping the boost requirement to 1.36 (previous was 1.35 IIRC)

this is an error though, since that particular function was introduced in 1.40, I fixed it in trunk today
Fight key loggers: write some perl using vim

User avatar
averyimaginativename
Posts: 245
Joined: August 21st, 2010, 12:40 pm
Location: /dev/null

Re: scons errors since rev 50543

Post by averyimaginativename » August 6th, 2011, 6:08 pm

Successfully built 50622 with boost 1.40.

Thanks.
UMC Story Images web gallery

On an indefinite Wesbreak for health reasons - please only try to get my attention for UMC story images website issues.

Post Reply