1.8 For Karmic Koala.

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
Antty
Posts: 9
Joined: March 9th, 2010, 2:13 am

1.8 For Karmic Koala.

Post by Antty » May 5th, 2010, 4:23 am

Hi, im an amature computer user tbh.. and well big words that i dont understand past "download" are being thrown at me when i want to *download* 1.8 wesnoth...

I was hoping if there was a tutorial or a simple step by step for helping me compile or build wesnoth...whatever that means.
I would really appreciate it, as 1.6 seemed to have completely died :\ i also have a friend FallenAngel who has the same issue.

If there is a link that you could show me (of steps, not just a bunch of links to things that i cant do anythign too) would make my day :D

Thank you

User avatar
norbert
Posts: 368
Joined: June 14th, 2009, 6:57 pm
Location: The Netherlands

Re: 1.8 For Karmic Koala.

Post by norbert » May 5th, 2010, 1:38 pm

Antty wrote:Hi, im an amature computer user [...] i want to *download* 1.8 wesnoth...
Since the repository of Ubuntu 9.10 (Karmic Koala) includes version 1.6.5, you'd have to compile Wesnoth yourself. Download the source and follow these instructions. If it's not working out, read through this page.

Where it says...
tar -xvzf wesnoth-1.x.x.tar.gz
...use...
tar -xvjf wesnoth-1.8.1.tar.bz2

Antty
Posts: 9
Joined: March 9th, 2010, 2:13 am

Re: 1.8 For Karmic Koala.

Post by Antty » May 5th, 2010, 10:22 pm

Source downloaded, next the instructions i did:

cd /usr/src
tar -xvzf wesnoth-1.x.x.tar.gz
cd wesnoth-1.x.x
./configure --datadir=/usr/share/games ...
make
sudo make install


So i colored it.
First step gets me from
antty@antty-laptop:~$
to
antty@antty-laptop:/usr/src$

Next step gets me

antty@antty-laptop:/usr/src$ tar -xvjf wesnoth-1.8.1.tar.bz2
tar: wesnoth-1.8.1.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Exiting with failure status due to previous errors
antty@antty-laptop:/usr/src$

not sure if maybe i downloaded in wrong place.. or move the thing i downloaded..

User avatar
norbert
Posts: 368
Joined: June 14th, 2009, 6:57 pm
Location: The Netherlands

Re: 1.8 For Karmic Koala.

Post by norbert » May 5th, 2010, 10:48 pm

Antty wrote:Source downloaded, next the instructions i did: [...]
It's important that you (try to) understand what you're doing. If the instructions said "Now, format your hard disk.", you wouldn't do it either. With the command "cd" you change the current working directory; "tar" is used to unpack the source package (tar is an archive file format). You change the working directory because you want to run the second command from the directory where the package resides.

Code: Select all

tar: wesnoth-1.8.1.tar.bz2: Cannot open: No such file or directory
The "tar" command tells you that it cannot open the package because there is no file with the name you specified in the working directory. I'm sure you've downloaded files before, so you know where it is. Go there and rerun the "tar" command.

adm
Posts: 44
Joined: April 8th, 2010, 7:08 am

Re: 1.8 For Karmic Koala.

Post by adm » May 5th, 2010, 11:10 pm

The info on that page isn't quite accurate and rather confusing.

First you have to extract the source code. You don't have to use the console to do that. Just right click on the source code and choose either extract here or extract to.
Now open a console and enter cd and then space. Now just drag and drop the folder with the uncompressed source code into the console and press enter. Now continue with the configure step. Note that you need to have the dev version of the following files installed to compile wesnoth.

boost_iostreams >= 1.35.0
boost_regex >= 1.35.0
boost_serialization >= 1.35.0
lua >= 5.1
libfontconfig >= 2.4.1
libpango (with cairo backend) >= 1.14.8
libsdl >= 1.2.7
libsdl-image >= 1.2 (with png support)
libsdl-mixer >= 1.2 (with Vorbis support)
libsdl-net
libsdl-ttf >= 2.0.8
libz

But you don't necessarily have to compile wesnoth. Wesnoth 1.8 packages will be made available through Karmic-backports. Alternatively you could upgrade to Ubuntu 10.04 which has both Wesnoth 1.6 and Wesnoth 1.8 in the repositories.

User avatar
shadowm
Site Administrator
Posts: 6579
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: 1.8 For Karmic Koala.

Post by shadowm » May 6th, 2010, 4:36 pm

On a side note...
norbert wrote:[...] and follow these instructions.[...]

Where it says...
tar -xvzf wesnoth-1.x.x.tar.gz
...use...
tar -xvjf wesnoth-1.8.1.tar.bz2
It's always helpful if people who know a wiki article is wrong edit and rectify the information in it, since our time, memory and energy is limited.

Same for outdated instructions, broken links, etc.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.

User avatar
Rhonda
Site Administrator
Posts: 47
Joined: January 26th, 2008, 9:13 pm
Location: Vienna, Austria, Europe, Earth, Milky Way
Contact:

Re: 1.8 For Karmic Koala.

Post by Rhonda » June 2nd, 2010, 9:39 am

Antty wrote: I was hoping if there was a tutorial or a simple step by step for helping me compile or build wesnoth...whatever that means.
I would really appreciate it, as 1.6 seemed to have completely died :\ i also have a friend FallenAngel who has the same issue.

If there is a link that you could show me (of steps, not just a bunch of links to things that i cant do anythign too) would make my day :D

Thank you
I have created a backport request for wesnoth-1.8 to karmic a while ago, unfortunately it hasn't got processed yet. Maybe it would help if you could add your comments and wish to it: https://bugs.launchpad.net/karmic-backports/+bug/570609

This is the only thing I can currently offer, don't have more permission to push it, sorry.
Rhonda

Post Reply