Wesnoth 0.8.2 for Mac OS X

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderator: Forum Moderators

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Wesnoth 0.8.2 for Mac OS X

Post by quartex »

To try to prevent too many people bugging the developers for an OS X version of Wesnoth, I'm linking to scott's compilation of the source code. Thanks scott for compiling the code for OS X, so far I haven't found any bugs in his build. The build is just the application, no editor or documentation, though I think scott is working on them.

Goto this ftp site and download the file titled wesnoth 0.8.2 application:
http://www.cis.rit.edu/~slk8779/wesnoth/

Enjoy!

And again, thanks scott for making the new version available to all of us Mac users so quickly. We appreciate it.
lilepo2023
Posts: 195
Joined: July 16th, 2004, 7:57 pm
Location: NY

Post by lilepo2023 »

dave take that thing an slap it on the downloads... pls?
schu
Posts: 12
Joined: August 11th, 2004, 2:41 pm
Location: Huntsville AL

Post by schu »

Sorry, lilepo, but I think that would be jumping the gun. Just grabbing the latest executable might be OK for wesnoth fans, but distributing it to the general public with no docs looks bad. As a Mac app, wesnoth is problematic as it is, because it doesn't act like a typical Mac app. The version that Scott has made available doesn't even identify itself correctly in the Finder (0.8 instead of 0.8.2). A little thing, but "fit and finish" make a difference, especially to new users.

Besides, I think I may have found a bug. If I start a Rise of Wesnoth campaign with version 8.1, I cannot open it with 8.2. This is true for Scott's compilation and one that I just did also. It is easy to check. Start the campaign in 8.1, save right away. Try to open it in 8.2. I get an error message "The game cannot be loaded:load_game_failed: Unit not found: 'Female_Outlaw'...". Surprisingly, 8.1 will load a campaign created with 8.2, but not vice-versa.

Now this may or may not be a bug. It may just be that something has changed in the file format between versions that we have to live with. I couldn't tell for sure from the changelog. I'd like to know one way or the other before it is released. Players can get pretty cranky when they can't open their saved games.
scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott »

Sometimes units and graphics change between distributions, breaking campaigns. The file might have been renamed or the unit could have been accidentally dropped altogether. It's up to the campaign developers to keep up (per another thread somewhere around here). But, this is just one possibility.

You're absolutely right - my work is definitely not sourceforge material. Just enough to keep the playtesters playtesting! I guess people respond well to anything when nothing is the next alternative.
wobbegong
Posts: 62
Joined: May 5th, 2004, 11:07 pm
Location: York (UK)
Contact:

Post by wobbegong »

schu wrote: If I start a Rise of Wesnoth campaign with version 8.1, I cannot open it with 8.2.
I just get a 'file is corrupt' error for the same campaign (started in 8.1, won't load in 8.2). Also when I load 8.1 HttT scenarios I get the normal 'are you sure you want to do this' type of message, and the scenario almost works, however the day/night graphics box and the tooltip that gives information on time of day are both broken (blank, no effect) which is not helpful.

Everything seems to work when I start new campaign/scenarios under 8.2 all the way though.

10.3.5, 384Mb memory, G4 PowerBook.

Cheers,

Tim.
schu
Posts: 12
Joined: August 11th, 2004, 2:41 pm
Location: Huntsville AL

Post by schu »

Hi Scott,

I'm glad that you seem to realize that I'm not trying to slam your efforts. It's great that you are giving people executables that they can test.

I guess what I want to know is if this is a known problem for the developers. If so, it needs to be in the release documentation. If not, I would be hesitant to release it at all if it breaks existing functionality (and the developers don't know why).

Of course, since OS X 8.1 never made it to the main download page...

In any case, I think a few more people ought to bang on it a bit. I'll work on packaging it up for OS X later today.
bear
Posts: 19
Joined: July 9th, 2004, 9:14 am
Location: Southern California

Post by bear »

0.8.1 worked well for me. But unfortunately, 0.8.2 works well except for one thing. It doesn't let me recruit. Whenever I hit ctrl-R, it does nothing. I got up to the menu under Actions and click on the recruit button... nothing. I right click and do recruit... nothing.

Is anyone else having this problem?
schu
Posts: 12
Joined: August 11th, 2004, 2:41 pm
Location: Huntsville AL

Post by schu »

Bear, I don't have that problem when starting a new scenario. I haven't had much time to try anything else.

I've put together an 8.2 package to be considered for release. It can be downloaded at

http://homepage.mac.com/schu/FileSharing1.html

I'd at like the problem with 8.2 opening 8.1 campaigns to be addressed before it is released. It at least needs to be documented if it is a known reproducible problem.
quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex »

I just checked with my version of 0.8.2, running OS X 10.2.8.

I can definitely recruit units in the castle when I start a new game. And when i load 0.8.1 savefiles from TROW, it gives me the warning that this savefile was created with a different version of the game, but they seem to convert fine.
Star Gazer
Posts: 110
Joined: April 6th, 2004, 10:06 am
Location: North Norfolk, UK

No picnic in the woods?

Post by Star Gazer »

Hi Bear, I can't seem to replicate these problems with incompatible save files and recruiting using ctr+R.

I've run games in both 10.2.8 and 10.3.5 without problems, old 0.8.1 saves converted without incident, and ctr-R recruiting just fine.

Have you accidently got a corrupted file when downloading 0.8.2?
blackjack
Posts: 178
Joined: February 11th, 2004, 11:12 am

Post by blackjack »

The reason is because, if you look at the changelog, that Female Outlaws have been removed from the game (and subsumed into the Outlaw unit).

Thus, savefiles in the scenarios before the Female Outlaw "changes" will become invalid. This is not a bug or a problem - it is part of the development process.
A witty saying proves nothing.
-Voltaire
bear
Posts: 19
Joined: July 9th, 2004, 9:14 am
Location: Southern California

Wierd problem (more info)

Post by bear »

Ok guys, this is the one campaign I played. It was the undead one. I can't remember the name right now. In any case, the first 2 scenarios, I was able to recruit. Then all the middle scenarios, no go. But then the last two scenarios, it was available again.

Can anyone make any heads or tails of this? I've done it twice, and it's the same thing. I haven't tried other scenarios yet.
Star Gazer
Posts: 110
Joined: April 6th, 2004, 10:06 am
Location: North Norfolk, UK

Post by Star Gazer »

Ahh...apologies to Bear for not having tried a save with the Female Outlaw - she was already an 'Outlaw Princess' in the version I tried.

On the other hand, what's with the ability to recall a 'Troll Whelp' in the very first scenario of the 'undead' campaign - when there should be nothing to recall?

I don't remember that before - or was it that I had never bothered to try.

What's going on?
schu
Posts: 12
Joined: August 11th, 2004, 2:41 pm
Location: Huntsville AL

Post by schu »

Blackjack, you are no doubt correct, although I might nitpick that the change to the female outlaw is not very clear in the changelog. I agree that the problem with the female outlaw unit in 8.2 is not a bug.

Star Gazer, I agree the ability to recall Troll Whelps in the first scenario is odd (I can do it too), but I wouldn't hold up a release over it.

Has anyone looked at my package? Any comments?
scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott »

The recruiting/recall issues in the undead campaign are bugs in the campaign WML that are getting fixed.

Schu, do you set the compiler to optimize for size or speed or neither? I just discovered these options in Xcode and decided to optimize for size (but it took almost 2 hours). 'Build style' is starting to make sense now.
Post Reply