Problem with ./configure in Ubuntu 8.10

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Problem with ./configure in Ubuntu 8.10

Postby PhilipN » April 28th, 2009, 4:44 am

I am using Ubuntu 8.10, and when I unpacked the tarball for 1.6.1 and tried to use ./configure, I got the usual output of the command (checking this, checking that), until it ran into the following error and stopped:

Code: Select all
Checking for SDL - version >= 1.2.7 and SDL_ttf - version >= 2.0.8... no
configure: error: *** Please upgrade your SDL and/or SDL_ttf version


It then returned me to the shell prompt. I suppose that I should tell you that the first time I tried to use the command

Code: Select all
sudo apt-get build-dep wesnoth


I realized that it would take several hours, and that I didn't have that kind of battery life left in the laptop (I was sitting outside the local library and using their wi-fi), so I interrupted the download. Later, I used the same command when I had access to a high-speed wired connection. My two questions are: (1) "Could this interruption be the problem?" and (2) "Whatever the answer to the first question is, how do I get Wesnoth up and running?"

Your help in solving this problem would be greatly appreciated.
PhilipN
 
Posts: 29
Joined: October 27th, 2008, 4:49 am

Re: Problem with ./configure in Ubuntu 8.10

Postby loonycyborg » April 28th, 2009, 11:55 am

Ubuntu 8.10 has wesnoth 1.4 which doesn't depend on SDL_ttf, build-dep won't fetch it. So you'll need to apt-get it manually:
Code: Select all
sudo apt-get install libsdl-ttf2.0-dev
"meh." - zookeeper
User avatar
loonycyborg
Windows Packager
 
Posts: 242
Joined: April 1st, 2008, 4:45 pm
Location: Russia/Moscow

Re: Problem with ./configure in Ubuntu 8.10

Postby ivanovic » April 28th, 2009, 12:34 pm

Beside this there are several other dependencies that you won't fetch when getting the build dependencies for 1.4. Just have a look at this page in the wiki for a list of all dependencies that you really need.
User avatar
ivanovic
Lord of Translations
 
Posts: 1146
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Re: Problem with ./configure in Ubuntu 8.10

Postby PhilipN » May 1st, 2009, 1:11 am

Are there any handy shortcuts to getting any of those dependencies, or must I download and compile them individually?
Either way, I am going to try to get it working tomorrow.
PhilipN
 
Posts: 29
Joined: October 27th, 2008, 4:49 am

Re: Problem with ./configure in Ubuntu 8.10

Postby loonycyborg » May 1st, 2009, 4:11 pm

All dependencies can be installed with sudo apt-get install.

EDIT:
Code: Select all
sudo apt-get install libsdl-dev libsdl-image1.2-dev  libsdl-mixer1.2-dev libsdl-net1.2-dev libsdl-ttf2.0-dev libboost-iostreams-dev libboost-regex-dev libpango1.0-dev libfontconfig-dev liblua5.1-dev
"meh." - zookeeper
User avatar
loonycyborg
Windows Packager
 
Posts: 242
Joined: April 1st, 2008, 4:45 pm
Location: Russia/Moscow

Re: Problem with ./configure in Ubuntu 8.10

Postby PhilipN » May 2nd, 2009, 2:14 am

It works now :D

Thanks, guys!
PhilipN
 
Posts: 29
Joined: October 27th, 2008, 4:49 am


Return to Release Announcements, Compiling & Installation

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest