Wesnoth 1.4

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Mithrandir
Posts: 2
Joined: June 22nd, 2007, 8:47 pm
Location: Vilnius, Lithuania

Re: Wesnoth 1.4

Post by Mithrandir »

Thanks to everyone who has contributed to this release. Let's hope that 1.6 will be even more awesome.

User avatar
Iris
Site Administrator
Posts: 6689
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Wesnoth 1.4

Post by Iris »

Let's hope? Let's HOPE? No way.

Let's MAKE it even more awesome!

(the power of OSS)
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

User avatar
Unnheulu
Posts: 738
Joined: November 25th, 2007, 4:50 pm
Location: Cymru
Contact:

Re: Wesnoth 1.4

Post by Unnheulu »

Gena wrote::( :( :( :( i have a bit of trouble i have linux fedora 8 and i tried to download this 1.4 version of the net but i cant install it which is a bit obvious as im a kid but its not in Yum extnder (a program to download stuff strait to your computer) where i originally got my 1.2.8 version from and i cant find it in software updeter either my dad says it will be out on updater soon but i cant wait that long what should i do?
Source code...Compile yourself?

Just wondering if that is possible IIRC then its just a matter of:

Code: Select all

$ ./configure --enable_editor
$ make
$ sudo make install
In fact if your impatient surely others are, why not make the package yourself? ;)

User avatar
Iris
Site Administrator
Posts: 6689
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Wesnoth 1.4

Post by Iris »

I just do:

Code: Select all

./configure --enable-editor --enable-tools && make && su -c "make install"
The parameter's correct spelling is --enable-editor, NOT --enable_editor by the way.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

User avatar
Unnheulu
Posts: 738
Joined: November 25th, 2007, 4:50 pm
Location: Cymru
Contact:

Re: Wesnoth 1.4

Post by Unnheulu »

Shadow Master wrote:I just do:

Code: Select all

./configure --enable-editor --enable-tools && make && su -c "make install"
The parameter's correct spelling is --enable-editor, NOT --enable_editor by the way.
I thought it was something like that, but I havn't compiled since when 1.3.18 was out... :oops:

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4

Post by Jovycos »

Hi!
I use Fedora 8 and Wesnoth 1.3.13.
There is no 1.4 Fedora rpm in the official repositories, yet.

Is Wesnoth 1.4 "better" than 1.3? It is "only" a stable version.
And the maps without headers - a lot of mp-scenarios use them - are they replaced?
I will wait for a rpm.

Edit: nice campaign, shadow master! ;)
Full of Nerdiness...

User avatar
Aethaeryn
Translator
Posts: 1553
Joined: September 15th, 2007, 10:21 pm
Location: Baltimore, Maryland, USA

Re: Wesnoth 1.4

Post by Aethaeryn »

Jovycos wrote:Hi!
I use Fedora 8 and Wesnoth 1.3.13.
There is no 1.4 Fedora rpm in the official repositories, yet.

Is Wesnoth 1.4 "better" than 1.3? It is "only" a stable version.
And the maps without headers - a lot of mp-scenarios use them - are they replaced?
I will wait for a rpm.
1.4 is better than 1.3 and will always be better than 1.3 as it is effectively 1.3.19 with some updated art/songs/bugfixes. The next development version, 1.5, will be better than 1.4 in features, but could introduce new bugs that might not be fixed/noticed until later on in the 1.5 branch.

Of course the maps without headers are updated, unless the content is abandoned by the creator in the case of add-ons. If you really care about this content, you can run wmllint (a python script) to update it for your personal use (though you may need to check the WML by hand anyway, scripts aren't perfect).

There was a new server released for 1.3.14 so all content would be 1.4-compatible on the add-on server. In fact, by using 1.3.13 you're missing out on updated material from 1.2 and pre-1.3.14 as well as all the new content. It might be better to not wait for the rpm. All your add-ons are several months out of date! You're also missing out on great new songs and sprites (as well as the portraits for the elves).
Aethaeryn (User Page)
Wiki Moderator (wiki)
Latin Translator [wiki=Latin Translation](wiki)[/wiki]
Maintainer of Thunderstone Era (wiki) and Aethaeryn's Maps [wiki=Aethaeryn's Maps](wiki)[/wiki]

Elvarg
Posts: 3
Joined: March 12th, 2008, 2:37 am

Re: Wesnoth 1.4

Post by Elvarg »

thanks to the devs :lol2:

cant wait to get it installed :wink:

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4

Post by Jovycos »

Okay, okay - i downloading waiting for 1.5! ;)
In 1.3.13 some official maps had no headers.
Full of Nerdiness...

User avatar
Iris
Site Administrator
Posts: 6689
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Wesnoth 1.4

Post by Iris »

Jovycos wrote:Okay, okay - i downloading waiting for 1.5! ;)
In 1.3.13 some official maps had no headers.
That was fixed a long time ago (1.3.14 IIRC).
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

User avatar
singalen
iOS Port Maintainer
Posts: 293
Joined: January 3rd, 2007, 10:18 am
Location: bay

Re:

Post by singalen »

nataS wrote:Working as expected here (Windows Vista).
I can't tell now what version it appeared in, about 1.3.16.
I couple of things went worse:

* Wesnoth now re-initializes display when going from map selection to player lobby, and when loading a game. This is notably slower then before;
* Now there is a notable pause after appearance of save and load dialogs when UI doesn't react to keyboard. So now you can't just press Return when the dialog appears, you have to wait about a second.

I have 1.4, Windows Vista.
Thank you.

EDIT: merged from Wesnoth 1.3.19 disc. thread. -- Shadow Master

User avatar
Lizard
Posts: 352
Joined: January 19th, 2008, 8:20 am
Location: Hiding in a swamp (gtm +1; DST)

Re: Wesnoth 1.4

Post by Lizard »

The English 1.4 Release Notes wrote:More Info
  • Full Changelog (English, very long)
  • User's Manual
  • Wesnoth Official Website (English)
  • Wesnoth 1.0 Release Notes
  • Wesnoth 1.2 Release Notes
:? A hint that the Full Changelog&The Website is English on a English site? On a German(or other) this makes sense to warn the Reader, but on a English one? I would expect an English page there.
~ I'll heal you by 4 hp if you post next to me ~
Have a look at the Era of Strife, featuring Eltireans, Eventide, Minotaurs, Saurians and Triththa

VS
Translator
Posts: 187
Joined: November 27th, 2005, 10:07 am

Re: Wesnoth 1.4

Post by VS »

That's because of how the translation works. English text is the original, which is translated, so it makes sense to mention the warning and make sure translators won't forget that. Ironically, English also does not need any translation, so the warning stays :) Nothing can be really "properly" done about that...

User avatar
pauxlo
Posts: 1047
Joined: September 19th, 2006, 8:54 pm

Re: Wesnoth 1.4

Post by pauxlo »

VS wrote:That's because of how the translation works. English text is the original, which is translated, so it makes sense to mention the warning and make sure translators won't forget that. Ironically, English also does not need any translation, so the warning stays :) Nothing can be really "properly" done about that...
Maybe one could put these warnings in an HTML comment in the english version.

runearun
Posts: 29
Joined: January 23rd, 2008, 2:49 am

Re: Wesnoth 1.4

Post by runearun »

where is 1.2.X?

on the download page , i only see 1.4.X and 1.3X. I don't want these newer versions; where can i get 1.2.X ? (probably 8)

Post Reply