Wesnoth 1.3.18

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
ivanovic
Lord of Translations
Posts: 1146
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Wesnoth 1.3.18

Post by ivanovic » February 19th, 2008, 11:04 pm

Wesnoth 1.3.18 is out!

This is the first release candidate for 1.4. There will be at least one more rc, maybe two. The next one will probably released at the end of FOSDEM. When everything goes right, 1.4 will be ready by the beginning of march.

Some might ask why this release is not named 1.3.17 but 1.3.18. The reason is simple: there was a really last minute change after 1.3.17 was already packaged. Due to some problems with the creation of checksums of units, the algorithm defining which items to use had to be rewritten to make sure that all rc versions as well as 1.4.x are compatible with each other. The result of this change is that all replays from previous versions will not work with 1.3.18 (and following). Normal savegames from previous versions should still be fully usable, just the replay function will not work. On the other hand this change will allow us to keep all versions from the first rc of 1.4 up to the last 1.4.x version compatible with each other, no matter if savegames, replays or normal multiplayer matches are concerned.

A new option to run Wesnoth nicely in 800x480 (the resolution needed for sweet toys like eg the Asus eeePC or the Nokia n810) is now supported when activating it at compile time eg via the configure switch --enable-smallgui. Since there are some known glitches with it (small stuff like buttons being half hidden), of which some will definitely not be fixed before 1.4 since they require really big changes (the multiplayer "create game"-screen), it is not activated by default and probably will not be activated in any of the default binaries. Some more theming fixes should make the default theme scale better on all resolutions from 800x600 onwards.

Another nice change is the huge amount of added portraits for most of the elves which were done by Kitty. What else was changed? Some updated graphics, translations and probably a lot more that I am too lazy to mention now. For a more complete list (not 100% complete, some devs tend to forget adding entries) have a look at the changelog. A changelog with the changes that might be visible to most users (and only includes these) is the players_changelog.

Downloads
Sources:
http://downloads.sourceforge.net/wesnot ... 2?download (115.4 MB) md5sum
Here is the xDelta for the sources:
http://downloads.sourceforge.net/wesnot ... a?download (1.3.16 to 1.3.18, 2.7 MB)
Check http://www.wesnoth.org/forum/viewtopic.php?t=7034 for info on using xdelta.

The Windows binary is already available You can find it on the download page.

The MacOSX binary is already available You can find it on the download page.

The OpenSolaris binary is not available yet. Once it is you can find it on the download page.

Beside those the binaries for Debian (currently just in 'incoming'), the binary for OpenSuse (the usual place) as well as the ebuilds for Gentoo (hardmasked) are already updated and probably available via the normal package manager. All the other known packagers have been contacted. Information about where to get the respective binaries or how to get them work you get on the Linux binaries site for the Linux binaries. Download links for the other supported systems will be listed at the downloads page once the binaries are available.

As a fallback you can also get the sources from http://files.wesnoth.org/ - you should first try to get files through SourceForge to help us save bandwidth.

The multiplayer server for 1.3.18+ is already up and running. Within the next hours we will shutdown the 1.3.16 multiplayer server since we want our first release candidate for 1.4 be tested as much as possible and the major binaries are already available. It is not possible to play with 1.3.16 (or any older version) with players that are using 1.3.18+. But 1.3.18 is meant to be compatible with all the following release candidates as well as all the 1.4.x stable releases. Please consider updating Wesnoth as soon as possible.

By now the add-on server already offers some content that should be completely compatible with 1.3.18 (and the upcoming 1.4). If you encounter any problems with content not working as expected, please notice the contents author, most of them should be here in the forums.

If you find any bugs don't hesitate to report them, but please read the instructions on how to post bugs first. Instructions for bug reporting can be found at http://www.wesnoth.org/wiki/ReportingBugs.

Enjoy!

PS: Bugreports in the forums tend to be forgotten. So better follow the guidelines and report them in the bugtracker.
Last edited by ivanovic on February 25th, 2008, 10:26 pm, edited 2 times in total.

whitewater
Posts: 17
Joined: August 5th, 2006, 5:38 am

Post by whitewater » February 19th, 2008, 11:47 pm

For a more complete list (not 100% complete, some devs tend to forget adding entries) have a look at the changelog. A changelog with the changes that might be visible to most users (and only includes these) is the players_changelog.
The first changelog link is to version 1.3.16 and should be changed to 1.3.18

Thanks

ulissesroc
Posts: 70
Joined: December 28th, 2007, 12:02 pm
Location: Amsterdam
Contact:

Post by ulissesroc » February 21st, 2008, 8:48 am

Even if Ivanovic said that no --small-gui version would ever be packaged, the version that was on the server has this option for Mac OS X. Some people find it annoying anyway (see http://www.wesnoth.org/forum/viewtopic.php?p=283185 for references) and then I created a version without this annoying main screen..

Ok, thus at sourceforge I've uploaded the versione _a without this annoying modification.

http://sourceforge.net/project/showfile ... _id=577644

ciropom++
Posts: 4
Joined: February 24th, 2008, 10:03 pm

Re: Wesnoth 1.3.18

Post by ciropom++ » February 26th, 2008, 4:32 pm

ivanovic wrote: The multiplayer server for 1.3.18+ is already up and running.
Hi guys!
I have already installed the version 1.3.18 on my debian sid and it work perfectly. :D

But I have a little problem.
I would like to create a wesnoth server for this version on my pc, but I have found only the package wesnoth-server (the daemon wesnothd) for the old stable version 1.2.x...

My question is how can I do? I cannot found any package for the version 1.3.18...
Thanks for the reply :)
ipse dixit

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Post by AI » February 26th, 2008, 4:39 pm

It probably doesn't exists yet, so your best option is probably to get the source code and compile it yourself. Since you're on debian, that should be easy.

ciropom++
Posts: 4
Joined: February 24th, 2008, 10:03 pm

Post by ciropom++ » February 26th, 2008, 4:42 pm

AI wrote:It probably doesn't exists yet, so your best option is probably to get the source code and compile it yourself. Since you're on debian, that should be easy.
ok this is the source code for the client... but for the server?
ipse dixit

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Post by AI » February 26th, 2008, 4:51 pm

./configure --enable-server

and whatever other flags you want.

ciropom++
Posts: 4
Joined: February 24th, 2008, 10:03 pm

Post by ciropom++ » February 26th, 2008, 5:00 pm

AI wrote:./configure --enable-server

and whatever other flags you want.
ok... also, I must uninstall the version 1.3.18 that I have installed and reinstall it with the option --enable-server?

But to uninstall the software how can I do? becouse I have compiled it...
ipse dixit

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Post by AI » February 26th, 2008, 7:06 pm

if you compiled the previous version, do "make uninstall" in the directory containing it's sources.

User avatar
Rhonda
Site Administrator
Posts: 47
Joined: January 26th, 2008, 9:13 pm
Location: Vienna, Austria, Europe, Earth, Milky Way
Contact:

Re: Wesnoth 1.3.18

Post by Rhonda » February 26th, 2008, 10:24 pm

ciropom++ wrote:
ivanovic wrote: The multiplayer server for 1.3.18+ is already up and running.
Hi guys!
I have already installed the version 1.3.18 on my debian sid and it work perfectly. :D

But I have a little problem.
I would like to create a wesnoth server for this version on my pc, but I have found only the package wesnoth-server (the daemon wesnothd) for the old stable version 1.2.x...

My question is how can I do? I cannot found any package for the version 1.3.18...
Thanks for the reply :)
That's pretty strange. How did you manage to install wesnoth 1.3.18 from sid but not wesnoth-server 1.3.18 from sid? Because both binary packages are produced from the same source package and are uploaded at the same time, no matter what hardware architecture you are using (in contrary to the architecture: all packages, which get uploaded together with the powerpc packages due to the fact that I build on that architecture myself). So technically there can't really be any problem with getting wesnoth-server package for an architecture if the wesnoth package for that architecture is available...
See http://packages.debian.org/unstable/wesnoth and http://packages.debian.org/unstable/wesnoth-editor - you won't notice any difference from the one package to the other on the same architecture.

For what it's worth, current unstable has 1.3.19, you might want to upgrade to it. Given that you said you are using unstable you should be able to figure out minor problems like the above yourself - otherwise I would suggest to use testing, if not even stable, there are much more severe problems than this in unstable happening regularly. For stable I am offering backports of the package from testing - that means time line for the final 1.4 release (all fingers crossed) are expected around a week later from http://backports.org/

ciropom++
Posts: 4
Joined: February 24th, 2008, 10:03 pm

Post by ciropom++ » March 1st, 2008, 3:49 pm

I had deleted the folder with the sources, for this reason I cannot been able to uninstall the previous version...

Then I have tried to do make uninstall on the folder that contains the new source (1.3.18 ) and it work.

With the option --enable-server was created a daemon that I could run when I want.
Thanks for the help.
ipse dixit

Post Reply