"Boost headers" error while configuring (Ubuntu)

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

Georex
Posts: 1
Joined: March 27th, 2008, 10:12 pm

Re: "Boost headers" error while configuring (Ubuntu)

Post by Georex »

If you're compiling from the source code, I've found the following configure command to work...

BOOST_LIB=-L/usr/local/lib ./configure --with-boost=/usr/local/include/boost-1_34_1

This seems to allow the configure script to find both the Boost headers and libraries.
You'll need to modify the above locations for your system of course.
invalid
Posts: 4
Joined: August 15th, 2006, 11:05 pm
Location: US

Re: "Boost headers" error while configuring (Ubuntu)

Post by invalid »

Georex wrote:If you're compiling from the source code, I've found the following configure command to work...

BOOST_LIB=-L/usr/local/lib ./configure --with-boost=/usr/local/include/boost-1_34_1

This seems to allow the configure script to find both the Boost headers and libraries.
You'll need to modify the above locations for your system of course.
I sure feel like an idiot now...

Thank you

I can confirm this works...
shevegen
Posts: 286
Joined: June 3rd, 2004, 4:35 pm

Re: "Boost headers" error while configuring (Ubuntu)

Post by shevegen »

guess this is good wiki info!
daridac
Posts: 1
Joined: April 23rd, 2008, 8:29 am

Re: "Boost headers" error while configuring (Ubuntu)

Post by daridac »

I`ve got the same problems.
configure: error: Could not find Boost headers version >= 1.33
have done all, that recomended:
sudo apt-get build-dep wesnoth
sudo apt-get install python-dev libboost libboost-iostreams-dev
And now I have an error:
checking for the Boost iostreams library... configure: error: Cannot compile a test that uses Boost iostreams
I have the newest versions of all that packages. What`s wrong? Pleas help me - I`m not a linux guru at all
User avatar
Chris7mas
Posts: 55
Joined: October 28th, 2006, 8:52 am
Location: Bucharest
Contact:

Re: "Boost headers" error while configuring (Ubuntu)

Post by Chris7mas »

I had the same problem:

Code: Select all

configure: error: Could not find Boost headers version >= 1.33
Thanks for the tip about the 'pyste' package, it configures now. So, on Debian Lenny:

Code: Select all

apt-get install libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl-net1.2-dev libboost-dev pyste
./configure
make
make install
And it works!
Overhead the albatross hangs motionless upon the air...
TuxArena - Linux news, tutorials, articles & reviews
Kristjan

Re: "Boost headers" error while configuring (Ubuntu)

Post by Kristjan »

daridac wrote: And now I have an error:
...
I have the newest versions of all that packages. What`s wrong? Pleas help me - I`m not a linux guru at all
Install pyste package
Post Reply