(Solved) Compiling on Linux Mint 18.1 Serena

Get help with compiling or installing the game, and discuss announcements of new official releases.

Moderators: Forum Moderators, Developers

(Solved) Compiling on Linux Mint 18.1 Serena

Postby Ravana » September 19th, 2017, 8:39 pm

Commands that solved it
Code: Select all
sudo add-apt-repository ppa:pkg-games/wesnoth-devel
sudo apt-get build-dep wesnoth-1.13
sudo add-apt-repository ppa:vincent-c/wesnoth
sudo apt-get build-dep wesnoth-1.12
sudo apt-get update
scons --config=force





I have been trying to find all the dependencies, but havent managed so far.

Build log
Code: Select all
ravana@ravana-think ~/wesnoth/wesnoth-master $ scons
scons: Reading SConscript files ...
Saved options: default_targets = 'wesnoth,wesnothd'
Building Wesnoth version 1.13.8+dev
---[checking prerequisites]---
Checking for C header file poll.h... (cached) yes
Checking for C header file sys/poll.h... (cached) yes
Checking for C header file sys/select.h... (cached) yes
Checking for C header file sys/sendfile.h... (cached) yes
Checking for C function sendfile()... (cached) yes
Checking for C library m... (cached) yes
Checking for C function round()... (cached) yes
Checking if floating point numbers are in the IEEE 754 format... (cached) yes
Checking whether C++ compiler works (g++ version >= 4.8 required)... (cached) yes
Checking for C library libcrypto... (cached) no
Checking for Boost iostreams library version >= 1.48.0... (cached) no
Checking for gzip support in Boost Iostreams... (cached) no
Checking for bzip2 support in Boost Iostreams... (cached) no
Checking for C library pthread... (cached) yes
Checking for Boost system library... (cached) no
Checking for Boost asio library... (cached) no
Checking for Boost random library version >= 1.48.0... (cached) no
Checking for Boost smart_ptr library... (cached) yes
Checking for Boost system library... (cached) no
Checking for Boost filesystem library version >= 1.48.0... (cached) no
Checking for Boost locale library... (cached) no
WARNING: Base prerequisites are not met
Checking for Simple DirectMedia Layer library version >= 2.0.4... (cached) yes
Checking for SDL2_ttf library... (cached) yes
Checking for SDL2_mixer library... (cached) yes
Checking for SDL2_image library... (cached) yes
Checking for C library vorbisfile... (cached) no
Checking for Ogg Vorbis support in SDL... (cached) yes
Checking for PNG support in SDL... (cached) yes
Checking for JPG support in SDL... (cached) yes
Checking for Cairo... (cached) yes
Package pangocairo was not found in the pkg-config search path.
Perhaps you should add the directory containing `pangocairo.pc'
to the PKG_CONFIG_PATH environment variable
No package 'pangocairo' found
Checking for Pango with cairo backend... (cached) no
Checking for fontconfig... (cached) yes
Checking for Boost program_options library version >= 1.48.0... (cached) yes
Checking for Boost thread library... (cached) no
Checking for Boost regex library... (cached) yes
WARNING: Client prerequisites are not met. wesnoth cannot be built
WARNING: Unit tests are disabled because their prerequisites are not met
  If any config checks fail, look in build/config.log for details
  If a check fails spuriously due to caching, use --config=force to force its rerun
---[applying configuration]---
scons: done reading SConscript files.
scons: Building targets ...
error_action(["wesnoth"], [])
scons: *** [wesnoth] Target disabled because its prerequisites are not met
scons: building terminated because of errors.


How to get the missing ones?
User avatar
Ravana
Moderator
 
Posts: 1481
Joined: January 29th, 2012, 12:49 am
Location: Estonia

Re: Compiling on Linux Mint 18.2

Postby Ravana » September 19th, 2017, 10:13 pm

Updated to 18.2 as suggested.

Log after using sudo apt-get build-dep wesnoth-1.13

Code: Select all
ravana@ravana-think ~/wesnoth/wesnoth-master $ scons
scons: Reading SConscript files ...
Saved options: default_targets = 'wesnoth,wesnothd'
Building Wesnoth version 1.13.8+dev
---[checking prerequisites]---
Checking for C header file poll.h... (cached) yes
Checking for C header file sys/poll.h... (cached) yes
Checking for C header file sys/select.h... (cached) yes
Checking for C header file sys/sendfile.h... (cached) yes
Checking for C function sendfile()... (cached) yes
Checking for C library m... (cached) yes
Checking for C function round()... (cached) yes
Checking if floating point numbers are in the IEEE 754 format... (cached) yes
Checking whether C++ compiler works (g++ version >= 4.8 required)... (cached) yes
Checking for C library libcrypto... (cached) no
Checking for Boost iostreams library version >= 1.48.0... (cached) no
Checking for gzip support in Boost Iostreams... (cached) no
Checking for bzip2 support in Boost Iostreams... (cached) no
Checking for C library pthread... (cached) yes
Checking for Boost system library... (cached) no
Checking for Boost asio library... (cached) no
Checking for Boost random library version >= 1.48.0... (cached) no
Checking for Boost smart_ptr library... (cached) yes
Checking for Boost system library... (cached) no
Checking for Boost filesystem library version >= 1.48.0... (cached) no
Checking for Boost locale library... (cached) no
WARNING: Base prerequisites are not met
Checking for Simple DirectMedia Layer library version >= 2.0.4... (cached) yes
Checking for SDL2_ttf library... (cached) yes
Checking for SDL2_mixer library... (cached) yes
Checking for SDL2_image library... (cached) yes
Checking for C library vorbisfile... (cached) no
Checking for Ogg Vorbis support in SDL... (cached) yes
Checking for PNG support in SDL... (cached) yes
Checking for JPG support in SDL... (cached) yes
Checking for Cairo... (cached) yes
Checking for Pango with cairo backend... (cached) yes
Checking for fontconfig... (cached) yes
Checking for Boost program_options library version >= 1.48.0... yes
Checking for Boost thread library... no
Checking for Boost regex library... yes
WARNING: Client prerequisites are not met. wesnoth cannot be built
WARNING: Unit tests are disabled because their prerequisites are not met
  If any config checks fail, look in build/config.log for details
  If a check fails spuriously due to caching, use --config=force to force its rerun
---[applying configuration]---
scons: done reading SConscript files.
scons: Building targets ...
error_action(["wesnoth"], [])
scons: *** [wesnoth] Target disabled because its prerequisites are not met
scons: building terminated because of errors.
User avatar
Ravana
Moderator
 
Posts: 1481
Joined: January 29th, 2012, 12:49 am
Location: Estonia

Re: Compiling on Linux Mint 18.1 Serena

Postby Ravana » September 19th, 2017, 10:17 pm

scons --config=force seems to have fixed it.
User avatar
Ravana
Moderator
 
Posts: 1481
Joined: January 29th, 2012, 12:49 am
Location: Estonia

Re: (Solved) Compiling on Linux Mint 18.1 Serena

Postby Pentarctagon » September 19th, 2017, 11:54 pm

The list of all things that are required (and possibly a few that aren't) that I use for 18.2:
Code: Select all
libboost-filesystem1.58-dev libboost-filesystem1.58.0 libboost-iostreams1.58-dev libboost-iostreams1.58.0 libboost-locale1.58-dev libboost-locale1.58.0 libboost-regex1.58-dev libboost-regex1.58.0 libboost-serialization1.58-dev libboost-serialization1.58.0 libasio-dev libboost-program-options1.58-dev libboost-program-options1.58.0 libboost-random1.58-dev libboost-random1.58.0 libboost-system1.58-dev libboost-system1.58.0 libboost-thread1.58-dev libboost-thread1.58.0 libbz2-1.0 libbz2-dev bzip2 zlib1g zlib1g-dev libpangocairo-1.0-0 libssl-dev libsdl2-2.0-0 libsdl2-dev libsdl2-image-2.0-0 libsdl2-image-dev libsdl2-mixer-2.0-0 libsdl2-mixer-dev libsdl2-ttf-2.0-0 libsdl2-ttf-dev libpng12-0 libpng12-dev libreadline6-dev libvorbis-dev libcairo2 libcairo2-dev libpango-1.0-0 libpango1.0-dev git scons gcc
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Forum Administrator
 
Posts: 2976
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: (Solved) Compiling on Linux Mint 18.1 Serena

Postby Pentarctagon » December 2nd, 2017, 6:22 am

An update on this: Wesnoth now uses a Ubuntu 16.04 docker image to run its automated travis linux builds, and all the dependencies it needs(as well as the optional ones) installed can be found here.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code
User avatar
Pentarctagon
Forum Administrator
 
Posts: 2976
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)


Return to Release Announcements, Compiling & Installation

Who is online

Users browsing this forum: No registered users and 4 guests