"Searching for installing add-ons" crash on Windows 7

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

"Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 9th, 2019, 8:11 pm

Operating system: Windows 7 Home Premium (czech)
Wesnoth version: 1.14.7

Strength,

I downloaded the 1.14.7 Win32 installer and installed the game (without any errors). I launch Wesnoth then, but wesnoth game client crash next after the "searching for installing add-ons" message appears. I send you the printscreen and log file.

The last record wrote in log is "Setting mode to 1280x720".

Maybe here is the key. I still used 1024 x 768 resolution on my old LCD L365 EIZO.

Thanks for help.
Attachments
wesnoth-20190509-205838-3356.log
(442 Bytes) Downloaded 87 times
wesnoth.jpg

User avatar
josteph
Developer
Posts: 678
Joined: August 19th, 2017, 6:58 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by josteph » May 10th, 2019, 9:56 am

Could you run wesnoth --log-debug=config and send the resulting log file as well?
geronimo68 wrote:
May 9th, 2019, 8:11 pm
The last record wrote in log is "Setting mode to 1280x720".

Maybe here is the key. I still used 1024 x 768 resolution on my old LCD L365 EIZO.
I don't think that's very likely, but to rule this out, try editing the preferences file and set xresolution/xwindowsize/yresolution/ywindowsize to 800/800/600/600 respectively.

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 10th, 2019, 12:05 pm

OK, i am sending big log file.
Attachments
wesnoth-20190510-134222-3644.log.gz
(31.31 KiB) Downloaded 78 times

User avatar
josteph
Developer
Posts: 678
Joined: August 19th, 2017, 6:58 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by josteph » May 10th, 2019, 1:21 pm

geronimo68 wrote:
May 10th, 2019, 12:05 pm

Code: Select all

20190510 13:43:27 info config: refreshing add-on versions cache
20190510 13:43:27 info config: time elapsed: 64451 ms
Thanks. The log shows it passed the addons stage: https://github.com/wesnoth/wesnoth/blob ... #L717-L726

Did it really take 64 seconds? That's probably because of the log level (you can use --log-info=config to generate less chatty logs) but it still seems like a lot.

At this point I'd really like to get a backtrace, but viewtopic.php?f=4&t=16163#w0windows ...

Does the windows error dialog in your screenshot say anything useful?

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 10th, 2019, 2:07 pm

No, it says nothing. In english:

Wesnoth Game Client has stopped working
A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available.

This I found about that error on internet:
It happens when Windows detects that a loop, such as a while (true) {} fails to exit. The application in question should at this point send a message to Windows, telling it that it’s still working, but it fails, resulting in this error message.



Yes, 64 sec, i think comp freeze :D

Some rows from DxDiag.txt:
Processor: AMD Athlon(tm) 64 Processor 3200+, ~2.0GHz
Memory: 4096MB RAM
DirectX Version: DirectX 11
Card name: ATI Radeon HD 3600 Series
Display Memory: 2298 MB

Sound Devices:
Description: Reproductors (Realtek AC'97 Audio)
Driver Name: RTKVAC64.SYS
Driver Version: 6.00.0001.6305 (English)
Driver Attributes: Final Retail
Date and Size: 6/18/2009 19:45:06, 3491616 bytes

I can try some older version of Wesnoth.
Last edited by geronimo68 on May 19th, 2019, 11:38 pm, edited 3 times in total.

User avatar
josteph
Developer
Posts: 678
Joined: August 19th, 2017, 6:58 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by josteph » May 10th, 2019, 4:03 pm

Try an older 1.14 version if you can.

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 10th, 2019, 6:29 pm

Version 1.13.14 crashes some steps further :D
Attachments
wesnoth-20190510-201726-1252.log.gz
(31.6 KiB) Downloaded 78 times
wesnoth1-13-14.jpg

User avatar
josteph
Developer
Posts: 678
Joined: August 19th, 2017, 6:58 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by josteph » May 10th, 2019, 6:59 pm

Did you interact with the title screen in any way before you got that error, or did it show as soon as the title screen loaded?

It's a wild guess, but could you go to the preferences file and change the value of locale to "en_US", and see if that helps? You're on windows, is there any chance that the root problem has to do with Windows being in Czech?

Probably need a Windows user or developer to take over from here, I'm on Linux :(

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 10th, 2019, 8:02 pm

(1.13.14) I can nothing to do, that error show as soon as the title screen loaded.

But some progress we have ...

Version 1.12.6 looks stable and i can switch to English(US) and Fullscreen, until ...

i choose campaign, for example Heir to the Throne, after many dialogs (last speaks Chantal and Delfador), after blinking signpost at northwest corner and centering on Konrad, game crash again, just before scenario objectives box is expected.

I have no idea where the log file is, because the log directory do not exist.
Attachments
wesnoth1-12-6.jpg

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 10th, 2019, 10:44 pm

Next I tried ver. 1.11.19, but it behaves same as 1.12.6.

And what do you think about 1.10.7 now ?
BINGO !!!
It works !

So, you may investigate the problem, you have a few indicies now.

Bye, i rush into battle ... :D

Mawmoocn
Posts: 97
Joined: March 16th, 2019, 3:54 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by Mawmoocn » May 11th, 2019, 1:35 am

Greetings,

For Wesnoth 1.12.6, have you tried to turn off music and sound effects?

For some weird reason, I had problems with those, not sure if it still affects those.

User avatar
geronimo68
Posts: 7
Joined: May 9th, 2019, 7:12 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by geronimo68 » May 19th, 2019, 11:34 pm

Thanks for tip Mawmoocn,

when I turn off sound effects (only), I can play the first campaign map a few turns yet.
When i turn off music too, I did play the map to the end. :D

It seems this will be a problem with sound drivers, but i have the last Realtek AC97 Audio drivers for Windows 7.

Mawmoocn
Posts: 97
Joined: March 16th, 2019, 3:54 pm

Re: "Searching for installing add-ons" crash on Windows 7

Post by Mawmoocn » May 21st, 2019, 7:00 pm

Greetings,

I lack time to confirm things but I seem to remember that fullscreen occasionally causes crashes.

Not sure if it the problems for Wesnoth 1.12.6, applies for 1.14.7, if it does you can edit your preferences file, located in C:\Users\yourname>\AppData\Local\VirtualStore\Program Files\Battle for Wesnoth <version> or Documents\My Games\Wesnoth<version>.

After you located your preferences file, open it with your text editor(notepad or something similar), find and edit these preferences from yes to no.

fullscreen=no
sound=no
UI_sound=no
music=no


I hope it could work for you!

Post Reply