harm_unit doesnt fire advance event when experience=yes

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:

harm_unit doesnt fire advance event when experience=yes

Postby gfgtdf » May 21st, 2013, 7:50 pm

my problem is:
harm_unit doesnt fire post advance event when experience=yes.
using wesnoth 10.6 on win 7 x64.

is this intendet? (if yes then why?).

i think the reason is, that harm_unit uses unstrore unit at the end with advance = yes and fire_event = no by default.
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.
gfgtdf
Developer
 
Posts: 313
Joined: February 10th, 2013, 2:25 pm

Re: harm_unit doesnt fire advance event when experience=yes

Postby Anonymissimus » May 21st, 2013, 11:43 pm

Probably not intended. I added [unstore_unit]fire_event= some time after harm_unit was added and chose default no, which should have changed harm_unit's behavior in that aspect.
You can report it as a bug at gna: http://gna.org/bugs/?group=wesnoth
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign
Anonymissimus
Developer
 
Posts: 2418
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: harm_unit doesnt fire advance event when experience=yes

Postby gfgtdf » May 22nd, 2013, 12:31 pm

hm i dont find a "post bug" button, do i have to Create anaccount?
and when i post it do i have to Assigned to it to someone?

EDIT: problems solved, found the button
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.
gfgtdf
Developer
 
Posts: 313
Joined: February 10th, 2013, 2:25 pm

Re: harm_unit doesnt fire advance event when experience=yes

Postby Elvish_Hunter » June 16th, 2013, 2:36 pm

Fixed in master: http://git.io/YWkPPA .
However, I'm undecided if this fix should be backported to 1.10 or not, because we don't have current plans for a 1.10.7 release, and this may cause OoS problems if a fixed version plays against a non-fixed version. :hmm:
For bug report purpose: I'm playing Wesnoth 1.11.15 on Windows 7 and trunk on Linux Xubuntu 14.04.
Current maintainer of The Sojournings of Grog , Children of Dragons , A Rough Life and Wesnoth Lua Pack
Co-author of The White Troll
User avatar
Elvish_Hunter
Developer
 
Posts: 1154
Joined: September 4th, 2009, 2:39 pm
Location: Lintanir Forest...

Re: harm_unit doesnt fire advance event when experience=yes

Postby ivanovic » June 25th, 2013, 9:35 am

Elvish_Hunter wrote:Fixed in master: http://git.io/YWkPPA .
However, I'm undecided if this fix should be backported to 1.10 or not, because we don't have current plans for a 1.10.7 release, and this may cause OoS problems if a fixed version plays against a non-fixed version. :hmm:

It should not be backported if it would result in OOS errors.
User avatar
ivanovic
Lord of Translations
 
Posts: 1146
Joined: September 28th, 2004, 10:10 pm
Location: Germany


Return to Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest