OS X 10.7.4 > Wesnoth unplayable once more

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
ozean
Posts: 90
Joined: September 27th, 2005, 5:19 pm
Location: Norway
Contact:

OS X 10.7.4 > Wesnoth unplayable once more

Post by ozean » May 10th, 2012, 9:36 am

It seems as if we have some new problems with Wesnoth in the most recent update to OS X Lion. (Running on a MacBook Pro 2,2 with 3GB RAM.) At the home screen and in dialogues Wesnoth stalls almost completely, often to the point where I have to force-quit it.

Console repeats entries like these:

Code: Select all

10.05.12 11:28:58,985 [0x0-0xa00a0].org.wesnoth.Wesnoth: Battle for Wesnoth v1.10.2
10.05.12 11:28:58,985 [0x0-0xa00a0].org.wesnoth.Wesnoth: Started on Thu May 10 11:28:58 2012
10.05.12 11:29:00,079 [0x0-0xa00a0].org.wesnoth.Wesnoth: Data directory: /Applications/Wesnoth.app/Contents/Resources/./
10.05.12 11:29:00,079 [0x0-0xa00a0].org.wesnoth.Wesnoth: User configuration directory: /Users/ozean/Library/Application Support/Wesnoth_1.10
10.05.12 11:29:00,079 [0x0-0xa00a0].org.wesnoth.Wesnoth: User data directory: /Users/ozean/Library/Application Support/Wesnoth_1.10
10.05.12 11:29:00,079 [0x0-0xa00a0].org.wesnoth.Wesnoth: Cache directory: /Users/ozean/Library/Application Support/Wesnoth_1.10/cache
10.05.12 11:29:01,097 [0x0-0xa00a0].org.wesnoth.Wesnoth: Checking video mode: 1440x900x32...
10.05.12 11:29:01,130 [0x0-0xa00a0].org.wesnoth.Wesnoth: setting mode to 1440x900x32
10.05.12 11:29:12,958 Wesnoth: CGContextSetFont: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextSetFontSize: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextSetTextMatrix: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextSaveGState: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextSetCompositeOperation: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextFillRects: invalid context 0x0
10.05.12 11:29:12,969 Wesnoth: CGContextRestoreGState: invalid context 0x0
10.05.12 11:29:12,970 Wesnoth: CGContextSetRGBFillColor: invalid context 0x0
10.05.12 11:29:12,970 Wesnoth: CGContextShowGlyphsAtPoint: invalid context 0x0
10.05.12 11:29:12,970 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSetFont: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSetFontSize: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSetTextMatrix: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSaveGState: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSetCompositeOperation: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextFillRects: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextRestoreGState: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextSetRGBFillColor: invalid context 0x0
10.05.12 11:29:12,971 [0x0-0xa00a0].org.wesnoth.Wesnoth: May 10 11:29:12 Dorsch.local Wesnoth[7812] <Error>: CGContextShowGlyphsAtPoint: invalid context 0x0
From time to time and with some patience it is possible to bridge these problems, but in longer dialogues (such as in the beginning of a scenario during campaign play), this is not possible. Anyone else experiencing this? Should I report this to gna?

I checked permissions and fonts, rebuild all kinds of caches, but nothing helps…

User avatar
Crow_T
Posts: 850
Joined: February 24th, 2011, 4:20 am

Re: OS X 10.7.4 > Wesnoth unplayable once more

Post by Crow_T » May 11th, 2012, 10:07 pm

This is probably a solution you don't want to hear, but I initially dual-booted my macbook with ubuntu for all my favorite foss programs- they just work better there. These days it runs only 'nix, which is kind of funny on startup, no apple, just a folder with a question mark in it heh. I understand this method is on the nerdy side though :whistle:

ozean
Posts: 90
Joined: September 27th, 2005, 5:19 pm
Location: Norway
Contact:

Re: OS X 10.7.4 > Wesnoth unplayable once more

Post by ozean » May 12th, 2012, 8:28 am

I actually run Wine or Winebottler, but if possible, I of course prefer native versions. In addition, I’ve been running the OS X version of Wesnoth since version 0.7 or something like that… and it has been smooth sailing for almost all of the last seven years. That is how great the Wesnoth devs are!
:D

User avatar
Alarantalara
Art Contributor
Posts: 782
Joined: April 23rd, 2010, 8:17 pm
Location: Canada

Re: OS X 10.7.4 > Wesnoth unplayable once more

Post by Alarantalara » May 12th, 2012, 8:36 pm

The errors you present have been present for some time (and on earlier systems) without causing crashes so they may not be related to your problem. As I recall, the last time I looked into them, they were generated by one of the external libraries used for text rendering (either Pango or Cairo, I don't recall which).

User avatar
Kymille
Posts: 104
Joined: October 25th, 2009, 4:55 am

Re: OS X 10.7.4 > Wesnoth unplayable once more

Post by Kymille » May 12th, 2012, 9:57 pm

Just to confirm the previous comment, I have all those errors on MacOS 10.6.8 when I start a campaign, and zillions of Pango errors later, but wesnoth (1.10.2) does not freeze or crash.

ozean
Posts: 90
Joined: September 27th, 2005, 5:19 pm
Location: Norway
Contact:

Re: OS X 10.7.4 > Wesnoth unplayable once more

Post by ozean » May 13th, 2012, 8:18 am

Then I guess I we have to ignore these entries and only focus on the fact that Wesnoth under 10.7.4 has the tendency to hang either in the start screen or in the course of longer dialogues.

The hang is also never absolute, more of a slowdown, but after a while it slows the UI so much that it is impossible to click to move the dialogue further – keyboard input is also not accepted anymore. Usually, the cursor can still be moved (not fluidly though). The only thing that works at that stage is to hit command-alt-esc to force quit Wesnoth. I can make a screen recording, if that is of any help…

Post Reply