Error:Could not auto save the game

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
kolz
Posts: 2
Joined: January 28th, 2012, 11:57 am

Error:Could not auto save the game

Post by kolz » February 2nd, 2012, 9:42 am

Wesnoth 1.10.0
Windows 7
Single and mutiplay game
any map (ANL, Den of Onis, etc) begins, message "Could not auto save tha game"

solve: Change the save name (like "aa") no error and able to save. But anyway as next turn begins, same error shows up.

Tried reinstal game 4times.
changed install place default(program files(x86)) to other place (drive c any name), changed save data place to default to same as installed folder. But it would not solve case. Help.. I did not experience any error with Wesnoth 1.8 nor 1.9.

Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: Error:Could not auto save the game

Post by Anonymissimus » February 2nd, 2012, 2:12 pm

Which language do you have set ?
I suppose that your language contains some "unusual" characters which cause it, such problems happen rather often it seems.
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign

deathmothon
Posts: 9
Joined: September 30th, 2008, 2:36 am

Re: Error:Could not auto save the game

Post by deathmothon » February 4th, 2012, 9:08 am

I'm getting this problem as well, though only on 1 mission. Vista64, English. It started happening when I beat HttT - Princess of Wesnoth. I think it has something to do with the default name of the next mission, Valley of Death. The default save name looks like "HttT-The Valley of Death --- ... Turn 1". (the --- is one solid line the width of roughly 3 regular -) I think that's the culprit. I delete that and it works. I also can't scroll -->. I have to scroll <-- until it raps around and goes to the far right side. And after I do that the cursor doesn't match with the characters anymore. It might just be a font issue or something with me, but just wanted to make sure it's not a global problem.

Max
Posts: 1449
Joined: April 13th, 2008, 12:41 am

Re: Error:Could not auto save the game

Post by Max » February 4th, 2012, 6:44 pm


deathmothon
Posts: 9
Joined: September 30th, 2008, 2:36 am

Re: Error:Could not auto save the game

Post by deathmothon » February 4th, 2012, 7:06 pm

Max wrote:can you attach your error log (http://forums.wesnoth.org/viewtopic.php?f=4&t=25660)?
You mean this?
20120204 03:36:35 error engine: The game could not be saved: save_game_failed: Could not write to file20120204 03:36:35 error general: The game could not be saved: save_game_failed: Could not write to file

20120204 03:36:43 error engine: Could not auto save the game. Please save the game manually.save_game_failed: Could not write to file20120204 03:36:43 error general: Could not auto save the game. Please save the game manually.save_game_failed: Could not write to file
It's just a bunch of those 2. One for auto and one for regular saving.

Max
Posts: 1449
Joined: April 13th, 2008, 12:41 am

Re: Error:Could not auto save the game

Post by Max » February 4th, 2012, 7:30 pm

could you attach the last save before this happens? it sounds like it can be reproduced on your machine so someone who can debug it might have a chance to fix it.

deathmothon
Posts: 9
Joined: September 30th, 2008, 2:36 am

Re: Error:Could not auto save the game

Post by deathmothon » February 5th, 2012, 8:28 am

This is the last save I have before I got to Valley of death I think. It just happens with The Valley of Death mission. After I beat it, auto and default named saves worked fine.
Attachments
HttT-The_Princess_of_Wesn..._Turn_11.gz
(53.04 KiB) Downloaded 140 times

Max
Posts: 1449
Joined: April 13th, 2008, 12:41 am

Re: Error:Could not auto save the game

Post by Max » February 6th, 2012, 4:02 pm

unable to reproduce this but the "—" sign is an UTF-8 char so i guess that might be part of the problem...
deathmothon wrote:I also can't scroll -->. I have to scroll <-- until it raps around and goes to the far right side. And after I do that the cursor doesn't match with the characters anymore. It might just be a font issue or something with me, but just wanted to make sure it's not a global problem.
same here.

Post Reply