Multiplayer Server Crashing 1.8.6?

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
User avatar
Lalindo
Posts: 24
Joined: May 10th, 2008, 8:40 pm
Location: Standing right behind you.

Multiplayer Server Crashing 1.8.6?

Post by Lalindo »

Hi. Well. I have a problem. First off (to get the easy stuff out of the way) I'm running Wesnoth 1.8.6 (English) on Mac OS X 10.6.3 (On a MacBook Pro).

My problem? Basically, every time I try to load the multiplayer server, the application crashes. It gets right to the multiplayer server interface for about a second (not loading any games or online people) and crashes immediately. It's just that function, however - I started a mainline campaign, an add-on campaign and a local multiplayer game. I tried emptying my cache (in Library/Wesnoth_1.8/cache). I also tried (noting the similarity between this problem and a problem [I assume it's fixed, I got to it by searching 'multiplayer crashing application'] with 1.9.0, where you couldn't join the multiplayer server without the application crashing) to join a specific server (trying server.wesnoth.org:14997 as suggested and that thread, as well as 14999 [which ended up giving me a dialogue box saying that I needed 1.6 to use that server]). I've also attached the last error report as an rtf file. I ran - and crashed - the application several times, and I'm not sure which would be the most useful. Let me know if you'd like a different one.

*side note: Long parenthetical statements, I know, and I apologise.. I hope they're not too convoluted.
Attachments
Error Report - Wesnoth 1.8.6.rtf
(34.55 KiB) Downloaded 338 times
"Try to restate the purpose of the story. In your native tongue, if necessary.
If English is your native tongue, well...
I never did like our public school system."
-Maeglin Dubh

kittydiln
Posts: 1
Joined: May 29th, 2011, 2:55 am

Re: Multiplayer Server Crashing 1.8.6?

Post by kittydiln »

I am having the same problem. Any help please! :(






Professor Katherine Bodenhamer Anderson
Last edited by kittydiln on July 5th, 2011, 11:36 am, edited 1 time in total.

Atz
Art Contributor
Posts: 313
Joined: August 21st, 2008, 2:22 am

Re: Multiplayer Server Crashing 1.8.6?

Post by Atz »

I've had similar problems in 1.8.5 and was able to avoid it by switching to the new lobby interface, under Preferences -> Multiplayer at the main menu. Strangely I was able to go back to the old interface a few weeks later and it worked, so I've got no idea what the cause was, but it's worth a try.

User avatar
Lalindo
Posts: 24
Joined: May 10th, 2008, 8:40 pm
Location: Standing right behind you.

Re: Multiplayer Server Crashing 1.8.6?

Post by Lalindo »

I experimented with a few things, nothing worked.. and it's randomly working again. (before I saw this post, I mean) Like you, I have no idea what happened (or why) - I don't even think I restarted my computer. At least it's working again, though.. and I'll keep that in mind if it happens again! Thanks!
"Try to restate the purpose of the story. In your native tongue, if necessary.
If English is your native tongue, well...
I never did like our public school system."
-Maeglin Dubh

User avatar
TheChosenOne
Posts: 216
Joined: April 7th, 2006, 8:26 am
Location: Royal Palace, Weldyn St. 01, Wesnoth 123 456

Re: Multiplayer Server Crashing 1.8.6?

Post by TheChosenOne »

I'm using Wesnoth 1.8.5 on Windows Vista. It has always worked fine until just now...I am using the old mp interface and everytime I try to log into the server, the client closes. However this problem is fixed once I switched to the new interface. On switching back to the old one, it works as usual.

Could this be some kind of bug ?
Numbers do not win a battle
---Konrad III
(A loyal member of the pro-loyalists)

Would you like to translate the Battle of Wesnoth into Indonesian? Then come and join us at http://www.wesnoth.org/wiki/IndonesianTranslation

Post Reply