Error Reading the WML: Mandatory WML child missing but not..

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Lucid
Posts: 3
Joined: October 22nd, 2009, 10:36 pm

Error Reading the WML: Mandatory WML child missing but not..

Post by Lucid »

Error Reading the WML: Mandatory WML child missing but not tested for.

My brother and I are both getting this error on different machines no matter the map. The two maps we have tested it on are: a dark forecast and team survival. The error throws seeming randomly: 4-8 turns in.

We were playing using 1.7.10 1.8 Beta 3 on the official server. I don't recall having this problem on beta 2. Everything runs fine using the stable version.

He is using XP, I am using vista. If you want more specs on our comps let us know. Hope someone knows what was going on.

Ceremute
Posts: 3
Joined: June 18th, 2009, 6:23 pm

Re: Error Reading the WML: Mandatory WML child missing but not..

Post by Ceremute »

Using Beta 4 on official server with friend on one of the four player maps and random maps, getting the same error frequently. One player is using windows 7, the other windows vista although both are now in XP compatability mode. This happens every few turns, but only to the host it seems.

Ariel
Posts: 1
Joined: February 25th, 2010, 12:06 am

Re: Error Reading the WML: Mandatory WML child missing but not..

Post by Ariel »

I have the same problem, using 1.7.13 beta6. This only occurs to the host, but it is fairly frequent, happening at any random time in the game.

booner
Posts: 22
Joined: September 5th, 2008, 3:53 am
Location: Nova Scotia, Canada

Re: Error Reading the WML: Mandatory WML child missing but not..

Post by booner »

OS:
-----

Linux Fedora 11

Version:
-----------

[booner@localhost ~]$ wesnoth --version
Battle for Wesnoth v1.8.0
Started on Thu Apr 8 13:00:10 2010

Battle for Wesnoth 1.8.0

Walkthrough:
------------------

Started a game of Isar Cross as the host. The game went smoothly except for one strange happening. The Player of the east (right) section of the map seemed to go away from keyboard. The Player in the north (top) agreed to take control until their return. It was just a matter of ending the turn for the east (right) faction. We continued on to the next turn. Prior to the east's (right) turn control was given back to the original player. That player still did not respond when it became their turn so we, again, gave control to the north (top) player. That player then reported that he could not move any of the units and could only end turn. He did report that he received the beginning of turn notice and all seemed normal except for the fact that all of his units were un-moveable.

The north (top) player considered the loss of a full turn enough to give up the match. Me (south-bottom) and my team mate said that we would continue play against the ai. The north (top) player then droided both the north (top) and the east (right) factions.

We continued play for a number of turns until receiving the error:

Error while reading the WML:Mandatory WML child missing yet untested for. Please report

We two remaining players were then thrown back to the Lobby.

Saved Game Code:
--------------------------

Turn 16 where crash occured can be read from http://trollkeep.com/error-isar-cross-auto-save16.gz

User avatar
Crab
Inactive Developer
Posts: 200
Joined: March 18th, 2009, 9:42 pm

Re: Error Reading the WML: Mandatory WML child missing but not..

Post by Crab »

Big thanks for reporting!
I've just fixed that particular "Mandatory WML child missing..." bug. The fix is in branches/1.8 in [rev]42123[/rev] and in trunk in [rev]42125[/rev],
and the fix will be included in 1.8.1 and 1.9.0
The usual (not only) cause was 'host sending/receiving a chat message during AI attack'

Post Reply