SurvivalXtreme games won't show up in the multiplayer lobby.

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
Clonkinator
Posts: 676
Joined: July 20th, 2006, 4:45 pm
Location: Germany

SurvivalXtreme games won't show up in the multiplayer lobby.

Post by Clonkinator » January 16th, 2009, 10:28 am

Okay, I've no idea what's going on. I've been wondering since quite some time now why totally noone would join my SurvivalXtreme maps when I tried to hosted one, so I eventually started to wonder if they even showed up in the lobby. And indeed they don't; however, I've no idea why they don't show up as I have hardly changed anything between version 2.10 and 2.11 of the addon, and 2.10 used to show up just fine, as do 'normal' maps like 2p Hamlets. Can someone help me out?

I'm using version 1.4.3 of Wesnoth, in case that's of importance.

Soliton
Site Administrator
Posts: 1594
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Re: SurvivalXtreme games won't show up in the multiplayer lobby.

Post by Soliton » January 16th, 2009, 4:41 pm

Your WML is nested too deep it has more than 30 levels. The server doesn't like that and that sounds like you better refactor your WML.

I'll see about getting a proper error message back to the user though.
"If gameplay requires it, they can be made to live on Venus." -- scott

Clonkinator
Posts: 676
Joined: July 20th, 2006, 4:45 pm
Location: Germany

Re: SurvivalXtreme games won't show up in the multiplayer lobby.

Post by Clonkinator » January 16th, 2009, 6:57 pm

Ahhh... I had no clue that was causing problems. I'll see what I can do about it then. Thank you!

Post Reply