Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

Hi!
I have installed Wesnoth with openSuSE.
But when I try to run it, I do not see the Wesnoth-Logo and after initialization Wesnoth crashes. (I think because the data and the images are not found)
I tried with a 1.4-binary and with a self-compiled-1.5-version.

The data-Directory is:
/usr/local/share/wesnoth/data
The program is:
/usr/local/bin/wesnoth

What could I do?

Thank you for aid.
Jovycos
Full of Nerdiness...

musketaquid
Art Contributor
Posts: 117
Joined: July 18th, 2006, 12:23 am

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by musketaquid »

Start it from a text console and post the output here. It's hard to find the problem without some logging info.

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

Battle for Wesnoth v1.5.2
Started on Sat Aug 9 19:49:01 2008

Data at '/usr/local/share/wesnoth'
20080809 19:49:01 error display: could not open image 'wesnoth-icon.png'
Checking video mode: 1280x970x16...
setting mode to 1280x970x16
20080809 19:49:02 error display: could not open image 'cursors-bw/normal.png'
null neutral surface...
20080809 19:49:02 error display: could not open image 'cursors-bw/wait.png'
null neutral surface...
20080809 19:49:02 error display: loadscreen: Failed to load the logo: /usr/local/share/wesnoth/images/misc/logo.png
set locale to 'de_DE@wesnoth'
set locale to 'de_DE@wesnoth'
set locale to 'de_DE@wesnoth'
null neutral surface...
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining M-Giant Ant to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining M-Fire Dragon to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining M-Giant Scorpion to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining M-Young Ogre to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining M-Cuttle Fish to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Salamander to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Saurian Assassin to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Saurian Chameleon to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Spectre Lizard to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Storm Dragon to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Vampire Lady to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Deep Magus to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Guardian to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Hunter to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Mage to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Sentinel to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Spellcrafter to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Spellwarrior to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Warden to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Warlock to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Naga Warrior Mage to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Nagini Shaman to convert it to using [unit_type]
warning: UnitWML [unit] tag will be removed in 1.5.3, run wmllint on WML defining Nagini Witch to convert it to using [unit_type]
null neutral surface...
no location found for 'data/campaigns/Bad_Moon_Rising/translations', not adding textdomain
no location found for 'data/campaigns/Children_of_Dragons/translations', not adding textdomain
no location found for 'data/campaigns/Die_letzten_Mitwal/translations', not adding textdomain
no location found for 'data/campaigns/Extended_Era/translations', not adding textdomain
no location found for 'data/campaigns/Flight_Freedom_1_3/translations', not adding textdomain
no location found for 'data/campaigns/Forgotten_Legacy/translations', not adding textdomain
no location found for 'data/campaigns/Imperial_Era/translations', not adding textdomain
no location found for 'data/campaigns/Invasion_from_the_Unknown/translations', not adding textdomain
no location found for 'data/campaigns/Legend_of_Wesmere/translations', not adding textdomain
no location found for '=data/campaigns/Lodissea_dei_nereidi/translations', not adding textdomain
no location found for 'data/campaigns/No_Name/translations', not adding textdomain
no location found for 'data/campaigns/The_Unstoppable_Legion/translations', not adding textdomain
null neutral surface...
null neutral surface...
20080809 19:49:08 error display: could not open image 'misc/logo.png'
20080809 19:49:08 error display: Could not find game logo
20080809 19:49:08 error display: could not open image 'buttons/button.png'
20080809 19:49:08 error display: could not open image 'buttons/button-pressed.png'
20080809 19:49:08 error display: could not open image 'buttons/button-active.png'
20080809 19:49:08 error display: error initializing button!
Could not create button: Image could not be found
Of course I ll run wmllint for MarshMP
But the "20080809-Errors" are terrible, the images are on the right places...
Full of Nerdiness...

musketaquid
Art Contributor
Posts: 117
Joined: July 18th, 2006, 12:23 am

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by musketaquid »

If the images are on the right places as you say, then it can only be a problem with the users rights. Do you have read permission?
Does the same error occur if you start wesnoth as root?

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

I have already tried to set the rights to 0777 - no effect. Same problem as root.
Full of Nerdiness...

musketaquid
Art Contributor
Posts: 117
Joined: July 18th, 2006, 12:23 am

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by musketaquid »

Strange :?

But wait, take a look at this line:
Checking video mode: 1280x970x16...
Maybe some graphics don't like 16 bit mode. Try to change the xserver settings to 24 bits or 32.

But as i see, there is already an error before the video mode setting line. Well i really can't say what's going wrong by now.

User avatar
Iris
Site Administrator
Posts: 6693
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Iris »

musketaquid wrote:Strange :?

But wait, take a look at this line:
Checking video mode: 1280x970x16...
Maybe some graphics don't like 16 bit mode. Try to change the xserver settings to 24 bits or 32.
That shouldn't be the cause of this problem. Judging from the console text, the graphics files are either inaccessible or corrupted. Graphics mode mismatches would cause interesting behavior, but never those messages.

On a side note, Wesnoth should work even at 8 bit mode.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

Same problem with 32 Bits. :(
Full of Nerdiness...

User avatar
Iris
Site Administrator
Posts: 6693
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Iris »

What openSUSE version are you using by the way? I'm using openSUSE 10.3 (x86_64) here and I have had no problems with my custom builds of Wesnoth 1.4 (latest SVN) and 1.5 (latest SVN). I don't recall having problems with the shipped version either. No problems with openSUSE 10.3 (x86) and 10.2 (x86 and x86_64) either.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm (now available for Wesnoth 1.14).

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

OpenSuSE 11.0
I have a very bad gra-card, but Wesnoth only uses SDL and it worked before...
Full of Nerdiness...

suokko
Inactive Developer
Posts: 65
Joined: June 1st, 2006, 4:13 pm

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by suokko »

Try trunnig wesnoth using --log-debug=all
Then post output to here if it doesn't help you finding image locaions where they are looked for.

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

Code: Select all

(wesnoth --log-debug=all | grep '(2008|set|warning|no|found)') &> ./wesnothlog.txt
...doesnt work. :(
Full of Nerdiness...

suokko
Inactive Developer
Posts: 65
Joined: June 1st, 2006, 4:13 pm

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by suokko »

Code: Select all

wesnoth --log-debug=all 2> error.txt
2> redirects stderr

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by AI »

And &> redirects both stdout and stderr.

Maybe not piping through grep will help?

Jovycos
Posts: 59
Joined: October 12th, 2007, 4:15 pm
Location: Germany

Re: Wesnoth 1.4 and 1.5 - openSuSE - Data not found

Post by Jovycos »

@suokko
But this output is too long for an attachement. (~1.2mb).
Full of Nerdiness...

Post Reply