Can't download any extra campaigns/eras/factions

Having trouble with the game? Report issues and get help here. Read this first!

Moderator: Forum Moderators

Forum rules
Before reporting issues in this section, you must read the following topic:
Saint Jack
Posts: 1
Joined: August 9th, 2006, 1:29 am

Can't download any extra campaigns/eras/factions

Post by Saint Jack »

Just like the title says. I can't seem to connect to the server; I keep getting a message saying that the remote host has disconnected. Any suggestions?
torangan
Retired Developer
Posts: 1365
Joined: March 27th, 2004, 12:25 am
Location: Germany

Post by torangan »

State wheter you use 1.0.x or 1.1.x and try it again at a later time. Might be a temporary downtime/hangup of the server. If so, it'll usually be fixed rather soon once it's been brought up to the devs. Best way for that is to join the IRC channel #wesnoth-dev on freenode.org.
WesCamp-i18n - Translations for User Campaigns:
http://www.wesnoth.org/wiki/WesCamp

Translators for all languages required: contact me. No geek skills required!
MadMax
Posts: 1792
Joined: June 6th, 2004, 3:29 pm
Location: Weldyn, Wesnoth

Post by MadMax »

Same here. I have an updated version of FtF sitting on my hard drive, ready to go, but I can't connect to the campaign server to upload it.
"ILLEGITIMIS NON CARBORUNDUM"

Father of Flight to Freedom
http://www.wesnoth.org/wiki/FlightToFreedom
Free
Posts: 82
Joined: October 30th, 2005, 1:51 am

Post by Free »

Yeah, I can't either and tried two different times on 1.1.8.
User avatar
Temuchin Khan
Posts: 1737
Joined: September 3rd, 2004, 6:35 pm
Location: Player 6 on the original Agaia map

Post by Temuchin Khan »

Same problem here.
User avatar
Sapient
Inactive Developer
Posts: 4453
Joined: November 26th, 2005, 7:41 am
Contact:

Post by Sapient »

brunowolf wrote the following in IRC about five days ago:
brunowolff wrote:The move for my server that occured while I was away didn't work out well. I think DSL at the new location didn't happen and will be checking further today. So the web page for downloading campaigns is still unavailable, but hopefully will be available again soon.

I did get an update on my server connection. The delayed DSL install happened yesterday, but there is a problem with the loop. This could be a bad problem since the connection is through a competitor to the local phone comapny, but the phone company needs to fix it. They like to drag these out and then offer to fix it quickly if you switch to them. So the connection could be active in a couple of days or a couple of weeks.
http://www.wesnoth.org/wiki/User:Sapient... "Looks like your skills saved us again. Uh, well at least, they saved Soarin's apple pie."
Bombax
Posts: 3
Joined: August 14th, 2006, 9:33 am
Location: Switzerland

Post by Bombax »

What do I actually need to do to download campaigns?

I just cant figure it out. Id be just awesome, if somebody could explain it to me with all possible details.

Thanx a lot
User avatar
ivanovic
Lord of Translations
Posts: 1147
Joined: September 28th, 2004, 10:10 pm
Location: Germany

Post by ivanovic »

Do not forget, there are two different things:
1) The campaign server:
This one is where the campaigns you reach ingame are actually hosted. This machine was hanging but was just restarted.
2) The Webinterface:
you reach it when you enter http://campaigns.wenoth.org in your browser. This is the one maintained by brunowolff. And it will be down until his server works again.

The Webinterface and the campaign server itself are two independent things.
Bombax
Posts: 3
Joined: August 14th, 2006, 9:33 am
Location: Switzerland

Post by Bombax »

So, how does ist work with the campaign server. How do I get to it?
jg
Posts: 244
Joined: September 12th, 2005, 7:17 am

Post by jg »

Don't know which version of Wesnoth you are using, but normally:

1. Open Wesnoth, click the button 'Get Add-ons', wait till it is finished loading, then you get a list and doubleclick any campaign you want to start the download.

2. Open Wesnoth (this is on earlier versions), press Campaigns button, scroll to the end, press the 'More campaigns' button (not sure about the name of the button) and from then on do the same as above.

jg
tsr
Posts: 790
Joined: May 24th, 2006, 1:05 pm

Post by tsr »

There is a web interface too, try that too (when I tried now both the in-game and the web interface worked, before neither did, so maybe this tip isn't that valuable :D)

/tsr
Flametrooper
Posts: 984
Joined: February 21st, 2006, 11:02 pm
Location: 0x466C616D65

Post by Flametrooper »

I have the same problem (Wesnoth 1.1.8, Windows 2000). I click "Get Add-Ons" and it starts to load, then says: "ERROR: Remote host disconnected." :? I've tried a few times.
EDIT: I just tried again, and it worked. Strange.
hey.
Grevanar
Posts: 1
Joined: September 1st, 2006, 3:28 pm

can't get campaigns

Post by Grevanar »

I can't seem to get any extra campaigns. I have tried the website, but it won't display and gives the error that I can't connect to it. If I try to download campaigns through the game, it says receiving data with a progress bar beneath it that stays at 0%. Even when I left it for like an hour. I run version 1.0.2 for windows. Does anyone have an idea what the problem might be?
User avatar
Noyga
Inactive Developer
Posts: 1790
Joined: September 26th, 2005, 5:56 pm
Location: France

Post by Noyga »

The campaign server had some problem lately, it could be that...
Soliton
Site Administrator
Posts: 1635
Joined: April 5th, 2005, 3:25 pm
Location: #wesnoth-mp

Post by Soliton »

As already mentioned in this thread if the campaign server is unresponsive join IRC and report it and it will get restarted (don't forget to mention which version; stable or development).
The campaign server is unfortunately quite unstable so it can happen quite often. (Developers needed to fix that :wink:) Also when the campaign server is down the backend of the web interface can't connect to it, so it will not work either.
"If gameplay requires it, they can be made to live on Venus." -- scott
Post Reply