SLOW Performance Issues: post here to report

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
notnot
Posts: 3
Joined: July 4th, 2009, 5:18 pm

Re: SLOW Performance Issues: post here to report

Post by notnot » June 10th, 2019, 11:02 am

Pentarctagon wrote:
December 2nd, 2018, 4:00 pm
I'd suggest turning off water animations and see if that helps. You can also try this.

Otherwise, I'd suggest getting a more up to date version via ppa(current is 1.14.5, 1 2) or flatpak, or try using the nvidia blob driver.
None of the above helped in any way. To be more detailed, the real slowness was in the yellow hexagonal cursor not being able to keep up with the mouse pointer. It was lagging way behind and delayed all actions. I downloaded and compiled 1.12 from source.
A new ubuntu update to disco solved my issue with 1.14. It's now as fluid as 1.12 was, even with all animations on.
Thanks for all the work that goes into Wesnoth.

User avatar
EarthCake
Posts: 354
Joined: March 29th, 2019, 1:57 pm
Location: Braavosi

Re: SLOW Performance Issues: post here to report

Post by EarthCake » June 10th, 2019, 11:04 am

You can turn off the colored cursor.

User avatar
beetlenaut
Developer
Posts: 2389
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: SLOW Performance Issues: post here to report

Post by beetlenaut » August 21st, 2019, 9:01 pm

RAMOTTO wrote:
August 21st, 2019, 12:37 pm
whenever I click a catch in the entryway or battle/situation choice screen, it takes around thirty seconds to stack. Its quite irritating.
Welcome to the forums. That does sound irritating, but we can't help you yet because you didn't give us enough information. Look at the first post in this thread. It tells you what information we need. When you say "catch in the entryway," are you talking about a button in the main menu?
Campaigns: Dead Water,
The Founding of Borstep,
Secrets of the Ancients,
and WML Guide

Glxblt76
Posts: 21
Joined: April 28th, 2012, 5:57 pm

Re: SLOW Performance Issues: post here to report

Post by Glxblt76 » November 2nd, 2019, 11:23 pm

Dear fellow Wesnoth players,

I have a very simple lag that is also very irritating in the scenario editor.

I want to make a 200x200 map. I like making large maps and playing 4v4, with 3 computers allies and 4 computer enemies. I like these huge battles, it can go on for months on my computer, it's my playstyle.

Now the problem is that if I generate a 200x200 map, and I click on an hexagon to place some terrain, it will lag like for 5-10 seconds before the terrain is changed. I noticed that this lag scales with map size: it is virtually non-existent for 40x40 maps and starts being noticeable around 100x100 map.

Is there anything I can do to remove this lag so that I can conceive my 200x200 map? Is there any mod? Because right now, I won't wait 10 seconds for every tile to place. With a 40000 tiles maps, it can be pretty long, especially when it's something avoidable.

PS: my computer is windows 10 professional, 1TB SSD, i7-6600 dual core CPU with 16GB of ram, graphic card: NVIDIA GeForce GPU. It seems to be relatively powerful, I don't get why I have lag with such a basic game as Battle for Wesnoth.

Thanks in advance for your help!

User avatar
beetlenaut
Developer
Posts: 2389
Joined: December 8th, 2007, 3:21 am
Location: Washington State
Contact:

Re: SLOW Performance Issues: post here to report

Post by beetlenaut » November 3rd, 2019, 2:22 am

It may be trying to update all of the tile borders every time you add a tile. Try turning off the automatic transition updates. In the menu, go to Map-->Transition Update, and choose the last option. The map will look very basic that way, but it should place tiles a lot faster. You can use Map-->Refresh Display or Ctrl-D to update the display manually when it's convenient.
Campaigns: Dead Water,
The Founding of Borstep,
Secrets of the Ancients,
and WML Guide

gnombat
Posts: 237
Joined: June 10th, 2010, 8:49 pm
Contact:

Re: SLOW Performance Issues: post here to report

Post by gnombat » November 3rd, 2019, 4:17 pm

The map editor in Wesnoth 1.12 seems to work better for large maps. (Actually the Wesnoth 1.8 map editor is even better yet.)

Post Reply