Mods not appearing in any campaigns

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:
Post Reply
tafm1803
Posts: 4
Joined: September 12th, 2018, 6:02 pm

Mods not appearing in any campaigns

Post by tafm1803 » September 12th, 2018, 6:21 pm

I downloaded a bunch of mods: unit line changes, unit replacements, etc. I went to try them out in an official campaign, and only one (XP bank mod) appeared in the dropdown checkbox menu for all of the campaigns. They all appear when I create a local game for multiplayer, and they are all installed and updated when I check my add-on list. I tried uninstalling the XP bank mod. I have tried restarting both Wesnoth itself and my computer. I have checked the forums for the same problem, and all I can find is new players who have installed an mp scenario or some other thing unaware that it is not a user made campaign. I think the installed mods may have appeared at first and then disappeared after I started a campaign. I think I may have encountered the same problem on an older version, though that was a while back. Below is my info as required by the forum.

The Battle for Wesnoth version 1.14.4
Running on Microsoft Windows 10 (10.0.17134)

Game paths
==========

Data dir: C:\Program Files (x86)\Battle for Wesnoth 1.14.4
User config dir: C:\Users\USER\OneDrive\Documents\My Games\Wesnoth1.14
User data dir: C:\Users\USER\OneDrive\Documents\My Games\Wesnoth1.14
Saves dir: C:\Users\USER\OneDrive\Documents\My Games\Wesnoth1.14\saves
Add-ons dir: C:\Users\USER\OneDrive\Documents\My Games\Wesnoth1.14\data\add-ons
Cache dir: C:\Users\USER\OneDrive\Documents\My Games\Wesnoth1.14\cache

Libraries
=========

Boost: 1.59
OpenSSL/libcrypto: 1.1.0f (runtime 1.1.0f)
Cairo: 1.10.2 (runtime 1.10.2)
Pango: 1.30.1 (runtime 1.30.1)
SDL: 2.0.4 (runtime 2.0.4)
SDL_image: 2.0.0 (runtime 2.0.0)
SDL_mixer: 2.0.0 (runtime 2.0.0)
SDL_ttf: 2.0.12 (runtime 2.0.12)

Features
========

Experimental OpenMP support: yes
JPG screenshots: no
Lua console completion: yes
Legacy bidirectional rendering: no
Win32 notifications back end: yes

User avatar
Ravana
Moderator
Posts: 1874
Joined: January 29th, 2012, 12:49 am
Location: Estonia
Contact:

Re: Mods not appearing in any campaigns

Post by Ravana » September 12th, 2018, 8:07 pm

Most mods are designed to only support multiplayer.

tafm1803
Posts: 4
Joined: September 12th, 2018, 6:02 pm

Re: Mods not appearing in any campaigns

Post by tafm1803 » September 13th, 2018, 6:21 am

These seem like they wouldn't be all that useful for multi player though, after all the multiplayer games usually end before any unit gets to level 3, or so I've heard.

enclave
Posts: 892
Joined: December 15th, 2007, 8:52 am

Re: Mods not appearing in any campaigns

Post by enclave » September 13th, 2018, 6:50 am

the mod designers/creators may not be aware of their mod only working in MP. For example I made couple of mods, but it's first time I hear that the mods can be "designed" or "not designed" for multipplayer only... I have no idea how to make a mod appear in checkbox for campaign and i have no idea if my mods support it (would need to go read about it, if I was interested at this time of my life.. which i'm not unfortunately as i have no time for any modifications). Is it some new 1.14 thing? or...?

my advice for you (tafm1803) personally then would be to find out who created these mods and request them in forum with private message or find their posts/threads or whatever else way you can find, just basically ask them to modify their mod to be compatible for single player campaigns or whatever you need exactly... if somebody asked me for such a change, I most probably would do it in most circumstances.. so don't be shy, just ask them.

User avatar
James_The_Invisible
Posts: 465
Joined: October 28th, 2012, 1:58 pm
Location: Somewhere in the Northlands, fighting dark forces

Re: Mods not appearing in any campaigns

Post by James_The_Invisible » September 13th, 2018, 8:38 am

enclave wrote:
September 13th, 2018, 6:50 am
the mod designers/creators may not be aware of their mod only working in MP. For example I made couple of mods, but it's first time I hear that the mods can be "designed" or "not designed" for multipplayer only... I have no idea how to make a mod appear in checkbox for campaign and i have no idea if my mods support it (would need to go read about it, if I was interested at this time of my life.. which i'm not unfortunately as i have no time for any modifications). Is it some new 1.14 thing? or...?
Yes, sp modifications are new in 1.14. Whether a modification is available in sp and/or mp is determined by [modification] type attribute (possible values being sp, mp, hybrid).

gfgtdf
Developer
Posts: 1105
Joined: February 10th, 2013, 2:25 pm

Re: Mods not appearing in any campaigns

Post by gfgtdf » September 13th, 2018, 10:25 am

the most important thing to make your mod work in singleplayere is to not put it inside #ifdef MULTIPLAYER
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.

tafm1803
Posts: 4
Joined: September 12th, 2018, 6:02 pm

Re: Mods not appearing in any campaigns

Post by tafm1803 » September 13th, 2018, 12:44 pm

Thanks for the advice guys, I'll go annoy some mod devs, politely. :P

tafm1803
Posts: 4
Joined: September 12th, 2018, 6:02 pm

Re: Mods not appearing in any campaigns

Post by tafm1803 » October 8th, 2018, 11:09 am

Just an update, I talked to the dev of most of them (it was the same guy), and he said it would be a lot of trouble for him to make his mods SP compatible. Thanks for the help, sorry for the trouble.

Post Reply