Mac animation bug?

Having trouble with the game? Report issues and get help here. Read this first!

Moderators: Forum Moderators, Developers

Forum rules
Before reporting issues in this section, you must read the following topic:

Mac animation bug?

Postby IIIO_METAL » May 19th, 2017, 1:03 pm

In the Japanese environment of Mac OS X, in 1.13.6 and 1.13.7 it seems that animation setting 'direction' as animation is ignored. For example, even though "Spearman" moves north, it still faces the front. Attack animation will be replaced with animation without direction setting. This problem is common to all applicable units.

It worked normally in windows. Are there other people who encountered this problem?
Creator of Mountain Witch
User avatar
IIIO_METAL
 
Posts: 53
Joined: January 18th, 2017, 5:03 pm
Location: japan

Re: Mac animation bug?

Postby Lord-Knightmare » May 19th, 2017, 2:15 pm

I use a late-2015 MacBook Pro to run Wesnoth. The bug doesn't occur in my case.
User avatar
Lord-Knightmare
Forum Regular
 
Posts: 1063
Joined: May 24th, 2010, 5:26 pm
Location: Somewhere in the depths of Irdya, gathering my army to eventually destroy the known world.

Re: Mac animation bug?

Postby zookeeper » May 19th, 2017, 9:43 pm

IIIO_METAL wrote:Attack animation will be replaced with animation without direction setting.

What does the above mean? Please describe what you see in more detail.
User avatar
zookeeper
WML Wizard
 
Posts: 9514
Joined: September 11th, 2004, 10:40 pm
Location: Finland

Re: Mac animation bug?

Postby IIIO_METAL » May 20th, 2017, 3:00 am

I do not know how to log an error log, so I will explain the situation displayed on the game screen.

Operating environment: Mac mini (Late 2012) 2.3 GHz Intel Core i 7, OS X 10.11.6 Japanese environment
Wesnoth: 1.13.7

An example in which animation of the unit malfunctions.
"Direction = s, se, sw" and "direction = n, ne, nw" are found in "standing_anim" of "Spearman".
"Spearman" which appears at the beginning of the campaign "The South Guard" start scenario should play animation of "direction = n, ne, nw", but in Mac OS X it is "direction = s, se, sw" .

I will attach a screenshot at the start of "The South Guard".
Spoiler:

Also, those with "direction" used in [attack_anim] will not work. When "Spearman" attacks with spear, the animation of javelin is used.
Other units that use "direction" for animation also cause the same phenomenon.
Creator of Mountain Witch
User avatar
IIIO_METAL
 
Posts: 53
Joined: January 18th, 2017, 5:03 pm
Location: japan

Re: Mac animation bug?

Postby zookeeper » May 20th, 2017, 7:20 am

IIIO_METAL wrote:An example in which animation of the unit malfunctions.
"Direction = s, se, sw" and "direction = n, ne, nw" are found in "standing_anim" of "Spearman".
"Spearman" which appears at the beginning of the campaign "The South Guard" start scenario should play animation of "direction = n, ne, nw", but in Mac OS X it is "direction = s, se, sw" .

I will attach a screenshot at the start of "The South Guard".

In that particular case, the direction that unit faces is random each time, so it could just be that.

IIIO_METAL wrote:Also, those with "direction" used in [attack_anim] will not work. When "Spearman" attacks with spear, the animation of javelin is used.
Other units that use "direction" for animation also cause the same phenomenon.

Really? If you attack with, say, a Dwarvish Thunderer's melee attack, you (sometimes?) see the thunderstick animation instead? What happens when you attack with the thunderstick?

I'm not saying it can't be happening, since I can't actually test it myself, but it does sound quite... extraordinary.
User avatar
zookeeper
WML Wizard
 
Posts: 9514
Joined: September 11th, 2004, 10:40 pm
Location: Finland

Re: Mac animation bug?

Postby IIIO_METAL » May 20th, 2017, 8:29 am

Hello, zookeeper.
I will write a result of observation a little more.

All animations using "direction" seem to be affected.
Basically it seems that an animation with "direction" is judged not to have that setting and it is replaced with "image" specified by [unit_type].
[Movement_anim] normally reflects the "direction" of [standing_anim], but not Mac on that.
Even if "Spearman" moves to the north, he does not show his back.

Observing [attack_anim], it seems that [attack_anim] first described in [unit_type] will be adopted.
Even in that case, the frame on the unit side is ignored and only [missile_frame] appears to be valid.

I can not judge whether this phenomenon is due to a bug or personal environment.
I would like other Mac users to check.
Creator of Mountain Witch
User avatar
IIIO_METAL
 
Posts: 53
Joined: January 18th, 2017, 5:03 pm
Location: japan


Return to Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 8 guests