Under the Burning Suns

This is the place for discussing development of mainline campaigns, reporting bugs in them and providing overall feedback.

Moderators: Forum Moderators, Developers

Post Reply
quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 18th, 2005, 2:51 am

Thanks for the clarification Atilla. I do use the accelerated speed switch, which is why I didn't realize that the fake unit animation was proportional. I created an Ethereal Nightguant unit (don't worry, I'm not giving it to the undead side, that wouldf just be nasty) and I'll use that instead. That should fix the problem of moving so slowly through the rock. You can find the fixed version on the campaign server.

0.4.1 changelog:

scenario 7:
-fixed problem with nightgaunt moving so slowly through the cavewall terrain

philt
Posts: 1
Joined: May 18th, 2005, 5:10 pm

Campaign Server

Post by philt » May 18th, 2005, 5:11 pm

Quartex, Can you post the campaign to your website. I'm behind a firewall and can't access the campaign server.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Re: Campaign Server

Post by quartex » May 18th, 2005, 9:55 pm

philt wrote:Quartex, Can you post the campaign to your website. I'm behind a firewall and can't access the campaign server.
Phlit,
You'll find version 0.4.1 available to download from the website. Enjoy! :-)

http://members.lycos.co.uk/quartex/

scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott » May 19th, 2005, 12:54 am

quartex,
With 0.4 5/17/05, I get a game error when starting the game. Moving the binary path tag to the end of the config file fixes the error for me.
Hope springs eternal.
Wesnoth acronym guide.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 19th, 2005, 2:07 am

scott wrote:quartex,
With 0.4 5/17/05, I get a game error when starting the game. Moving the binary path tag to the end of the config file fixes the error for me.
Huh? Don't think I've ever had that bug. Technically I would put the [binary_path] command inside the #ifdef CAMPAIGN_DESERT block, except that I need to preload the images so that the desert hunter images appear in the difficulty selection menu.

Glad you fixed the problem, hope it doesn't cause you any more problems. Also you can upgrade to 0.4.1 to fix a few tiny bugs.

scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott » May 19th, 2005, 2:52 am

It's 0.9.2cvs, but I don't know why it would make a difference on one system and not another.
Hope springs eternal.
Wesnoth acronym guide.

scott
Posts: 5242
Joined: May 12th, 2004, 12:35 am
Location: Alexandria, VA

Post by scott » May 21st, 2005, 1:57 am

What's going on with this section of code from scenario 5? (It's 0.4.1)

Code: Select all


#if Normal diff (EASY)
{UNIT_T (Troll Whelp2) (Troll Reinforcements) 7 43 97}
{UNIT_T (Troll Whelp2) (Troll Reinforcements) 7 44 97}

#else

[unit]
	type=Troll Shaman
	description=Troll High Shaman
	x=42
	y=97
	side=7
	[modifications]
		{RESILIENT}
		{LOYAL}
	[/modifications]
	traits_description="resilient, loyal" 
[/unit]

#endif
Is the #if supposed to be a command or a comment? It's causing errors. Also, I replaced several hundred \n with \r. The \n shows up as a square box in an editor such as BBEdit. The game appears not to mind, but I just wanted to ask what are you doing to cause such a seemingly random mix? Do you press enter instead of return sometimes?
Hope springs eternal.
Wesnoth acronym guide.

zaimoni
Posts: 281
Joined: January 27th, 2005, 7:00 am
Location: Linn Valley, KS U.S.A.
Contact:

Post by zaimoni » May 21st, 2005, 1:50 pm

[/n vs. /r]
Sounds like a binary upload/download from Mac to Windows (or vice versa).

Good thing the game doesn't mind :D

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 21st, 2005, 2:14 pm

Thanks for catching that bug, scott. The code should look like this:

Code: Select all


{UNIT_T (Troll Whelp2) (Troll Reinforcements) 7 43 97} 
{UNIT_T (Troll Whelp2) (Troll Reinforcements) 7 44 97} 

#ifdef EASY
#else 

[unit] 
   type=Troll Shaman 
   description=Troll High Shaman 
   x=42 
   y=97 
   side=7 
   [modifications] 
      {RESILIENT} 
      {LOYAL} 
   [/modifications] 
   traits_description="resilient, loyal" 
[/unit] 

#endif 

The idea was that two trolls whelps appear on all difficulties, and the troll shaman comes back on Challenging and Hard difficulty.

/n is the newline character. I am using a mac, and writing my .cfg files using Textedit and saving them as textfiles, so I believe that the newline character is saved as a '/n' not a '/r'. But I'm not really sure. The problem must be with your text editor, BBEdit must be showing the invisible return characters. I doubt that Wesnoth cares which return/new line character the text file uses.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 21st, 2005, 2:56 pm

UTBS version 0.4.2 has been released. Just a few minor changes, most importantly fixing the above bug in scenario 5. In scenario 7 I wanted to make it a bit harder for the human messenger to escape. So there are now several sand dunes obstructing the dirt road leading north. And when the water pours out of the cave wall, the river and lake it forms is not much father south, so it actually has an effect on gameplay. (hopefully) Finally to make the the vengeful undead a bit harder, they now target the elves much more often than the human.

Unfortunately the campaign server is down right now, so I'd posting the update on my webpage for people to manually download instead. You can download it from:

http://members.lycos.co.uk/quartex/

0.4.2 changelog:

scenario 5:
-fixed bug with troll shamans bring back reinforcements in lava cave

scenario 7:
-made vengeful undead target elves more than humans
-changed map to add more sand dunes blocking dirt path running north
-changed flow of water, so it created a lake further south

emdot
Posts: 66
Joined: October 12th, 2004, 4:01 pm
Location: pl
Contact:

Post by emdot » May 24th, 2005, 10:50 am

Smaller problems with latest version:

1.
Holy Water in Harsh Sands

Should be placed where Bandits leader escapes/dies. Placing in fixed hex means
it can be hidden below unit and go unnoticed.

2.
When killing last loyalist unit from caves in Frying Pan after going to
fresh air it still triggers dialog about flooding water which has little sense.

Banned King
Posts: 6
Joined: April 29th, 2005, 11:55 am
Location: Canada

Post by Banned King » May 26th, 2005, 12:32 am

I downloaded the campaing "Under The Burning Sun" for Windows XP. I started up the campaing and it worked fine for a while, I got to the 5th level and then I started having problems. I found out that there are a few bugs and then I corected them. When I started Wesnoth up again it would not start. All it did was this:

wesnoth.exe has encountered a problem and needs to close. We are sorry for the inconvenience.

and gave me the option to send the error report...

Can somebody please help me? ?
Just another idea from Banned King...

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 27th, 2005, 2:26 am

Thanks emdot. I fixed the first problem, it does make sense for the holy water to appear on the hex where the leader is defeated. However I don't understand what your second problem in "Out of the Frying pan..." is. Which dialog about flooding water are you referring to?
emdot wrote:Smaller problems with latest version:

1.
Holy Water in Harsh Sands

Should be placed where Bandits leader escapes/dies. Placing in fixed hex means
it can be hidden below unit and go unnoticed.

2.
When killing last loyalist unit from caves in Frying Pan after going to
fresh air it still triggers dialog about flooding water which has little sense.

quartex
Inactive Developer
Posts: 2258
Joined: December 22nd, 2003, 4:17 am
Location: Boston, MA

Post by quartex » May 27th, 2005, 2:29 am

Banned King, sorry you're having trouble. I don't know why wesnoth is crashing for you on Windows XP. My suggestion is to backup your savefiles and delete the entire wesnoth application and preferences files. Then install a new clean version and download the latest version of UTBS from the campaign server. Hopefully this will solve your problems.

If you find bugs, please private message me or post them in this thread. I'd like to hear about them too.

torangan
Retired Developer
Posts: 1365
Joined: March 27th, 2004, 12:25 am
Location: Germany

Post by torangan » May 27th, 2005, 7:47 am

The crash using Windows is easy to understand - the Windows version still contains a bug which makes it choke on encountering the new translation tags.

Post Reply