first_scenario= breaks between 1.10 and 1.12 ?

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
User avatar
markm
Posts: 157
Joined: August 13th, 2008, 3:53 pm
Location: Halifax Nova Scotia Canada

first_scenario= breaks between 1.10 and 1.12 ?

Post by markm »

I started to prepare my UMC for 1.12, starting with the Between the Worlds campaign.

I got rid of whitespace in unit file names and ran wmllint, but when I try to load the campaign it says Unknown scenario: 00a_Who_are_you

I have not seen anything in the how to upgrade from 1.10 to 1.12 indicating that first_scenario works differently in 1.12 or needs to be at some different position within the _main.cfg in 1.12 so am not sure where to look next for clues as to why 1.12 cannot find that scenario.

However, I have not completely cleaned out all wmllint problems from the 1.10 side; on both 1.10 and 1.12 the error output, which I separate out using 2>lint.err, says:

Code: Select all

"units/space/Doctor.cfg", line 9: attempt to close empty scope at end of macro line 9
"units/space/Doctor.cfg", line 68: attempt to close empty scope at [/unit_type] line 68
"units/space/Doctor.cfg", line 9: attempt to close empty scope at end of macro line 9
"units/space/Doctor.cfg", line 68: attempt to close empty scope at [/unit_type] line 68
"units/space/Doctor.cfg", line 9: attempt to close empty scope at end of macro line 9
"units/space/Doctor.cfg", line 68: attempt to close empty scope at [/unit_type] line 68
"units/space/Doctor.cfg", line 9: attempt to close empty scope at end of macro line 9
"units/space/Doctor.cfg", line 68: attempt to close empty scope at [/unit_type] line 68
wmllint: spell check unavailable, install python-enchant to enable
The macros on/near line 9 are core macros. It is mysterious to me, but therefore might maybe relate to a user interface problem that is also mysterious to me, in which the damage value of a weapon in the sidepanel showing a unit shows up coloured sometimes, and doubled sometimes. I see this lately on Time Lad when he is in the paths of time scenario.

So I am thinking maybe somewhere seemingly unrelated to all this there must be an unclosed macro-definition or something like that. Maybe far into the past by the time the system gets to the doctor unit.

The doctor unit does start and end with [unit_type] and [/unit_type] so maybe something in that file must be macro-expanding into something that contains a [/unit_type] itself? Maybe without having a corresponding [unit_type} ahead of it? But they are all core macros...
Spoiler:
-MarkM-
Developing Between the Worlds campaign portmanteau.
Have you eaten today?

gfgtdf
Developer
Posts: 1215
Joined: February 10th, 2013, 2:25 pm

Re: first_scenario= breaks between 1.10 and 1.12 ?

Post by gfgtdf »

One error is clearly in this line:

Code: Select all

description= _ ""+{SPECIAL_NOTES}+(SPECIAL_NOTES_CURES}
markm wrote:but when I try to load the campaign it says Unknown scenario: 00a_Who_are_you
This is not a very informative error message, you should look into wesnoths stderr for a better error message.
Scenario with Robots SP scenario (1.11/1.12), allows you to build your units with components, PYR No preperation turn 1.12 mp-mod that allows you to select your units immideately after the game begins.

Post Reply