[Solved] 2 icons in a row one works other does not both core

The place to post your WML questions and answers.

Moderator: Forum Moderators

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
User avatar
markm
Posts: 157
Joined: August 13th, 2008, 3:53 pm
Location: Halifax Nova Scotia Canada

[Solved] 2 icons in a row one works other does not both core

Post by markm »

FOUND IT: There was another copy of the unit file, that had not had the icon added to it. Nothing like posting here to inspire one to find the problem/fix! :)

Wesnoth 1.10.7 (apt-get install on Ubuntu 14.04):

The Minor Illusionist unit in units/time in the Between the Worlds campaign carries two weapons, both of which are supposed to show mainline core icons:

Code: Select all

        [attack]
                name=short sword
                description= _ "short sword"
                icon=attacks/sword-human.png
                type=blade
                range=melee
                damage=5
                number=3
        [/attack]
        [attack]
                name=missile
                description= _ "missile"
                icon=attacks/magic-missile.png
                type=pierce
                range=ranged
                damage=7
                number=2
                [specials]
                        {WEAPON_SPECIAL_MAGICAL}
                [/specials]
        [/attack]
Both look fine in game except for the absence of the magic-missile.png icon.

What could do this without messing up more about the weapons than just that icon?

I thought maybe some other weapon in some other unit might not have a closing attack tag maybe but wouldn't that cause a lot more havok than only just the icon being missing?

So I am kind of at a loss as to what kind of thing could even theoretically cause this so don't know what to look for.

Grasping at straws I have been doing wmllint on not only that campaign but also all the user-area, I have even downloaded the campaign on another machine to make sure it is not some interaction with someone else's UMC entirely (which evidently it is not).

So basically what I am hoping for here is some kind of workable theory as to how this problem could be accomplished if we wanted to accomplish it, so I can then go look for some accidental deployment of whatever technique it might be that the experts think could be used to accomplish this weird thing of making one mainline core image appear but the other not...

Code: Select all

markm@Think32G:~/.local/share/wesnoth/1.10/data/add-ons/Between_the_Worlds/units/time$ locate sword-human.png
/home/markm/Downloads/wesnoth-1.8.6/data/core/images/attacks/greatsword-human.png
/home/markm/Downloads/wesnoth-1.8.6/data/core/images/attacks/sword-human.png
/usr/share/games/wesnoth/1.10/data/core/images/attacks/greatsword-human.png
/usr/share/games/wesnoth/1.10/data/core/images/attacks/sword-human.png
markm@Think32G:~/.local/share/wesnoth/1.10/data/add-ons/Between_the_Worlds/units/time$ locate magic-missile.png
/home/markm/Downloads/wesnoth-1.8.6/data/core/images/attacks/magic-missile.png
/usr/share/games/wesnoth/1.10/data/core/images/attacks/magic-missile.png
(I checked locate in case the sword was maybe inside the campaign thus maybe the campaign was not looking in core. Evidently it must be looking in core.)

To see the icon missing in game, pick Time Lord timeline, your character "Time Lad" is the Minor Illusionist in question. Need to skip/clickthrough bunch of dialog to get to point you can actually look at him but by then you also get to attack something with him to see the icon is missing in his weapon-choice dialogue as well as on the encyclopaedia lookup of the unit.

The same unit is also in the Galactic Era but not so easy maybe to actually get to see what the encyclopaedia there says about the unit as at least for me it has to appear in game before you can look it up. So I haven't seen yet whether the icon also fails to work in that Era package.

Update: I figured out how to pick the time faction in the Galactic Era in Multiplayer so my leader was the Minor Illusionist, he looks fine in the encyclopaedia there (clicking on his unit type in the display of him on right of screen. Haven't gotten him to battle yet to check his actual weapon pick but seems likely that too will turn out to be fine.

-MarkM-
Developing Between the Worlds campaign portmanteau.
Have you eaten today?
Post Reply