Persistent side issue I'm having with 1.11.1

The place to post your WML questions and answers.

Moderators: Developers, Forum Moderators

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.

Persistent side issue I'm having with 1.11.1

Postby cephalo » December 29th, 2012, 2:46 am

In my Library of Kratemaqht campaign, there is a case where I need to keep a side persistent across a scenario where the side isn't being used. It works fine in 1.10, but in examining my saves for 1.11.1, my persistent side is carried over to the scenario where it is not used, but then in the following scenario where it is needed again, it is gone.

I tried setting side 1 to 'persistent=yes' in the scenario before the gap and then playing through, but the wiki says that player sides default to 'persistent=yes' anyway, and in any case it doesn't solve my problem as the side is still gone when I need it to pick up again.

What I would like to know is, is this a bug with 1.11.1, or is this behavior intended for some reason? Can I save a side in a variable? I need to find another way to do this if this is a permanent change.
cephalo
 
Posts: 112
Joined: December 20th, 2009, 4:37 pm

Re: Persistent side issue I'm having with 1.11.1

Postby Lord-Knightmare » December 29th, 2012, 11:56 am

I remember having solved a similar case in my campaign, but with two allied sides. At the start of a scenario where I had no need of them, I stored the leaders in variables and un-stored them after the level was completed. Hope that sheds some light to your problem. :)
User avatar
Lord-Knightmare
 
Posts: 774
Joined: May 24th, 2010, 5:26 pm
Location: Dhaka, Bangladesh

Re: Persistent side issue I'm having with 1.11.1

Postby Alarantalara » December 29th, 2012, 1:09 pm

It is likely the same issue that causes this bug: http://gna.org/bugs/?20373 so it should hopefully be fixed.
User avatar
Alarantalara
Mac OS X Packager
 
Posts: 749
Joined: April 23rd, 2010, 8:17 pm
Location: Canada


Return to WML Workshop

Who is online

Users browsing this forum: Exabot [Bot] and 2 guests