[player], [player] not supported at scenario toplevel

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
User avatar
SkyOne
Posts: 1310
Joined: January 3rd, 2009, 7:23 pm

[player], [player] not supported at scenario toplevel

Post by SkyOne »

Hi,

I have just encountered an error message, that I have never seen, on the replay of own Fate of a Princess campaign by running BfW 1.9.14 and 1.9.13.
It says: "<Invalid WML found> [player], [player] not supported at scenario toplevel".

It only shows on the replay of its scenario 25 during the first 20-25th turns, and disappears after that. Playing the scenario was just fine. Could anyone tell me what causes to the message even just a guess ? I am out of ideas so far because the [player] tag is not familiar to me. I mean that there is not a [player] tag in the entire campaign.

Thanks
Fate of a Princess/feedback thread: "What is in own heart that is the most important, not who you are."
Drake Campaign: Brave Wings/feedback thread, Naga Campaign: Return of the Monster, Saurian Campaign: Across the Ocean
Northern Forces - now on 1.12 server
Anonymissimus
Inactive Developer
Posts: 2460
Joined: August 15th, 2008, 8:46 pm
Location: Germany

Re: [player], [player] not supported at scenario toplevel

Post by Anonymissimus »

Did you make an addon-wide search for, perhaps, the string "player" ?
http://forums.wesnoth.org/viewtopic.php?f=21&t=35905&
projects (BfW 1.12):
A Simple Campaign: campaign draft for wml startersPlan Your Advancements: mp mod
The Earth's Gut: sp campaignSettlers of Wesnoth: mp scenarioWesnoth Lua Pack: lua tags and utils
updated to 1.8 and handed over: A Gryphon's Tale: sp campaign
Post Reply