First time WML'er (debug)

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
User avatar
1000hp
Posts: 14
Joined: July 11th, 2010, 1:22 am

First time WML'er (debug)

Post by 1000hp » July 29th, 2010, 12:53 am

I was wondering if someone could help me debug a really simple WML MP level. This is my first level ever and has little practical purpose besides for training me. The next one I will work on however, will be pretty cool. (More info later.)

I keep on getting the error that I am:

Missing closing tag for multiplayer at ~add-ons/Mountains\ and\ Sea\multi.cfg:1, value " at ~add-ons/Mountains\ and\ Sea\multi.cfg:31

Any help would be appreciated. :)
Mountain and Sea multi.cfg
The level I am working on. Just a simple MP level.
(13.48 KiB) Downloaded 115 times
Multiplayer Username: JV

User avatar
krotop
2009 Map Contest Winner
Posts: 433
Joined: June 8th, 2006, 3:05 pm
Location: Bordeaux, France

Re: First time WML'er (debug)

Post by krotop » July 29th, 2010, 1:22 am

You put a " at the beginning of the map_data key, but not at the end (after the terrain text).
Don't trust me, I'm just average player.
***
Game feedback for the Nightmares of Meloen
Art feedback by mystic x the unknown

User avatar
1000hp
Posts: 14
Joined: July 11th, 2010, 1:22 am

Re: First time WML'er (debug)

Post by 1000hp » July 29th, 2010, 2:12 am

I can tell i am getting closer but I still can't find a way to indent my map in text edit. (It goes all the way to the edge of the map instead of being slightly indented) Does anyone use text edit and know how to fix this problem?

Thanks krotop for you help. :D
Mountain and Sea multi.cfg
(13.46 KiB) Downloaded 100 times
Multiplayer Username: JV

monochromatic
Posts: 1549
Joined: June 18th, 2009, 1:45 am

Re: First time WML'er (debug)

Post by monochromatic » July 29th, 2010, 3:29 am

I'd definitely say move the map onto a different file and just call it in the scenario file. It's easier to manage especially if you decide to make a map change suddenly. A couple things to try:
step 1:
step 2:
step 3:
step 4:
step 5:
step 6:
Yeah::::
EDIT: Mistake. map-file-name.map, rather than .cfg.
Last edited by monochromatic on July 29th, 2010, 1:52 pm, edited 1 time in total.

User avatar
1000hp
Posts: 14
Joined: July 11th, 2010, 1:22 am

Re: First time WML'er (debug)

Post by 1000hp » July 29th, 2010, 4:22 am

Thanks a ton. :D

I will try that really soon.
Multiplayer Username: JV

User avatar
1000hp
Posts: 14
Joined: July 11th, 2010, 1:22 am

Re: First time WML'er (debug)

Post by 1000hp » July 31st, 2010, 4:06 pm

Alright now that I put the cfg. file and the map. file together in the same folder, the map file shows but not the other one.
Mountain and Sea multi.cfg
(848 Bytes) Downloaded 121 times
I have some screen shots that show what I have done with the file
Picture 2.png
Picture 1.png
Multiplayer Username: JV

User avatar
zookeeper
WML Wizard
Posts: 9740
Joined: September 11th, 2004, 10:40 pm
Location: Finland

Re: First time WML'er (debug)

Post by zookeeper » July 31st, 2010, 4:18 pm

Don't use spaces in the directory names or the .cfg filenames.

Also the game doesn't automatically look for any .cfg files inside add-on directories except for _main.cfg, which you don't have. Rename the file to _main.cfg and add #ifdef MULTIPLAYER at the top of the file and #endif at the bottom.

User avatar
1000hp
Posts: 14
Joined: July 11th, 2010, 1:22 am

Re: First time WML'er (debug)

Post by 1000hp » July 31st, 2010, 9:18 pm

Thanks for the help.

Good news. It is showing up in the map list again.

Bad news. It still says error.

I will try troubleshooting but if anyone has further advice that would be appreciated.
Attachments
_main.cfg
(858 Bytes) Downloaded 108 times
Multiplayer Username: JV

User avatar
zookeeper
WML Wizard
Posts: 9740
Joined: September 11th, 2004, 10:40 pm
Location: Finland

Re: First time WML'er (debug)

Post by zookeeper » July 31st, 2010, 9:44 pm

Well, this is definitely one of the most messed-up things I've ever seen:

Code: Select all

map_data="{~add-ons/Mountains_and_Sea.map/_Main.cfg}"
Just look at other add-ons to see how map includes are supposed to be written and where the map file is supposed to be.

User avatar
DEATH_is_undead
Posts: 960
Joined: March 4th, 2007, 3:00 pm
Location: Northern United States

Re: First time WML'er (debug)

Post by DEATH_is_undead » August 3rd, 2010, 7:18 pm

zookeeper wrote:Well, this is definitely one of the most messed-up things I've ever seen:

Code: Select all

map_data="{~add-ons/Mountains_and_Sea.map/_Main.cfg}"
Just look at other add-ons to see how map includes are supposed to be written and where the map file is supposed to be.
The map file also has to be renamed, add a '.map' at the end.

For map_data, zookeeper is talking about the map file, not the CFG file. The file with .map at the end.
3P MP Scenario - Great Dwarves Escape
The best way to learn is to follow. In order to learn WML, you have to follow other's work, and check their codes.

Post Reply