Illuminates [ability] trouble.

The place to post your WML questions and answers.

Moderators: Forum Moderators, Developers

Forum rules
  • Please use [code] BBCode tags in your posts for embedding WML snippets.
  • To keep your code readable so that others can easily help you, make sure to indent it following our conventions.
Post Reply
Nyxl
Posts: 25
Joined: February 12th, 2006, 6:21 pm
Contact:

Illuminates [ability] trouble.

Post by Nyxl » April 22nd, 2006, 12:43 pm

Hello there,

I'm currently dealing with an enigma regarding the "illuminates" ability. I have designed a custom unit that is supposed to be a level 4 Elvish Shyde, somewhat similar to Quartex's "Desert Star", though adapted to forest terrain, not sand.

I duplicated the "Elvish Shyde" [unit] and changed what needed to be changed. When it comes to the illuminates ability, I used the standard macro available in the ability.cfg file. Then I added the line

Code: Select all

halo=halo/white-cleric-aura.png
in the unit definition.

Upon testing, the halo does not show, though the ability is correctly listed (and works all right). It's not the first time I encounterd this mystery, since I tried to design a pure healer unit tree. At the time (three months ago), I gave up, but now I'd really like to add those custom units to my campaign, and can't seem to solve this...

Either I'm dumb, either I missed a subtlety in the ability WML...

In both cases, I'm eager to read your comments! :P

Edit :

Now I'm sure of it, I'm dumb! I found that my unit was still named "female^Elven Shyde" and replaced that by "female^Elvish Moonbeam". Upon reloading a saved game after clearing the cache, the halo appeared.

Post Reply