RPG AMLA Era for 1.10

It's not easy creating an entire faction or era. Post your work and collaborate in this forum.

Moderator: Forum Moderators

User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Nope, I need to test how would it work when played on multiple computers first (otherwise I risk that a possibility that it causes out of synch errors, theoretically, it should not, but who knows, a 5000 lines long (after the macro substitution, it is 24000 lines long!) event can do anything). And not everything was added yet. I mean... a few petty things, that I will add tonight. Can you log on the official server so that we could try how it works? I am there, and I will try to be there as much as possible tonight and tomorrow (approximately in the hours when you reply here). If it will fail, I will meet my brother and try it with his machine, but that won't be before the weekend and that would therefore mean another delay.
Last edited by Dugi on March 22nd, 2012, 4:52 pm, edited 1 time in total.
User avatar
masterofshadows
Posts: 15
Joined: November 22nd, 2011, 3:42 pm
Contact:

Re: RPG AMLA Era for 1.10

Post by masterofshadows »

One little bug found so far: when an unit kills a lvl 20 unit, you can only choose one time which upgrade (dmg, health, heal) you get. I couldn't choose the AMLA. Unit was on a side I droided while playing.
The help section in the game is a nice idea! You have all information, without an enormous info screen in startup. Nice work!
About the testing: It's about nine 'o clock down here, so I cannot try this evening. But I think tomorrow I will have the afternoon off, so we can try then, if you want.
Music4Life!
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

That problem looks like if it was rather something with the game than something with my mod. I have killed a level 20 unit, I got two AMLAs and then the unit was left with 75/24 exp. The only thing I can do with that is to lower the maximum level, I think 10 would be good, so it is capped at 10 now.

Tomorrow I have time from 16:00 to 17:00 and from 18:00 to 2:00. I live the same time zone than you.

Here is the complete version. The main change is that I added a lot of new attack icons for the new weapons. Not every weapon has its own icon, but it there is still enough of them. I also added the spreading fearie fire.

Just a funny note - the size of the add-on when unpacked increased by 650 KiBs, from which 300 KiBs is one new animation, 100 KiB are new weapon's icons, 100 KiB are new item's pictures, and 150 KiBs are all the changes I was writing for 99% of the time.
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

It is done.

It can be downloaded from the main server. Ready for feedback.
User avatar
francophone
Posts: 393
Joined: February 20th, 2010, 2:19 pm

Re: RPG AMLA Era for 1.10

Post by francophone »

loaded.
But it's going to be long test
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Ehm, have tested it with MasterOfShadows yesterday, and I have corrected the problem with multiplayer that we discovered. The final version that is supposed to work is on the server.

Sorry for the ambiguity of my posts.

But any discovery of a bug will be helpful, it is not too likely to be flawless.
User avatar
Drakefriend
Posts: 436
Joined: September 27th, 2009, 12:57 pm
Location: Wandering from one world to another
Contact:

Re: RPG AMLA Era for 1.10

Post by Drakefriend »

It would be nice to add the Orc Chieftain Line as a leader option with northerners; in this case, he should be able to select the Bloodlust ability of the Warlord, and maybe a "shamanic curse" (new attack similar to those of the shamans in SotBE).
PS: Bloodlust does not work.
After far too long an absence, I have returned.
According to the quiz 100% Silver Mage (85% Archmage, 75% Shyde, 67% Flameheart and Ancient Wose,58% Assassin, Troll Warrior and Berserker). And my top score is exactly how I see myself.
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Not a bad idea. I will introduce it.

EDIT: Problem fixed. The unit was not introduced yet and it was not uploaded yet neither.
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Done.

Version 2.01 is out.
Changes:

Code: Select all

Bloodlust now works
Added Orcish Ruler and Orcish Sovereign as possible leaders for Northerners
Added curse to Orcish Sovereign (pretty much line in SotBE)
Set Elvish Lord/High Lord and Orcish Ruler/Sovereign as default leaders
Warfall
Posts: 126
Joined: March 28th, 2009, 5:55 pm

AMLA

Post by Warfall »

Hi Dugi,

if you are the author / maintainer of the AMLA faction, it is time for me to say thank you.

I'm always using AMLA to first test a new map. In particular, i appreciate a lot the dwarf lord going out with 100% resistance against every weapons starting at turn 1 ! and this with a magical arcane or fire sword, the whole thing without spending too much money.

Sure, AMLA was probably never intended to be used with every maps, but what a nice way to cheat a map... for testing purpose only, obviously ;-)))
[I’ve moved this post from after post 565693, in “SX RPG ADD ON 4.7.2r - now on 1.10.x Server.”, to what I hope is the proper thread. — 8680]
Last edited by Warfall on July 6th, 2015, 2:53 pm, edited 1 time in total.
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Well, this era wasn't designed to work with SXRPG, if it doesn't glitch, it leads to inbalance. It was intended to work with survivals without heavy RPG additions like SurvivalExtreme.
Adrian160596
Posts: 2
Joined: December 13th, 2014, 5:53 pm

Re: RPG AMLA Era for 1.10

Post by Adrian160596 »

I dont know if you are still active, but Dugi I have to congratulate you for your awesome work with all your add-ons for BfW. I am pretty sure that you know that there is a new version for the game. And I dont know if im asking to much, but i love RPG AMLA Era and it would be awesome if you could make it work in version 1.12.
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

I am still alive.

I am of course aware that there is a new version, I have uploaded several add-ons there. However, I haven't ported RPG AMLA Era, because I had an impression that it wasn't played at all.

Years passed since I worked on this, and from then, I worked on a similar RPG system for my single player campaign that greatly developed many of the features. The idea of adding AMLA to level 3 units was ditched and replaced by an improvement, adding new units at the end of every advancement line (these units frequently have various new abilities and more elaborate AMLA; a few units and everything of the Drake faction is missing, though). I also made a large improvement regarding items. I haven't made any era out of these, mostly because of the few unit lines lacking the extra level unit with AMLA. I am planning to finish these few units and make something like an upgrated RPG AMLA Era from it, but I am not advancing much.

For now, you can try the add-on LotI-Mod (available on the 1.12 server, enable it and run it with Default Era), it does a similar thing but doesn't need to be an era. I haven't written it, but it's mostly a loader of my campaign's framework that extends the advacement lines and so on. I think that it's far more advanced that RPG AMLA Era.
Adrian160596
Posts: 2
Joined: December 13th, 2014, 5:53 pm

Re: RPG AMLA Era for 1.10

Post by Adrian160596 »

Well at least i played with it a lot. And i have tried almost every add-on you have uploaded (at least for a little time) but the best ones are LotI and RPG AMLA. And if I understand what you said, I will be waiting for the add-on.

And about the LotI-Mod I don't know if its just me but i haven't been able to find any gem, apparently neither I nor my enemies drop any. And just for you to know the feature I liked the most about your add-ons were the new units, it makes it more furn. Anyway good luck with your projects.

Pd: Sorry for my bad english
User avatar
Dugi
Posts: 4960
Joined: July 22nd, 2010, 10:29 am
Location: Carpathian Mountains
Contact:

Re: RPG AMLA Era for 1.10

Post by Dugi »

Well, better don't wait for it, I am currently quite busy and I will most likely not make it in the nearby future.

If you have some problems with LotI-Mod, ask its author about it. It's possible that he just set the gem drop chance to 0 or something for some reasons.
Post Reply