Design of the new web site

Discussion of all aspects of the website, wiki, and forums, including support requests and new ideas.

Moderators: Forum Moderators, Developers

Post Reply
LAZA
Posts: 26
Joined: October 13th, 2007, 9:52 am
Location: Winterhill, Swabia, Germany

Design of the new web site

Post by LAZA » July 18th, 2017, 6:07 pm

Hai @all,

i like the new and fresh design in the web site. :!:

But it causes two minor problems (at least on my end :whistle: ):

1. RSS feed is broken again

2. System requirements of the development version have no explanation about the foot notes:
"1024x768 or larger screen²" <--- we are talking about the "2" here, just to be sure

On the table of the stable versions there is the explation, on dev it is missing.

Thanks in advance
LAZA
Dell Precision T3500
-
* Manjaro Xfce 64 Bit - Testing *

User avatar
shadowm
Site Administrator
Posts: 6468
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Design of the new web site

Post by shadowm » July 18th, 2017, 8:27 pm

LAZA wrote:1. RSS feed is broken again
I’m not sure which feed you mean. The only (Atom, not RSS) feed for general news we have had for the past 4 years or so is the one associated to the News forum section: feed.php?f=62.
LAZA wrote:2. System requirements of the development version have no explanation about the foot notes:
"1024x768 or larger screen²" <--- we are talking about the "2" here, just to be sure

On the table of the stable versions there is the explation, on dev it is missing.
My mistake, the dev version doesn’t have any footnotes. It’s fixed now.

Thanks for the feedback!
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.
Elsewhere: shadowmBlogFollow me on Twitter

User avatar
SFault
Posts: 479
Joined: November 10th, 2009, 2:21 pm
Location: Esbo, Finland

Re: Design of the new web site

Post by SFault » July 19th, 2017, 5:09 am

The wesnoth style (traditional?) is missing from the forum settings. It's kinda sad since it really helped to show that I'm not just on some random forum but the mighty wesnoth site :cry:
segmentation fault
EBfW, GtR, Art, Old art

User avatar
Pentarctagon
Forum Administrator
Posts: 3485
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Design of the new web site

Post by Pentarctagon » July 19th, 2017, 7:11 am

SFault wrote:The wesnoth style (traditional?) is missing from the forum settings. It's kinda sad since it really helped to show that I'm not just on some random forum but the mighty wesnoth site :cry:
It was dropped now, since the forum software is eventually going to be upgraded from phpBB 3.0 to phpBB 3.2, at which point it would have had to have been dropped anyways.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

LAZA
Posts: 26
Joined: October 13th, 2007, 9:52 am
Location: Winterhill, Swabia, Germany

Re: Design of the new web site

Post by LAZA » July 19th, 2017, 7:02 pm

shadowm wrote:
LAZA wrote:1. RSS feed is broken again
I’m not sure which feed you mean. The only (Atom, not RSS) feed for general news we have had for the past 4 years or so is the one associated to the News forum section: feed.php?f=62.

I had the one from the website "wesnoth.org".
Was broken last year and now the address has changes.
Thanks.
LAZA wrote:2. System requirements of the development version have no explanation about the foot notes:
"1024x768 or larger screen²" <--- we are talking about the "2" here, just to be sure

On the table of the stable versions there is the explation, on dev it is missing.
My mistake, the dev version doesn’t have any footnotes. It’s fixed now.

Thanks for the feedback!
:thumpsup:
Dell Precision T3500
-
* Manjaro Xfce 64 Bit - Testing *

lea
Posts: 131
Joined: October 1st, 2016, 7:25 pm

Re: Design of the new web site

Post by lea » July 25th, 2017, 5:35 am

In old design of https://addons.wesnoth.org/1.12/ page I could hover mouse cursor over add-on's icon image to see its description in tooltip.
It does not work with new design - is it by design? Can anybody please confirm this loss of functionality to make sure it is not because of peculiarities of my PC?

Also there is a typo on https://addons.wesnoth.org/1.10/ page: its headers state that it is "Wesnoth 1.9 Add-ons List" - someone forgot to change the number when Wesnoth 1.10 lost its "beta" status?
author of: Altered Era/Ruleset (on add-ons servers for BfW 1.14, 1.12 and 1.10 )

User avatar
Pentarctagon
Forum Administrator
Posts: 3485
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Design of the new web site

Post by Pentarctagon » July 25th, 2017, 6:16 am

lea wrote:In old design of https://addons.wesnoth.org/1.12/ page I could hover mouse cursor over add-on's icon image to see its description in tooltip.
It does not work with new design - is it by design? Can anybody please confirm this loss of functionality to make sure it is not because of peculiarities of my PC?

Also there is a typo on https://addons.wesnoth.org/1.10/ page: its headers state that it is "Wesnoth 1.9 Add-ons List" - someone forgot to change the number when Wesnoth 1.10 lost its "beta" status?
What OS/browser are you using? It works for me:
Screenshot from 2017-07-25 01-13-11.png
The text right above the list of add-ons also says:
"Tip: Hover over the type field to see an explanation of the add-on type and over an icon to see a description for the add-on."
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
shadowm
Site Administrator
Posts: 6468
Joined: November 14th, 2006, 5:54 pm
Location: Chile
Contact:

Re: Design of the new web site

Post by shadowm » July 25th, 2017, 6:53 am

lea wrote:In old design of https://addons.wesnoth.org/1.12/ page I could hover mouse cursor over add-on's icon image to see its description in tooltip.
It does not work with new design - is it by design? Can anybody please confirm this loss of functionality to make sure it is not because of peculiarities of my PC?
You may need to force-refresh the cache using Ctrl+F5 if you’ve been there before.
lea wrote:Also there is a typo on https://addons.wesnoth.org/1.10/ page: its headers state that it is "Wesnoth 1.9 Add-ons List" - someone forgot to change the number when Wesnoth 1.10 lost its "beta" status?
Not a typo. The problem is that the script that generates that index is told to read the 1.9 add-ons server, which ended up becoming the 1.10 instance as well. I could add a special case to make it pretend 1.9 is 1.10 buuuut... EDIT: Okay, there you go.

And before anyone asks, nope, regenerating the listings for 1.8 and earlier is not practical because none of those add-ons server instances are running anymore, and the script needs an active connection to them. Several of them wouldn’t even compile on the server anymore.
Author of the unofficial UtBS sequels Invasion from the Unknown and After the Storm.
Elsewhere: shadowmBlogFollow me on Twitter

lea
Posts: 131
Joined: October 1st, 2016, 7:25 pm

Re: Design of the new web site

Post by lea » July 25th, 2017, 8:22 am

Pentarctagon wrote:What OS/browser are you using? It works for me:
your implicit assumption is confirmed: it works in newer version of my browser. false alarm )
shadowm wrote:You may need to force-refresh the cache using Ctrl+F5 if you’ve been there before.
it did not work for me, so I'll have to use newer browser for this feature or live without it
shadowm wrote:I could add a special case to make it pretend 1.9 is 1.10 buuuut... EDIT: Okay, there you go.
what about "buuuut..."? did you expect issues to arise from such a special case?
author of: Altered Era/Ruleset (on add-ons servers for BfW 1.14, 1.12 and 1.10 )

lea
Posts: 131
Joined: October 1st, 2016, 7:25 pm

Re: Design of the new web site

Post by lea » October 18th, 2017, 5:25 pm

SFault wrote:The wesnoth style (traditional?) is missing from the forum settings. It's kinda sad since it really helped to show that I'm not just on some random forum but the mighty wesnoth site :cry:
I agree...
author of: Altered Era/Ruleset (on add-ons servers for BfW 1.14, 1.12 and 1.10 )

Post Reply