Forum Upgrade

Discussion of all aspects of the website, wiki, and forums, including support requests and new ideas.

Moderators: Forum Moderators, Developers

User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Forum Upgrade

Post by Mist »

This stylesheet is a work in progress, there is at least on more update planned for it. The general aim is to unify mainpage, wiki and forums under a similar theme. As you can see by reading this thread feedback is noticed and acted upon.
Somewhere, between the sacred silence and sleep.
Disorder.

User avatar
Noyga
Inactive Developer
Posts: 1790
Joined: September 26th, 2005, 5:56 pm
Location: France

Re: Forum Upgrade

Post by Noyga »

The lack of contrast in some area does make reading less easy (through things improved) :
- Dark orange on light orange (the location in the header and the name of the poster in particular)
- Orange "new post" icon over an orange background

Also keep in mind that the human eye is the most sensible to yellow, so these kind of colors may wear a little faster the eyes. It may not be a problem if there is enough contrast on the information you read.

There is probably some waste of space in the header (it would reduce a little scrolling).
Btw more space under the thread title would probably be nice.

It looks nice visually but there still some work to make it as readable as was the previous version of the forum.
"Ooh, man, my mage had a 30% chance to miss, but he still managed to hit! Awesome!" ;) -- xtifr

vicza
Posts: 238
Joined: January 16th, 2008, 11:40 pm
Location: Moscow

Re: Forum Upgrade

Post by vicza »

When I try to answer in "Campaign Feedback" forum, I don't see neither smiles panel nor toolbar. Nor they work when I try to insert some tags (like [ b ] ) manually. Why?

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Forum Upgrade

Post by AI »

One thing I just noticed is that "post read" status doesn't carry over by account, but by cookie/IP.

In other words, every post that I've read on my other computer since I last used this one (almost a week ago) is unread on this one.

It's kind of annoying.

User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Forum Upgrade

Post by Mist »

It has to stay this way for now, there were some serious problems with database load we are causing at ibiblio and we decided to move as much weight away from database server as possible. Handling read history by cookies cuts out quite a lot of SQL, it might or might not change according to feedback from server admins over the next few weeks.
Somewhere, between the sacred silence and sleep.
Disorder.

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Forum Upgrade

Post by AI »

Unfortunately this isn't the only thing.

1. Forum is marked read
2. Someone posts in said forum
3. Forum is marked unread
4. I read the post
5. Forum is still marked unread, even though all threads in it are marked read

Only "mark all threads as read" fixes this.

UPDATE: it even does so on my own posts...

vicza
Posts: 238
Joined: January 16th, 2008, 11:40 pm
Location: Moscow

Re: Forum Upgrade

Post by vicza »

vicza wrote:When I try to answer in "Campaign Feedback" forum, I don't see neither smiles panel nor toolbar. Nor they work when I try to insert some tags (like [ b ] ) manually. Why?
Sorry about repeating my question, but the problem persists. Someone of moderators has answered me in that thread: "You disabled them manualy when submiting the post. Disable BBcode and Disable smiles was toggled on". But that is not so. You can see at the picture, I cannot neither disable nor enable anything. But only in that sub-forum, "campaign feedback", in others, like this one, for example, I can see both smiles and toolbar. Maybe, it's connected somehow with restrictions in that forum -- users can't create themes etc?
Attachments
nobbcode.PNG
nobbcode.PNG (20.67 KiB) Viewed 1684 times

User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Forum Upgrade

Post by Mist »

Okay, that should be fixed now. Someone tweaked the settings for that forum and the result was slightly to restrictive.
Somewhere, between the sacred silence and sleep.
Disorder.

vicza
Posts: 238
Joined: January 16th, 2008, 11:40 pm
Location: Moscow

Re: Forum Upgrade

Post by vicza »

Mist wrote:Okay, that should be fixed now. Someone tweaked the settings for that forum and the result was slightly to restrictive.
Yes, thanks, it works now.

User avatar
Mist
Inactive Developer
Posts: 753
Joined: February 15th, 2007, 8:44 am
Location: Milton Keynes, UK

Re: Forum Upgrade

Post by Mist »

I've now resurected just under a thousand missing attachments that did not make the move originaly. If any art is still missing I need to be pointed to each single case for further investigation.
Somewhere, between the sacred silence and sleep.
Disorder.

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Forum Upgrade

Post by AI »

The "pages read" problem seems to be getting worse, or maybe this is a part of it I hadn't noticed yet.

At 2300 at the 16th, I had read every post, marked all forums as read and all that.
I come back today using the same computer and browser as yesterday, and posts as far back as the 12th have been marked unread again.

It is becoming extremely annoying.

User avatar
anakayub
Moderator Emeritus
Posts: 518
Joined: May 3rd, 2007, 12:44 pm
Location: Malaysia
Contact:

Re: Forum Upgrade

Post by anakayub »

Even before the forum upgrade I've made it a habit to memorize the last tread that I read in the "View new posts" section.

It's not to say that it isn't a problem; it's just one that I can tolerate. :)
Take a breath.

vicza
Posts: 238
Joined: January 16th, 2008, 11:40 pm
Location: Moscow

Re: Forum Upgrade

Post by vicza »

AI wrote: I come back today using the same computer and browser as yesterday, and posts as far back as the 12th have been marked unread again.

It is becoming extremely annoying.
I agree. It annoys me too.

User avatar
Noyga
Inactive Developer
Posts: 1790
Joined: September 26th, 2005, 5:56 pm
Location: France

Re: Forum Upgrade

Post by Noyga »

It looks that the read/unread indicator it bogus.

Something i don't understand is from the same computer :
1) yesterday when i did logon there was some "new" messages... OK
2) today when i did logon there was some "new" messages that weren't even "new" yesterday... WTF ?
"Ooh, man, my mage had a 30% chance to miss, but he still managed to hit! Awesome!" ;) -- xtifr

AI
Developer
Posts: 2394
Joined: January 31st, 2008, 8:38 pm

Re: Forum Upgrade

Post by AI »

That happened to me too, it seems pretty random, but happens especially when you change computers, browsers or mess up your cookies. To my complete surprise, the forums have worked perfectly for me today. No old posts, no read forums marked as unread and so on. (I found some wood before I even clicked reply)

Post Reply