Defense of the Marshal (MP Scenario) [Version: 1.2.2]

Discussion of all aspects of multiplayer development: unit balancing, map development, server development, and so forth.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
JW
Posts: 5046
Joined: November 10th, 2005, 7:06 am
Location: Chicago-ish, Illinois

Post by JW » June 8th, 2006, 4:42 pm

I thought he meant it turned them into the current creep, aka Goblin Spearman, Mudcrawler, Vampire Bat, etc.

alchemist
Posts: 16
Joined: June 14th, 2006, 7:42 pm

DoTM broken in 1.1.5

Post by alchemist » June 14th, 2006, 7:49 pm

DoTM is broken in 1.1.5... creeps only appear visible to 1st player, all other players do not see them (creeps are invisible).

Any ideas???

User avatar
turin
Lord of the East
Posts: 11662
Joined: January 11th, 2004, 7:17 pm
Location: Texas
Contact:

Post by turin » June 14th, 2006, 7:51 pm

I suspect every player has to have downloaded DotM for it to work.
For I am Turin Turambar - Master of Doom, by doom mastered. On permanent Wesbreak. Will not respond to private messages. Sorry!
And I hate stupid people.
The World of Orbivm

alchemist
Posts: 16
Joined: June 14th, 2006, 7:42 pm

Post by alchemist » June 15th, 2006, 2:54 pm

You misunderstand, I think. Even when all players have the DoTM map and era properly installed it does not work. Creeps remain invisible to all but 1st player.

Swordy
Posts: 110
Joined: June 10th, 2005, 8:38 am

Post by Swordy » June 15th, 2006, 7:20 pm

:(

i have no idea why such problem would occur... :roll:

alchemist
Posts: 16
Joined: June 14th, 2006, 7:42 pm

Post by alchemist » June 23rd, 2006, 2:49 pm

I and others really miss this map... is there any way I can help in the debugging of this problem? Maybe provide some errors or failure cases or logs?

Jew unit
Posts: 93
Joined: May 16th, 2006, 1:17 am
Contact:

Post by Jew unit » June 23rd, 2006, 5:33 pm

alchemist wrote:I and others really miss this map... is there any way I can help in the debugging of this problem? Maybe provide some errors or failure cases or logs?
I too really miss this and Am more then willing to help if there is a way i can to fix this
2^x-1 mod x

Free
Posts: 82
Joined: October 30th, 2005, 1:51 am

Post by Free » June 24th, 2006, 5:02 am

Would the problem be fixed if someone had an older copy of DOTM?

User avatar
Para
Posts: 38
Joined: February 8th, 2006, 12:16 am

Post by Para » June 24th, 2006, 9:47 pm

I too would like to see a fix...

Swordy
Posts: 110
Joined: June 10th, 2005, 8:38 am

Post by Swordy » June 26th, 2006, 8:42 am

Thanks guys :)
You've already helped me by finding this bug. But to help me fix the bug, you must know WML and its engine well. If you do, I'd appreciate your help very much!

I don't think older version would work either.

So Wesnoth 1.1.7 is out... we shall see if the problem will still occur in the new version. If it does, I'm gonna seek help from sapientx or Tomsik.

User avatar
Para
Posts: 38
Joined: February 8th, 2006, 12:16 am

Post by Para » June 30th, 2006, 9:08 pm

DOTM is still having issues in 1.17.

Same bugs as before with creeps not appearing to non host players and OoS errors related to this.

Swordy
Posts: 110
Joined: June 10th, 2005, 8:38 am

Post by Swordy » July 2nd, 2006, 5:15 am

Para wrote:DOTM is still having issues in 1.17.

Same bugs as before with creeps not appearing to non host players and OoS errors related to this.
yup, thanks. I've reported this as a bug at GNA (bug #6277).

Yogibear
Retired Developer
Posts: 1086
Joined: September 16th, 2005, 5:44 am
Location: Hamburg, Germany

Post by Yogibear » July 3rd, 2006, 7:05 pm

This one is next on my list after fixing sounds playing in quick replays. I am not completely sure about it but i doubt if you can fix this bug with WML. It looks like there have been some changes to the processing of events inside the code. I will let you know if i find anything.
Smart persons learn out of their mistakes, wise persons learn out of others mistakes!

Swordy
Posts: 110
Joined: June 10th, 2005, 8:38 am

Post by Swordy » July 4th, 2006, 1:03 pm

Yogi Bear wrote:This one is next on my list after fixing sounds playing in quick replays. I am not completely sure about it but i doubt if you can fix this bug with WML. It looks like there have been some changes to the processing of events inside the code. I will let you know if i find anything.
thanks a lot! :)

Yogibear
Retired Developer
Posts: 1086
Joined: September 16th, 2005, 5:44 am
Location: Hamburg, Germany

Post by Yogibear » July 5th, 2006, 10:46 am

OK, i found it, it is a code problem: Side turns are not fired if it the side is set to AI. I wonder why that hasn't been discovered earlier since it should break some campaigns as well.

Anyway, i fixed it, it works and i will commit it soon to SVN (maybe tonight).

For all those unhappy windows users who don't know how to compile themselves: If there is going to be a substantial amount of time until the next release, i might be heavily tempted to upload a windows binary (only wesnoth.exe, not the whole rest) to sourceforge that puts you back in business again.

I will think of the definition of "substantial" later, after i checked on the release schedule 8) .
Smart persons learn out of their mistakes, wise persons learn out of others mistakes!

Post Reply