Deprecation Messages

Discussion of all aspects of the game engine, including development of new and existing features.

Moderators: Forum Moderators, Developers

Post Reply
User avatar
doofus-01
Art Contributor
Posts: 3834
Joined: January 6th, 2008, 9:27 pm
Location: land of small toilets, according to (impeached) dear leader.

Deprecation Messages

Post by doofus-01 »

Is there documentation on what the deprecation messages mean? I'm getting messages like
info deprecation: helper.child_range has been deprecated indefinitely.
(Note: You should use wml.child_range instead in new code)
But if I look at the wiki, it still mentions helper.child_range, says nothing about wml.child_range. Helper is deprecated, but will be supported indefinitely? Or is it deprecated for now, but might come back some day? Do I even want to try updating this, is it just a matter of changing "helper"->"wml", or does the whole thing need to be redesigned? So many questions...

Sorry if this is all spelled out somewhere (hopefully not a sticky topic right above this), but I didn't see it and didn't come up with immediately useful results in a search.
Thanks.
BfW 1.12 supported, but active development only for BfW 1.13/1.14: Bad Moon Rising | Trinity | Archaic Era |
| Abandoned: Tales of the Setting Sun
GitHub link for these projects

User avatar
Pentarctagon
Forum Administrator
Posts: 4127
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Deprecation Messages

Post by Pentarctagon »

The message is referring to point #1 from here.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
doofus-01
Art Contributor
Posts: 3834
Joined: January 6th, 2008, 9:27 pm
Location: land of small toilets, according to (impeached) dear leader.

Re: Deprecation Messages

Post by doofus-01 »

Thanks, that answers my questions, but will this be published somewhere? Two years old, and it's just hidden?
Attachments
Screenshot_20191019.jpg
BfW 1.12 supported, but active development only for BfW 1.13/1.14: Bad Moon Rising | Trinity | Archaic Era |
| Abandoned: Tales of the Setting Sun
GitHub link for these projects

User avatar
Pentarctagon
Forum Administrator
Posts: 4127
Joined: March 22nd, 2009, 10:50 pm
Location: Earth (occasionally)

Re: Deprecation Messages

Post by Pentarctagon »

I don't really know the history around that page or why it was never added anywhere, but I've now put a link to it here, here, and here.
99 little bugs in the code, 99 little bugs
take one down, patch it around
-2,147,483,648 little bugs in the code

User avatar
doofus-01
Art Contributor
Posts: 3834
Joined: January 6th, 2008, 9:27 pm
Location: land of small toilets, according to (impeached) dear leader.

Re: Deprecation Messages

Post by doofus-01 »

That certainly covers it. Thanks.
BfW 1.12 supported, but active development only for BfW 1.13/1.14: Bad Moon Rising | Trinity | Archaic Era |
| Abandoned: Tales of the Setting Sun
GitHub link for these projects

User avatar
Celtic_Minstrel
Developer
Posts: 1574
Joined: August 3rd, 2012, 11:26 pm
Location: Canada
Contact:

Re: Deprecation Messages

Post by Celtic_Minstrel »

Also, I intend to eventually retire LuaWML page for documenting the Lua API (it would stay around but only document how to use the [lua] tag). The official location for Lua API documentation will be LuaAPI, which while a work-in-progress does at least cover nearly everything that has been renamed. Basically, if you can't find something documented in the regular place, try LuaAPI.
Author of The Black Cross of Aleron campaign and Default++ era.
Maintainer of Steelhive.

Post Reply