Search found 291 matches

by solsword
January 14th, 2009, 9:06 pm
Forum: Music & Sound Development
Topic: WML macros that group default songs by mood
Replies: 5
Views: 1708

Re: WML macros that group default songs by mood

Good points... I guess the macros really aren't useful given that anyone with the will to use them can just-as-easily code them themselves. I stick by my idea of a music-description file, though. Also, anyone is welcome to use the macros, and if it seems appropriate, I may post them as examples of M...
by solsword
January 14th, 2009, 8:28 pm
Forum: Music & Sound Development
Topic: WML macros that group default songs by mood
Replies: 5
Views: 1708

Re: WML macros that group default songs by mood

According to my understanding of WML (which is quite limited at this point), the CUE_* macros should work for switching music mid-scenario, while the MOOD_* macros change the playlist. So if you wanted immediate battle music you'd do {CUE_BATTLE}, and if you wanted that battle music to continue, you...
by solsword
January 14th, 2009, 7:20 pm
Forum: Music & Sound Development
Topic: WML macros that group default songs by mood
Replies: 5
Views: 1708

WML macros that group default songs by mood

Not sure if this should go here or in the WML forum, but it seems less technical, so I'm posting it here. I just started working on the first scenario of my first campaign, which is also my first work with WML, so I'm kinda jumping into things, but when I got to making the [music] tag, I noticed tha...
by solsword
January 14th, 2009, 1:37 am
Forum: Technical Support
Topic: SLOW Performance Issues: post here to report
Replies: 238
Views: 106681

Re: SLOW Performance Issues: post here to Help

So... I've found part of the problem, and it was completely on my end of things. As it turns out, not only am I running Ubuntu Hardy, I'm also running Compiz as my window manager. And, surprise-surprise, that causes some issues. Ultimately, I think that I was running at 1024x696 (I maximized the win...
by solsword
January 13th, 2009, 10:24 am
Forum: Technical Support
Topic: SLOW Performance Issues: post here to report
Replies: 238
Views: 106681

Re: SLOW Performance Issues: post here to Help

Update-- I just built 1.4.7 on the same machine, and tried the first mission of "The South Guard" campaign: no lag issues there. I tried the same mission on 1.5.7, and experienced mild lag issues (not as bad as the first two missions of "Legend of Wesmere", which have more units). I played for a cou...
by solsword
January 13th, 2009, 7:18 am
Forum: Technical Support
Topic: SLOW Performance Issues: post here to report
Replies: 238
Views: 106681

Re: SLOW Performance Issues: post here to Help

System is Ubuntu 8.04, 2.0 GB RAM, AMD Athlon 64-bit Dual Core 4400+ processor, 2.33 GB of swap I was using Wesnoth from the Ubuntu repos (1.4.4) until today, when I decided that I wanted to try the Legend of Wesmere campaign. I downloaded 1.5.7 source tarball, untarred it, and built it using "scons...