Search found 39 matches

by AssassinT90
June 29th, 2009, 7:12 am
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Oh, and after fixing that bug, the message at prestart worked.
Everything was black, but the characters talked to each other.
by AssassinT90
June 28th, 2009, 7:20 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Here you are: [event] name=start [message] speaker=Hogward message= _ "Orders, sir?" [/message] [message] speaker="Commander Joy" message= _ "We must kill those zombies, then we kill the survivors!" [/message] [message] speaker=Hogward message= _ "But sir, our orders were to...!" [/message] [messag...
by AssassinT90
June 28th, 2009, 6:55 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

the prestart event messages aren't working because when you use [message] with a filter, it checks to see if the unit exists. If the unit doesn't exist, Wesnoth assumes the unit is dead and doesn't display the message. It looks like when the code runs, side 1 doesn't have any units. No, it's not it...
by AssassinT90
June 28th, 2009, 6:29 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Thank you all! Another problem... Could you help me here? Messages: [message] side=1 type=Lieutenant message= _ "Orders, sir?" [/message] [message] side=1 type=General message= _ "We must kill those zombies, then we kill the survivors!" [/message] [message] side=1 type=Lieutenant message= _ "But sir...
by AssassinT90
June 27th, 2009, 9:08 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

@Exasperation: Thank you! @zookeeper: If I had placed a unit, it wouldn't spawn on the (x,y=)$x1,$y1, but somewhere near. I could fix it doing this: [event] name=die [filter] side=2 [/filter] [store_unit] variable=zombie [filter] x,y=$x2,$y2 [/filter] [/store_unit] {VARIABLE zombie.hitpoints $zombie...
by AssassinT90
June 27th, 2009, 8:37 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Hello, there! I just found another problem, I guess one of you can help me here: Effect code: [effect] apply_to=remove_specials [set_specials] [plague] id=plague [/plague] [/set_specials] [/effect] Full unit: [unit] type=Walking Corpse x={X} y={Y} name=$zname side={SIDE} variation=$zrace [modificati...
by AssassinT90
June 26th, 2009, 6:41 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

@melinath, zookeeper:
Your tips were very, very precious for me, thanks a lot.
by AssassinT90
June 26th, 2009, 4:41 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Hey, people(yes, that's me again), just a quick question: How could I access(I'm talking about variable manipulation)the damage of the "spear" weapon? Here's the stored unit: [unit] advances_to="Swordsman,Pikeman,Javelineer" alignment="lawful" alpha="256" attacks_left="0" cost="14" die_sound="human-...
by AssassinT90
June 26th, 2009, 3:00 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

@zookeeper: Thanks for pointing the mistakes.
@melinath: Thanks for translating zookeeper's words.
by AssassinT90
June 26th, 2009, 8:56 am
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

That's me(again???)! I found other two bugs and... I can't fix them. So, I came here to ask your worth opinions about where the bugs are and how to fix them. First bug: [if] not working? My variable $zname "isn't" working. What happens is that instead of displaying, for example, Strong Zombie, it di...
by AssassinT90
June 25th, 2009, 6:57 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

@zookeeper:
Hah! Sorry again for a such stupid question.
Thank you!
by AssassinT90
June 25th, 2009, 6:23 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

@Exasperation: Thank you! @Forum: {RANDOM 0,1} [unit] type=Walking Corpse x,y=2,1 name=$random [modifications] [effect] apply_to=zoc value=$random [/effect] [/modifications] [/unit] (Full event) [event] name=moveto [filter] canrecruit=yes x,y=3,1 [/filter] {RANDOM 0,1} [unit] type=Walking Corpse x,y...
by AssassinT90
June 25th, 2009, 4:58 pm
Forum: WML Workshop
Topic: Event trigger: Why didn't work?
Replies: 41
Views: 2699

Re: Event trigger: Why didn't work?

Hey, guys, could you help me here? First: Here's the event resume: [event] [set_variable] name=zombie rand=0,1,0 [/set_variable] {RANDOM 0,1,0,0,0,1,1} name=moveto [filter] canrecruit=yes x,y=3,1 [/filter] [message] message= "$zombie|" [/message] [message] message= "$random|" [/message] {CLEAR_VARIA...
by AssassinT90
June 25th, 2009, 7:43 am
Forum: WML Workshop
Topic: how can I make names for a specific unit type?
Replies: 16
Views: 1404

Re: how can I make names for a specific unit type?

@zookeeper, melinath:
Thank you(again)!
by AssassinT90
June 24th, 2009, 3:10 pm
Forum: WML Workshop
Topic: how can I make names for a specific unit type?
Replies: 16
Views: 1404

Re: how can I make names for a specific unit type?

Code: Select all

[unstore_unit]
        variable=unit
        find_vacant=no
[/unstore_unit]
I'm wondering about why that is code useful. Already read its([unstore_unit]) effect, but couldn't understand well. Could somebody make it clear?