Search found 11 matches

by Vonkex
July 20th, 2017, 7:34 pm
Forum: WML Workshop
Topic: Item problem
Replies: 4
Views: 570

Re: Item problem

I have entered the filter example page and i didn't found the nor tag, i misread the tag.
by Vonkex
July 20th, 2017, 7:33 pm
Forum: WML Workshop
Topic: Item problem
Replies: 4
Views: 570

Re: Item problem

The first problem I spotted is "[nor]"... that is not a valid tag. Only use tags that are documented in the WML Reference as existing. What is does is if a unit moves over the item it doesn't pick it up. Could you explain what you are trying to do more clearly? Provide a detailed example of what yo...
by Vonkex
July 20th, 2017, 1:37 am
Forum: WML Workshop
Topic: Item problem
Replies: 4
Views: 570

Item problem

I have troubles with creating an "effect". What is does is if a unit moves over the item it doesn't pick it up. I made it work in one occasion but then i added another event and it stopped working. Here is the other event and the item part: [event] name=moveto first_time_only=yes [filter] side=1 x=5...
by Vonkex
July 19th, 2017, 1:15 am
Forum: WML Workshop
Topic: Adding an item
Replies: 2
Views: 372

Re: Adding an item

I think you might need to take another look at whatever cfg files you used as examples. [event] can't be used like that, period - other tags go inside the [event] tag, not the other way around(for the most part). The [if] tag can only be used with conditional tags , and the [then] tag goes inside t...
by Vonkex
July 19th, 2017, 12:21 am
Forum: WML Workshop
Topic: Adding an item
Replies: 2
Views: 372

Adding an item

Well, I'm having troubles with adding items in my scenario. I have read cfg files everywhere, copied all the file and I have modified some lines but when I start the scenario the item appears but has no effects or it doesn't appear and pops up an error saying something that went wrong with lua and i...
by Vonkex
July 17th, 2017, 2:19 pm
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

Re: I cannot start my campaign

Now my question is if I have to make a scenario file from zero or use my scenario file from the editor folder because in the that folder, the scenario file has some lines showing some information about the location of stuff from the scenario. Here is the file from the editor folder: current_time=0 d...
by Vonkex
July 17th, 2017, 2:03 pm
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

Re: I cannot start my campaign

Shiki wrote:Is it main.cfg or _main.cfg? The game looks for _main.cfg.
I always name the files like this: "01_(name of the file)" but in this case the main file is "main.cfg" Now I noticed my error, thanks!!
by Vonkex
July 17th, 2017, 1:45 pm
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

Re: I cannot start my campaign

Do I have to have some special folders in my campaign one to start it correctly? or is it just enough with "maps" and "scenarios"?
by Vonkex
July 17th, 2017, 1:38 pm
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

Re: I cannot start my campaign

It might be a copy/paste error but there is no [textdomain] for the closing [/textdomain] I changed it but the campaign still doesn't appear in the camapign menu. Here is the main.cfg changed data: #textdomain wesnoth-The_Four_Seasons [textdomain] name="wesnoth-The_Four_Seasons" path="data/add-ons/...
by Vonkex
July 17th, 2017, 1:32 pm
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

Re: I cannot start my campaign

Can you also check to make sure you have your 01_Outum.cfg in your scenarios folder and that it's id=01_Outum. All the spelling and capitalization and stuff is easy enough to overlook; it tends to bleed together after awhile for some. Then if all those things are good and it still is messing up, co...
by Vonkex
July 17th, 2017, 3:14 am
Forum: WML Workshop
Topic: I cannot start my campaign
Replies: 9
Views: 1797

I cannot start my campaign

Well, I have invested several hours trying to make my own campaign just to play one scenario but I couldn't do it. The problem is that the campaign doesn't appear in the campaign menu. Firstly I tried coping the main.cfg file of "A simple campaign" to my own campaign folder and it worked. But then I...