Search found 188 matches

by someone
August 1st, 2011, 7:23 am
Forum: Faction & Era Development
Topic: Marvel/DC Era
Replies: 5
Views: 1718

Re: Marvel/DC Era

My brother and I are actually currently working on a Marvel Era of our own (That we don't intend to distribute of course). It is indeed a challenging project, but I've found it to be great learning experience, and fun too! I would strongly suggest learning WML and try something for yourself, even if...
by someone
July 5th, 2011, 6:03 pm
Forum: WML Workshop
Topic: Help coding 'ricochet' weapon special.
Replies: 10
Views: 1182

Re: Help coding 'ricochet' weapon special.

So, I tried reworking it using the [while] tag, and here's what I came up with: [event] name=attacker hits first_time_only=no [filter_attack] name=Energy Shield [/filter_attack] [clear_variable] name=shieldtargeta,shieldtargetb,ifhits [/clear_variable] [store_unit] [filter] x,y=$x2,$y2 [/filter] var...
by someone
July 5th, 2011, 4:13 pm
Forum: WML Workshop
Topic: Help coding 'ricochet' weapon special.
Replies: 10
Views: 1182

Re: Help coding 'ricochet' weapon special.

Can an [while] tag include an else tag?
by someone
July 4th, 2011, 8:40 pm
Forum: WML Workshop
Topic: Help coding 'ricochet' weapon special.
Replies: 10
Views: 1182

Re: Help coding 'ricochet' weapon special.

@Max: Do you think the loop is causing the error? I'm not sure how else to make it work.

@A Guy: How do I find the stderr.txt? I'm using a Mac btw.
by someone
July 4th, 2011, 11:29 am
Forum: WML Workshop
Topic: Help coding 'ricochet' weapon special.
Replies: 10
Views: 1182

Help coding 'ricochet' weapon special.

I'm trying to code a special attack for personal use, but I've run into an unknown problem in my code while trying to test it. The error details reads "Missing closing tag for tag unstore_unit" but as far I can tell that isn't the problem at all. The attack has a weapon special called rico...
by someone
October 10th, 2010, 9:51 pm
Forum: WML Workshop
Topic: Making units face the right way.
Replies: 0
Views: 398

Making units face the right way.

A while back I made this bit of code for a unit so it would face different directions when it was standing still: [standing_anim] direction=s start_time=0 [frame] duration=150 image=units/federation/enterprise-nxclass-s.png [/frame] [frame] duration=150 image=units/federation/enterprise-nxclass-s.pn...
by someone
August 16th, 2010, 2:44 am
Forum: Scenario & Campaign Development
Topic: Campaign: Expanding Wesnoth
Replies: 12
Views: 4373

Re: Campaign: Expanding Wesnoth

It's supposed to be impossible to beat. Did you notice you get a victory message instead of defeat? Maybe it needs to be more clear. Any ideas on making it more obvious?
by someone
July 31st, 2010, 7:01 pm
Forum: Scenario & Campaign Development
Topic: What new terrain would be Great for your UMC?
Replies: 51
Views: 11387

Re: What new terrain would be Great for your UMC?

I was thinking more along these lines:
Image
(ignore the red line)

But whatever you think works best, I'm fine with.
by someone
July 31st, 2010, 6:05 am
Forum: Scenario & Campaign Development
Topic: What new terrain would be Great for your UMC?
Replies: 51
Views: 11387

Re: What new terrain would be Great for your UMC?

How about a cave wall like terrain that's reddish-brown instead of black? This would be helpful for making natural walls in outside areas.
by someone
July 10th, 2010, 8:08 pm
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

That's it! Thanks. I couldn't the placed units, so instead I created a new side for the regular orcs.
by someone
July 10th, 2010, 7:13 pm
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

How can I fix it?
by someone
July 10th, 2010, 12:20 am
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

Except that I've given them movement for castle and cave wall, allowing them to move just fine. Also, the units DO move, but only if they can reach a village or attack that turn.
by someone
July 9th, 2010, 10:09 pm
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

Well, those units are doing just as their supposed to. I made them specifically for moving on cliffs:

Code: Select all

    [movement_costs]
        impassable=1
        castle=1
    [/movement_costs]
    [defense]
        impassable=50
    [/defense]
It's the regular unit that aren't moving.
by someone
July 9th, 2010, 7:09 pm
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

Nice catch with the Slayer. ;) Doesn't solve the problem, but I'm glad that was caught. I don't think having nothing for "recruit=" hurts anything. Just in case; Custom Units: #textdomain wesnoth-units [unit_type] id=Orcish Sharpshooter name= _ "Orcish Sharpshooter" race=orc imag...
by someone
July 9th, 2010, 6:54 pm
Forum: WML Workshop
Topic: Side not moving SOLVED
Replies: 14
Views: 2094

Re: Side not moving

I put that in after the problem began, to try to err... motivate them. It didn't work before that so it definitely is not the problem.